Results 1 to 4 of 4

Thread: samba: no permission for USB drives

  1. #1

    Default samba: no permission for USB drives

    I set up a samba server with several drives.
    everything works fine with an internal drive - ir can be accessed from win10.

    but when trying to access a drive that is connected via USB, I can see and select the drive from win10, but trying to connect results in a message that i don't have permision.
    the server settings for both, the internal drive nd the USB drive, are identical.

    does the USB drive need special settings?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: samba: no permission for USB drives

    Quote Originally Posted by suse_paul View Post
    I set up a samba server with several drives.
    everything works fine with an internal drive - ir can be accessed from win10.

    but when trying to access a drive that is connected via USB, I can see and select the drive from win10, but trying to connect results in a message that i don't have permision.
    the server settings for both, the internal drive nd the USB drive, are identical.

    does the USB drive need special settings?
    Can you show your working smb.conf and the mounted filesystems?
    Code:
    cat smb.conf
    Code:
    mount -a
    openSUSE Leap 15.1; KDE Plasma 5

  3. #3

    Default Re: samba: no permission for USB drives

    seems to work now.
    looks like samba couldn't follow a symbolik link of the exported drive. I thought I had tried that before. But I did as well an update.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,713
    Blog Entries
    1

    Default Re: samba: no permission for USB drives

    Glad you got it sorted. Thanks for the update.
    openSUSE Leap 15.1; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •