Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

  1. #1
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Leap boots up withe the proper time and date. Win 10 boots with proper time and date. Windows 7 boots woth proper date, but is behind by 6 or 7 hours(I forget which).
    I have added the 'RealTimeIsUniversal' registry entry and it is set to 1. It is a 64bit DWORD.
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  2. #2
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by Bill_L View Post
    Leap boots up withe the proper time and date. Win 10 boots with proper time and date. Windows 7 boots woth proper date, but is behind by 6 or 7 hours(I forget which).
    I have added the 'RealTimeIsUniversal' registry entry and it is set to 1. It is a 64bit DWORD in both Windows versions.
    I 'triple boot' Leap15.1, Win 10 and Win 7. I need Win 7 for some things that are very hard to do in Win 10 because of the MS take over OS attitude and rob resources.
    Boot sequence via Grub2:
    1- Leap 15.1
    2- Leap 15.1 Advanced
    3- Windows 10
    If I choose 3, I get a Windows boot menu:
    1- Windows 10
    2- Windows 7
    3 Leap(because I have not had the nerve to get rid of easyBCD).

    My problem is Leap, and Win 10 both start with correct times.
    Win 7 does not(it is behind about 6 or 7 hours, I forget which, I am in U.S. Central time zone)
    IIRC, I set the Leap clock using the 'hwclock' command line.

    Any suggestions?
    If I add Win 7 to the Grub2 menu, will that help?
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,235
    Blog Entries
    15

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Hi
    Go into the BIOS and check the time is set to UTC, then in Win7, just make sure the timezone is set to Central time...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,478
    Blog Entries
    2

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    A likely big hint of your misconfiguration is your error...
    Note that USA Central Time zone is offset 6 hrs, and Daylight Savings Time likely accounts for that extra hour.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,889
    Blog Entries
    3

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by tsu2 View Post
    ..., and Daylight Savings Time likely accounts for that extra hour.
    That should make it 5 hours, not 7 hours.

    Note that I am in the Central Time zone, and I have never seen 7 hours off.

    I don't have Windows 10 (I am avoiding it). Windows 7 seems to work fine with the registry setting to use UTC -- except that Window 7 at one time would set the time wrongly (1 hour off) when setting time from the Internet. I'm not sure if that has been fixed. My easy workaround for that was to tell Windows to never set time from the Internet. I allowed openSUSE to manage that synchronization.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by nrickert View Post
    That should make it 5 hours, not 7 hours.

    Note that I am in the Central Time zone, and I have never seen 7 hours off.

    I don't have Windows 10 (I am avoiding it). Windows 7 seems to work fine with the registry setting to use UTC -- except that Window 7 at one time would set the time wrongly (1 hour off) when setting time from the Internet. I'm not sure if that has been fixed. My easy workaround for that was to tell Windows to never set time from the Internet. I allowed openSUSE to manage that synchronization.
    You both are right, it wasn't 6-7 hours it was 5 between going from Leap to Win 7.

    But it gets weirder still.
    Leap is a constant as far as the time goes and always correct.
    If I close Leap and open Windows 10, then Win 10 has correct time(assuming it was correct at last shutdown/restart).
    If I close Leap and open Win 7, then its clock is 'advanced' the 5 hours. I haven't been able to solve that! SO I set the correct time, and reboot into Win 7 and it still is correct time.
    This is the really odd thing, If I close out Win 7 and boot into Win 10, it's clock is BEHIND the 5 or 6 hours.
    Both Windows are set the same. UTC-0600

    I can't find search information that say the 'triple boot' is the problem.
    That is why I was wondering if adding Windows 7 manually to the Grub2 menu might help this? Also taking out easyBCD from the Windows boot menu.
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  7. #7
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Go into the BIOS and check the time is set to UTC, then in Win7, just make sure the timezone is set to Central time...
    I looked at every option I could find in the BIOS menu(s).
    The BIOS in this old HP desktop doesn't have a specific UTC setting that I can find.
    The BIOS time and date are the only changeable options.
    Time in 24 hours format and can't be altered to 12 hour format (is that UTC?)
    Date in month/day/year format.
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,235
    Blog Entries
    15

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by Bill_L View Post
    I looked at every option I could find in the BIOS menu(s).
    The BIOS in this old HP desktop doesn't have a specific UTC setting that I can find.
    The BIOS time and date are the only changeable options.
    Time in 24 hours format and can't be altered to 12 hour format (is that UTC?)
    Date in month/day/year format.
    Hi
    Yes, that's the place to set UTC time...

    To check from linux run;

    Code:
    date&date -u
    
    Fri 04 Oct 2019 01:56:21 AM UTC
    Thu 03 Oct 2019 08:56:21 PM CDT
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by nrickert View Post

    I don't have Windows 10 (I am avoiding it). Windows 7 seems to work fine with the registry setting to use UTC -- except that Window 7 at one time would set the time wrongly (1 hour off) when setting time from the Internet. I'm not sure if that has been fixed. My easy workaround for that was to tell Windows to never set time from the Internet. I allowed openSUSE to manage that synchronization.
    I am trying to get back to Win 7, and rid of Win 10, but it is taking a lot of back and forth to get my things to Win 7.
    MY OPINION! Avoid Windows 10 at all costs! It is getting more sickening every day, and I am truly sorry I ever put it on this old HP desktop,
    But I need the both for now until I can find time to devote to removing Win 10 and hoping the Leap OS Prober will pick up on the change.
    Then again, I may be blooding my head by slam it into brick walls, and getting hings more balled up than they are at present.
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,235
    Blog Entries
    15

    Default Re: Triple Boot - Leap 15.1, WInows 10, Windows 7 - time synchronization problem

    Quote Originally Posted by Bill_L View Post
    I am trying to get back to Win 7, and rid of Win 10, but it is taking a lot of back and forth to get my things to Win 7.
    MY OPINION! Avoid Windows 10 at all costs! It is getting more sickening every day, and I am truly sorry I ever put it on this old HP desktop,
    But I need the both for now until I can find time to devote to removing Win 10 and hoping the Leap OS Prober will pick up on the change.
    Then again, I may be blooding my head by slam it into brick walls, and getting hings more balled up than they are at present.
    Hi
    It's pretty easy to turn all the carp off... kill of cortana with a few commands, delete all the extra stuff and should be good to go?

    What do you need to run in Windows, remember only a few more months for Win7....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •