Results 1 to 9 of 9

Thread: Issue with prime-select

  1. #1

    Exclamation Issue with prime-select

    When I run the command :

    Code:
    prime-select nvidia
    ,

    I received and issue with following text :


    Code:
    update-alternatives: --set needs <name> <path>
    
    
    Use 'update-alternatives --help' for program usage information.
    Driver configured: nvidia
    How can I fix this issue?

  2. #2
    Join Date
    Sep 2012
    Posts
    5,323

    Default Re: Issue with prime-select

    Quote Originally Posted by john_neo View Post
    How can I fix this issue?
    I'd start with installing nvidia drivers.

  3. #3

    Default Re: Issue with prime-select

    I have already installed Nvidia driver with this guide :

    HTML Code:
    https://en.opensuse.org/SDB:NVIDIA_drivers

  4. #4
    Join Date
    Sep 2012
    Posts
    5,323

    Default Re: Issue with prime-select

    Quote Originally Posted by john_neo View Post
    I have already installed Nvidia driver
    Show output of
    Code:
    LC_ALL=C update-alternatives --display libglx.so

  5. #5

    Default Re: Issue with prime-select

    The output of the follow command :


    Code:
    LC_ALL=C update-alternatives --display libglx.so
    is :

    Code:
    libglx.so - manual mode  link best version is /usr/lib64/xorg/modules/extensions/xorg/xorg-libglx.so
      link currently points to /usr/lib64/xorg/modules/extensions/xorg/xorg-libglx.so
      link libglx.so is /usr/lib64/xorg/modules/extensions/libglx.so
    /usr/lib64/xorg/modules/extensions/xorg/xorg-libglx.so - priority 50

  6. #6
    Join Date
    Sep 2012
    Posts
    5,323

    Default Re: Issue with prime-select

    Quote Originally Posted by john_neo View Post
    Code:
    libglx.so - manual mode  link best version is /usr/lib64/xorg/modules/extensions/xorg/xorg-libglx.so
      link currently points to /usr/lib64/xorg/modules/extensions/xorg/xorg-libglx.so
      link libglx.so is /usr/lib64/xorg/modules/extensions/libglx.so
    /usr/lib64/xorg/modules/extensions/xorg/xorg-libglx.so - priority 50
    You do not have complete nVidia driver. At least nvidia-glG0x package is missing (it provides nVidia GL/GLX implementation). Show output of
    Code:
    rpm -qa | grep -i nvidia

  7. #7

    Default Re: Issue with prime-select

    The output of follow command

    Code:
    rpm -qa | grep -i nvidia
    is :

    Code:
    nvidia-computeG05-435.21-19.1.x86_64nvidia-gfxG05-kmp-default-435.21_k5.2.11_1-19.1.x86_64
    kernel-firmware-nvidia-20190909-35.1.noarch
    x11-video-nvidiaG05-435.21-19.1.x86_64
    nvidia-glG05-435.21-19.1.x86_64

  8. #8
    Join Date
    Sep 2012
    Posts
    5,323

    Default Re: Issue with prime-select

    OK, this is suse-prime bug. Xorg in Tumbleweed supports server side GLVND and nVidia drivers do not use alternatives anymore. X server dynamically selects the correct implementation. I assume switching to nVidia actually works even though you got error message?

    Bug is cosmetic as far as I can tell - switching alternatives is not needed so it does not matter that it fails. You may consider opening bug report so it is not forgotten.

  9. #9
    Join Date
    Sep 2012
    Posts
    5,323

    Default Re: Issue with prime-select

    Actually with current Xorg in TW and drivers 435 suse-prime is likely not needed anymore, at least in its current form.

    Xorg changelog:
    Code:
    - added patches required for NVIDIA's PRIME render offload support,  which is available since release 435.xx:
    nVidia 435 readme:
    Code:
    __NV_PRIME_RENDER_OFFLOAD=1 vkcube
    __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | grep vendor
    http://us.download.nvidia.com/XFree8...eroffload.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •