Results 1 to 4 of 4

Thread: Probable conflict port 80

  1. #1

    Default Probable conflict port 80

    Hello to all
    a few days ago I installed xampp, and it worked fine.
    Yesterday I installed openHAB, but xampp doesn't want to know how to open and gives me the following errors:
    Code:
    localhost:/opt/lampp # sudo ./xampp startStarting XAMPP for Linux 7.3.9-0...
    XAMPP: Starting Apache.../opt/lampp/share/xampp/xampplib: riga 22: netstat: comando non trovato
    /opt/lampp/share/xampp/xampplib: riga 22: netstat: comando non trovato
    fail.
    XAMPP:  Starting diagnose... 
    XAMPP:  Sorry, I've no idea what's going wrong. 
    XAMPP:  Please contact our forum http://www.apachefriends.org/f/ 
    Last 10 lines of "/opt/lampp/logs/error_log":
    tail: impossibile aprire '/opt/lampp/logs/error.log' per la lettura: File o directory non esistente
    XAMPP: Starting MySQL.../opt/lampp/share/xampp/xampplib: riga 22: netstat: comando non trovato
    ok.
    /lib/lsb/init-functions: riga 8: /etc/rc.status: File o directory non esistente
    XAMPP: Starting ProFTPD...already running.

    log file:
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    [Wed Sep 25 19:42:49.220884 2019] [ssl:warn] [pid 24797] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Sep 25 19:42:49.220938 2019] [ssl:warn] [pid 24797] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Sep 25 19:42:49.221006 2019] [suexec:notice] [pid 24797] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
    [Wed Sep 25 19:42:49.255216 2019] [ssl:warn] [pid 24798] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Sep 25 19:42:49.255240 2019] [ssl:warn] [pid 24798] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Sep 25 19:42:49.255363 2019] [lbmethod_heartbeat:notice] [pid 24798] AH02282: No slotmem from mod_heartmonitor
    [Wed Sep 25 19:42:49.264772 2019] [mpm_prefork:notice] [pid 24798] AH00163: Apache/2.4.41 (Unix) OpenSSL/1.1.1c PHP/7.3.9 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
    [Wed Sep 25 19:42:49.264815 2019] [core:notice] [pid 24798] AH00094: Command line: '/opt/lampp/bin/httpd -E /opt/lampp/logs/error_log -D SSL -D PHP'
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs


    this is output of listen
    Code:
    luigi@localhost:~> sudo lsof -i -P -n | grep LISTEN[sudo] password di root: 
    cupsd       788    root    6u  IPv6  23967      0t0  TCP [::1]:631 (LISTEN)
    cupsd       788    root    7u  IPv4  23968      0t0  TCP 127.0.0.1:631 (LISTEN)
    httpd-pre  1050    root    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    mysqld     1111   mysql   20u  IPv4  26443      0t0  TCP 127.0.0.1:3306 (LISTEN)
    httpd-pre  1267  wwwrun    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    httpd-pre  1268  wwwrun    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    httpd-pre  1269  wwwrun    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    httpd-pre  1270  wwwrun    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    httpd-pre  1271  wwwrun    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    master     1444    root   13u  IPv4  29146      0t0  TCP 127.0.0.1:25 (LISTEN)
    master     1444    root   14u  IPv6  29147      0t0  TCP [::1]:25 (LISTEN)
    kdeconnec  1857   luigi   13u  IPv6  32898      0t0  TCP *:1716 (LISTEN)
    kdeconnec  2862    root   12u  IPv6  39777      0t0  TCP *:1717 (LISTEN)
    httpd-pre 16577  wwwrun    4u  IPv6  26383      0t0  TCP *:80 (LISTEN)
    java      16643 openhab   28u  IPv6 166315      0t0  TCP 127.0.0.1:8101 (LISTEN)
    java      16643 openhab   33u  IPv6 167011      0t0  TCP *:5007 (LISTEN)
    java      16643 openhab   45u  IPv6 166186      0t0  TCP 127.0.0.1:36911 (LISTEN)
    java      16643 openhab  251u  IPv6 166931      0t0  TCP *:8443 (LISTEN)
    java      16643 openhab  257u  IPv6 166933      0t0  TCP *:8080 (LISTEN)
    kdeconnec 21604    root   12u  IPv6 198850      0t0  TCP *:1718 (LISTEN)
    proftpd   29836  daemon    0u  IPv6 324027      0t0  TCP *:21 (LISTEN)
    luigi@localhost:~>


    what I don't understand is:
    1. usually xampp is localized as localhost - 127.0.0.1
    and works on door 80
    2. openhab is located on the physical address of my IP 192.168.xxx.xxx
    and works on port 8080
    Result localhost does not work, openhab works


    is a conflict possible on port 443?
    where can I find the files to change the settings

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,019
    Blog Entries
    2

    Default Re: Probable conflict port 80

    log file:

    Code:
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs
    [Wed Sep 25 19:42:49.220884 2019] [ssl:warn] [pid 24797] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Sep 25 19:42:49.220938 2019] [ssl:warn] [pid 24797] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Sep 25 19:42:49.221006 2019] [suexec:notice] [pid 24797] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
    [Wed Sep 25 19:42:49.255216 2019] [ssl:warn] [pid 24798] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Wed Sep 25 19:42:49.255240 2019] [ssl:warn] [pid 24798] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
    [Wed Sep 25 19:42:49.255363 2019] [lbmethod_heartbeat:notice] [pid 24798] AH02282: No slotmem from mod_heartmonitor
    [Wed Sep 25 19:42:49.264772 2019] [mpm_prefork:notice] [pid 24798] AH00163: Apache/2.4.41 (Unix) OpenSSL/1.1.1c PHP/7.3.9 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
    [Wed Sep 25 19:42:49.264815 2019] [core:notice] [pid 24798] AH00094: Command line: '/opt/lampp/bin/httpd -E /opt/lampp/logs/error_log -D SSL -D PHP'
    (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
    (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    AH00015: Unable to open logs


    The above are your errors and warnings...
    0.0.0.0 is the broadcast address, essentially trying to bind to all available addresses, not just a specified address, that is why it's conflicting with an already installed service bound to your localhost.
    The SSL certificate name only "should" match your server name for name resolution purposes. If the client machine has a way of matching the name in the URL to the location on your server, then the SSL certificate CN will work and won't throw an error in the web browser.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Probable conflict port 80

    News, I was trying to find something but the virtual machine got stuck, so I reset it and by magic localhost works.
    Now the problem is to open the graphical interface of xampp, so I could see the various conf files and try to correct any errors.
    In win everything is grouped in a single directory, in linux I have them scattered everywhere

    Graphic interface not run.....
    Code:
    localhost:/opt/lampp # sudo ./xampp panel
    Usage: xampp <action>
    
    
            start         Start XAMPP (Apache, MySQL and eventually others)
            startapache   Start only Apache
            startmysql    Start only MySQL
            startftp      Start only ProFTPD
    
    
            stop          Stop XAMPP (Apache, MySQL and eventually others)
            stopapache    Stop only Apache
            stopmysql     Stop only MySQL
            stopftp       Stop only ProFTPD
    
    
            reload        Reload XAMPP (Apache, MySQL and eventually others)
            reloadapache  Reload only Apache
            reloadmysql   Reload only MySQL
            reloadftp     Reload only ProFTPD
    
    
            restart       Stop and start XAMPP
            security      Check XAMPP's security
    
    
            enablessl     Enable SSL support for Apache
            disablessl    Disable SSL support for Apache
    
    
            backup        Make backup file of your XAMPP config, log and data files
    
    
            oci8          Enable the oci8 extenssion
    
    
            panel         Starts graphical XAMPP control panel
    
    
    localhost:/opt/lampp #

  4. #4

    Default Re: Probable conflict port 80

    waiting to resolve I created a php file and started it on localhost

    https://drive.google.com/file/d/1J7F...ew?usp=sharing

    as you can see there are always 2 errors

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •