Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Installation failed third party program

  1. #1

    Default Installation failed third party program

    Hello to all
    for work reason I should install this software on linux machine:
    OpenHAB.
    The manufacturer's web page contains various installation scenarios, but the one referring to openSuse is (in my opinion) obsolete.
    The problem it's here:
    Install OpenHABPrerequisites: YaST2 - zypper install yast2
    Open YaST -> Software -> Software Repositories and use Add to add https://dl.bintray.com/openhab/rpm-repo2/stable as additional repository, accept it’s key

    in my terminal:
    Loading repository data ...Reading installed packages ...
    'https://dl.bintray.com/openhab/rpm-repo2/stable' was not found in the package names. The search attempt for functionality is performed.
    Not find 'https://dl.bintray.com/openhab/rpm-repo2/stable'




    given that the manufacturer also stated that:this is a not yet finished tutorial, it only contains necessary information, I think the information is incorrect or the commands to execute are not well described.Do you think there could be a valid solution?

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,299

    Default Re: Installation failed third party program

    Quote Originally Posted by chiabgigi View Post


    in my terminal:
    Code:
    Loading repository data ...Reading installed packages ...
    'https://dl.bintray.com/openhab/rpm-repo2/stable' was not found in the package names. The search attempt for functionality is performed.
    Not find 'https://dl.bintray.com/openhab/rpm-repo2/stable'
    ???

    So did you successfully add the repository?

    Could you show the output of:
    Code:
    sudo zypper lr -d
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191118) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,589
    Blog Entries
    1

    Default Re: Installation failed third party program

    While I have no interest in using this software, in an effort to assist I added the 3rd-party repo with
    Code:
    zypper ar https://dl.bintray.com/openhab/rpm-repo2/stable openHAB
    then after updating and accepting/trusting the repo key, I then searched for openhab packages and got
    Code:
     # zypper se -s openhab
    Loading repository data...
    Reading installed packages...
    
    S | Name                   | Type    | Version | Arch   | Repository
    --+------------------------+---------+---------+--------+-----------
      | openhab2               | package | 2.4.0-1 | noarch | openHAB   
      | openhab2               | package | 2.3.0-1 | noarch | openHAB   
      | openhab2               | package | 2.2.0-1 | noarch | openHAB   
      | openhab2               | package | 2.1.0-1 | noarch | openHAB   
      | openhab2               | package | 2.0.0-1 | noarch | openHAB   
      | openhab2-addons        | package | 2.4.0-1 | noarch | openHAB   
      | openhab2-addons        | package | 2.3.0-1 | noarch | openHAB   
      | openhab2-addons        | package | 2.2.0-1 | noarch | openHAB   
      | openhab2-addons        | package | 2.1.0-1 | noarch | openHAB   
      | openhab2-addons        | package | 2.0.0-1 | noarch | openHAB   
      | openhab2-addons-legacy | package | 2.4.0-1 | noarch | openHAB   
      | openhab2-addons-legacy | package | 2.3.0-1 | noarch | openHAB   
      | openhab2-addons-legacy | package | 2.2.0-1 | noarch | openHAB   
      | openhab2-addons-legacy | package | 2.1.0-1 | noarch | openHAB   
      | openhab2-addons-legacy | package | 2.0.0-1 | noarch | openHAB
    Hope that helps.
    Last edited by deano_ferrari; 27-Sep-2019 at 12:58.
    openSUSE Leap 15.1; KDE Plasma 5

  4. #4

    Default Re: Installation failed third party program

    hi sorry, meanwhile I had docker installed.Here is output
    # | Alias | Nome | Abilitato | Controllo GPG | Aggiornamento | Priorità | Tipo | URI | Servizio---+-------------------------------------+-------------------------------------------+-----------+---------------+---------------+----------+--------+--------------------------------------------------------------------------------------+---------
    1 | http-download.opensuse.org-84de2da6 | openSUSE:Leap:15.1:Update | Sì | (r ) Sì | Sì | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/ |
    2 | openSUSE-Leap-15.1-1 | openSUSE-Leap-15.1-1 | No | ---- | ---- | 99 | rpm-md | cd:/?devices=/dev/disk/by-id/ata-VMware_Virtual_IDE_CDROM_Drive_10000000000000000001 |
    3 | repo-debug | Debug Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/d...15.1/repo/oss/ |
    4 | repo-debug-non-oss | Debug Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/d.../repo/non-oss/ |
    5 | repo-debug-update | Update Repository (Debug) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/u...leap/15.1/oss/ |
    6 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/u.../15.1/non-oss/ |
    7 | repo-non-oss | Repository Non-OSS | Sì | (r ) Sì | Sì | 99 | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/ |
    8 | repo-oss | Repository principale | Sì | (r ) Sì | Sì | 99 | rpm-md | http://download.opensuse.org/distrib...15.1/repo/oss/ |
    9 | repo-source | Source Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/...15.1/repo/oss/ |
    10 | repo-source-non-oss | Source Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/.../repo/non-oss/ |
    11 | repo-update | Repository principale degli aggiornamenti | Sì | (r ) Sì | Sì | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/oss |
    12 | repo-update-non-oss | Repository degli aggiornamenti (Non-Oss) | Sì | (r ) Sì | Sì | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/ |
    13 | sublime-text | Sublime Text - x86_64 - Stable | Sì | (r ) Sì | Sì | 99 | rpm-md | https://download.sublimetext.com/rpm/stable/x86_64 |
    luigi@localhost:~>



  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,589
    Blog Entries
    1

    Default Re: Installation failed third party program

    The repo is not present. Add it using zypper like I just did.
    openSUSE Leap 15.1; KDE Plasma 5

  6. #6

    Default Re: Installation failed third party program

    @deano_ferrari.....done

  7. #7

    Default Re: Installation failed third party program

    Make service permanent
    Code:
    systemctl  enable openhab2.service

    terminal:
    Failed to enable unit: Unit file openhab2.service does not exist.


    ***************

    besides then it says:
    Configure OpenHABConfiguration files can be found at /etc/openhab2/
    Put your desired admin-user to openhab group and allow openhab group to write to that directory:

    # usermod -a -G openhab _yourAdminUser_
    # chmod g+ws /etc/openhab2/*
    Reopen your SSH shell afterwards to apply this change.

    New files will be created with correct group but no write access for the group. Either you give the group individual file access, or you set up ACL (or a cronjob) to fix file permissions regularly.
    _yourAdminUser_: is my username?

    etc/openhab2:

    no directory or document exists in the / etc directory

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,589
    Blog Entries
    1

    Default Re: Installation failed third party program

    Your last two posts read like you've now managed to add the openHAB repo, but have not yet installed the openhab2 package yet. Do that with
    Code:
    sudo zypper in openhab2
    You may also want to install the 'openhab2-addons' package as well.

    After installing the software you can proceed with configuration.
    Last edited by deano_ferrari; 27-Sep-2019 at 15:50.
    openSUSE Leap 15.1; KDE Plasma 5

  9. #9

    Default Re: Installation failed third party program

    wow !! success.
    Thanks deano_ferrari (are you sure you are not Italian ?, lol).
    Run your instructions plus these:
    Code:
    sudo systemctl start openhab2.servicesudo systemctl status openhab2.service
    
    sudo systemctl daemon-reload
    sudo systemctl enable openhab2.service

    One thing:
    I could not install
    insserv-compat (needed for later making the service permanent)
    tanks

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,589
    Blog Entries
    1

    Default Re: Installation failed third party program

    Quote Originally Posted by chiabgigi View Post
    wow !! success.
    Thanks deano_ferrari (are you sure you are not Italian ?, lol).
    Sadly not. Did travel there for F1 event when working as an audio-visual engineer once.

    One thing:
    I could not install

    tanks
    Is it not installed already? Check with
    Code:
    zypper se -s insserv-compat
    openSUSE Leap 15.1; KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •