Results 1 to 6 of 6

Thread: Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

  1. #1

    Default Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

    Ich habe vor einiger Zeit texlive von meinem Rechner gelöscht, weil bei den updates mit "zypper dup" immer tausende von tex-paketen upgedated wurden, und ich tex nur sporadisch nutze.
    Heute wollte ich wiedermal ein update machen und auf einmal schlägt zypper vor die ca. 3000 tex-pakete wieder zu installieren!!
    Warum macht zypper das? Und noch wichtiger, wie kann ich zypper davon abhalten?
    Ich habe im yast-Software Modul bereits nach Paketen gesucht, die texlive benötigen, aber da wird nichts angezeigt.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,983
    Blog Entries
    14

    Default Re: Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

    Code:
    sudo zypper al texlive
    al = add lock
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

    thanks a lot Knurpht, that solved the problem. But still the question remains, why does zypper want to install texlive again, why do I need the "zypper al texlive"?

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,019

    Default AW: Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

    Weil evtl ein Paket ein "empfohlenes" Paket installieren möchte und du dies nicht abgestellt hast?
    Aus der /etc/zypp/zypper.conf:
    Code:
    ## Install soft dependencies (recommended packages)
    ##
    ## CAUTION: The system wide default for all libzypp based applications (zypper,
    ## yast, pk,..) is defined in  /etc/zypp/zypp.conf(solver.onlyRequires)  and it
    ## will per default install recommended packages. It is NOT RECOMMENDED to define
    ## this value here for zypper exclusively, unless you are very certain that you
    ## want zypper to behave different than other libzypp based packagemanagement software
    ## on your system.
    ##
    ## Valid values: boolean
    ## Default value: follow zypp.conf(solver.onlyRequires)
    ##
    # installRecommends = yes
    und damit systemweit aus der /etc/zypp/zypp.conf:
    Code:
    ##
    ## Whether only required packages are installed.
    ##
    ## Recommended packages, will not be regarded.
    ##
    ## Valid values: boolean
    ## Default value: false
    ##
    solver.onlyRequires = false

  5. #5

    Default Re: Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

    Nochmal danke für die Info. Mit "zypper search --recommends texlive |less" habe ich auch die Übeltäter identifiziert. Es sind "patterns-desktop-technical_writing" und "patterns-fonts-fonts_opt"

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,019

    Default AW: Warum will "zypper dup" texlive mit ca. 3000 Paktetn installieren?

    Und wegen solcher Unzulänglichkeiten deinstalliere ich alle Patterns nach einer Installation.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •