Results 1 to 2 of 2

Thread: arm-none-eabi-g++ missiing

  1. #1

    Exclamation arm-none-eabi-g++ missiing

    Hi, I'm cross compiling C/C++ programs from openSUSE to a Cortex M embedded system. I'm using Eclipse as my IDE and it complains that "arm-none-eabi-g++" can't be found. I have installed the "cross-arm-none-gcc9" rpm but it doesn't provide the program I'm missing. However, I see that there's "arm-none-eabi-gcc" and "arm-none-eabi-cpp". I checked this forums to find out if I need to install additional packages. Should I install another rpm or have Eclipse pointed to gcc (or cpp) instead of g++? I read in gcc's man page that g++ should be used when compiling a C++ program.


    I'm rather new to this and I apologize if this has been answered before. Any information is greatly appreciated.

    Regards,

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,397
    Blog Entries
    2

    Default Re: arm-none-eabi-g++ missiing

    I wrote the following Wiki page as a guide for finding files and packages...

    https://en.opensuse.org/User:Tsu2/Mi...s_Dependencies

    IIRC
    Although I haven't tried for that specific g++, in general the "cnf" command will find packages that contain x64 versions of g++.
    Yes, g++ is a different compiler than gcc

    If you try all the methods I describe and still can't locate your need, post again.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •