Results 1 to 10 of 10

Thread: gameing causes slow down and stutter

  1. #1

    Default gameing causes slow down and stutter

    ok so a lot of the time i have problems with gameing ide like to figure it out i have a asus tuf fx505dy laptop it has a ryzen 5 3550h cpu and a rx560x gpu. when i play games in steaam like bloodstained ritual of the night under proton for a while at random sometimes 5 minutes in sometimes its ovr a few hours. the fps will drop and then my audio stutters a lot and when i close the game it affects my entire laptop system wide everything from any other game i try and play to just desktop affects this lag wont go away. it even happens when i play some games or emulators like pcsx2 or dolphin or ppsspp dosent matter what it is. this problem dose not go away untill i reboot my laptop and even sometimes the whole laptop will freeze and ill see green bars on the screen with what looks like toher applications that have previously closed. i would like to fix this problem as soon as i can or find out how. please help me thank you.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,128
    Blog Entries
    15

    Default Re: gameing causes slow down and stutter

    Hi
    Have you set any amdgpu kernel boot options?

    Can you show the card info?

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: gameing causes slow down and stutter

    no i have not as far as i know
    Code:
    01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] [1002:67ef] (rev e5)
            Subsystem: ASUSTeK Computer Inc. Device [1043:17c1]
            Kernel driver in use: amdgpu
            Kernel modules: amdgpu
    --
    05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8] (rev c2)
            Subsystem: ASUSTeK Computer Inc. Device [1043:17c1]
            Kernel driver in use: amdgpu
            Kernel modules: amdgpu

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,128
    Blog Entries
    15

    Default Re: gameing causes slow down and stutter

    Quote Originally Posted by anubis2497 View Post
    no i have not as far as i know
    Code:
    01:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] [1002:67ef] (rev e5)
            Subsystem: ASUSTeK Computer Inc. Device [1043:17c1]
            Kernel driver in use: amdgpu
            Kernel modules: amdgpu
    --
    05:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Picasso [1002:15d8] (rev c2)
            Subsystem: ASUSTeK Computer Inc. Device [1043:17c1]
            Kernel driver in use: amdgpu
            Kernel modules: amdgpu
    Hi
    So you have dual AMD gpus, look at installing switcheroo-control, enable the service and then start your games with DRI_PRIME=1 or depending on your desktop can right click and use the secondary gpu (your RX560X device), here is my laptop with dual AMD gpu's;

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    
    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] [1002:9874] (rev ca)
        Subsystem: Hewlett-Packard Company Device [103c:81fe]
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu
    --
    04:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] [1002:6900] (rev 83)
        DeviceName: AMD Radeon (TM) R7 440M
        Subsystem: Hewlett-Packard Company Device [103c:81fe]
        Kernel driver in use: amdgpu
    
    systemctl status switcheroo-control.service
    
    ● switcheroo-control.service - Switcheroo Control Proxy service
       Loaded: loaded (/usr/lib/systemd/system/switcheroo-control.service; enabled; vendor preset: disabled)
       Active: active (running) since Sun 2019-09-22 21:31:46 CDT; 1min 29s ago
     Main PID: 1097 (switcheroo-cont)
        Tasks: 3 (limit: 4915)
       Memory: 956.0K
       CGroup: /system.slice/switcheroo-control.service
               └─1097 /usr/lib/switcheroo-control
    
    Sep 22 21:31:46 bert systemd[1]: Starting Switcheroo Control Proxy service...
    Sep 22 21:31:46 bert systemd[1]: Started Switcheroo Control Proxy service.
    
    vkmark
    
    =======================================================
        vkmark 2017.08
    =======================================================
        Vendor ID:      0x1002
        Device ID:      0x6900
        Device Name:    AMD RADV ICELAND (LLVM 8.0.1)
        Driver Version: 79695877
    
    DRI_PRIME=1 vkmark
    
    =======================================================
        vkmark 2017.08
    =======================================================
        Vendor ID:      0x1002
        Device ID:      0x6900
        Device Name:    AMD RADV ICELAND (LLVM 8.0.1)
        Driver Version: 79695877
    With switcheroo running as can be seen in the following, you can start applications with the dedicated card (well can on the GNOME DE);

    Last edited by malcolmlewis; 22-Sep-2019 at 19:46.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,128
    Blog Entries
    15

    Default Re: gameing causes slow down and stutter

    Hi
    My vkmark output is flawed (it uses the dGPU).... here is the glxinfo instead to show it working....

    Code:
    glxinfo |grep "OpenGL renderer"
    OpenGL renderer string: AMD CARRIZO (DRM 3.32.0, 5.2.14-1-default, LLVM 8.0.1)
    
    DRI_PRIME=1 glxinfo |grep "OpenGL renderer"
    OpenGL renderer string: AMD Radeon (TM) R7 M340 (ICELAND, DRM 3.32.0, 5.2.14-1-default, LLVM 8.0.1)
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: gameing causes slow down and stutter

    i tryed the switcheroo thing and it dosent make any difference i believe steam is already using the correct gpu but it is still doing this insane stutter thing how else could i track this down to fix it maybe?

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,128
    Blog Entries
    15

    Default Re: gameing causes slow down and stutter

    Quote Originally Posted by anubis2497 View Post
    i tryed the switcheroo thing and it dosent make any difference i believe steam is already using the correct gpu but it is still doing this insane stutter thing how else could i track this down to fix it maybe?
    Hi
    Could try a amdgpu kernel option, if you add the following to the kernel command line options via YaST Bootloader;

    Code:
    amdgpu.dc=0
    Can you also post the output from the following to see what is set with respect to options (just need the parmeter lines);
    Code:
    systool -vm amdgpu
    Ref: https://www.kernel.org/doc/html/latest/gpu/amdgpu.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: gameing causes slow down and stutter

    Code:
      Attributes:
        coresize            = "3985408"
        initsize            = "0"
        initstate           = "live"
        refcnt              = "29"
        srcversion          = "1404097CE1A9DA42A3AF6A4"
        taint               = ""
        uevent              = <store method only>
    
      Parameters:
        aspm                = "-1"
        audio               = "-1"
        bapm                = "-1"
        benchmark           = "0"
        cg_mask             = "4294967295"
        cik_support         = "0"
        cntl_sb_buf_per_se  = "0"
        compute_multipipe   = "-1"
        cwsr_enable         = "1"
        dc                  = "-1"
        dcfeaturemask       = "0"
        debug_largebar      = "0"
        deep_color          = "0"
        disable_cu          = "(null)"
        disp_priority       = "0"
        dpm                 = "-1"
        emu_mode            = "0"
        exp_hw_support      = "0"
        fw_load_type        = "-1"
        gpu_recovery        = "-1"
        halt_if_hws_hang    = "0"
        hw_i2c              = "0"
        hws_max_conc_proc   = "8"
        ignore_crat         = "0"
        ip_block_mask       = "4294967295"
        job_hang_limit      = "0"
        lbpw                = "-1"
        lockup_timeout      = "10000"
        max_num_of_queues_per_device= "4096"
        msi                 = "-1"
        ngg                 = "0"
        noretry             = "0"
        param_buf_per_se    = "0"
        pcie_gen2           = "-1"
        pcie_gen_cap        = "0"
        pcie_lane_cap       = "0"
        pg_mask             = "4294967295"
        pos_buf_per_se      = "0"
        ppfeaturemask       = "4294950911"
        prim_buf_per_se     = "0"
        ras_enable          = "-1"
        ras_mask            = "16383"
        runpm               = "-1"
        sched_hw_submission = "2"
        sched_jobs          = "32"
        sched_policy        = "0"
        sdma_phase_quantum  = "32"
        send_sigterm        = "0"
        si_support          = "0"
        smu_memory_pool_size= "0"
        test                = "0"
        virtual_display     = "(null)"
        vis_vramlimit       = "0"
        vm_block_size       = "-1"
        vm_debug            = "0"
        vm_fault_stop       = "0"
        vm_fragment_size    = "-1"
        vm_size             = "-1"
        vm_update_mode      = "-1"
        vram_page_split     = "512"

  9. #9

    Default Re: gameing causes slow down and stutter

    ok so bloodstained downloaded a new shader pre cache today and it has seemed to fix the problem the game runs fine now BUT ive noticed if my fps drops below 30 fps the system wide lag happens and wont fix untill i reboot is this an issue with dxvk?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,128
    Blog Entries
    15

    Default Re: gameing causes slow down and stutter

    Quote Originally Posted by anubis2497 View Post
    ok so bloodstained downloaded a new shader pre cache today and it has seemed to fix the problem the game runs fine now BUT ive noticed if my fps drops below 30 fps the system wide lag happens and wont fix untill i reboot is this an issue with dxvk?
    Hi
    So if you remove the amdgpu option from the bootloader, does it come back to normal fps? Can you also test the DRI_PRIME=1 option with the glxinfo as well?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •