Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Tearing in OpenSUSE KDE

  1. #1

    Question Tearing in OpenSUSE KDE

    Hello, I am a novice user and I realize there are not many descriptions in what I will talk about here. But I installed Tumbleweed here and inexplicably had tearing (no other distro occurred to me), can you give me instructions to solve the problem?: |

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,643
    Blog Entries
    3

    Default Re: Tearing in OpenSUSE KDE

    It is probably a video problem. If you have nvidia graphics, then you might try installing the nvidia drivers.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,700

    Default Re: Tearing in OpenSUSE KDE

    Before tainting your installation with non-free software, be sure it's already been optimized. In system (desktop) settings for hardware display & monitor compositor you may need to select a different option, e.g. OpenGL 3.1 instead of 2.0.

    If
    Code:
    cat /proc/cmdline
    includes nomodeset, then it hasn't been optimized. Please fetch the latest version of the inxi information gathering script and paste here, using code tags, output in Konsole from
    Code:
    inxi -GxxSza
    We may need also to see the entire content of /var/log/Xorg.0.log or ~/.local/share/xorg/Xorg.0.log, which you can upload to https://susepaste.org or http://pastebin.com and paste in here only the URL provided when you upload.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  4. #4

    Default Re: Tearing in OpenSUSE KDE

    Esqueci de comentar que não tem placa Nvidia, apenas Intel.

  5. #5

    Default Re: Tearing in OpenSUSE KDE

    Quote Originally Posted by mrmazda View Post
    Before tainting your installation with non-free software, be sure it's already been optimized. In system (desktop) settings for hardware display & monitor compositor you may need to select a different option, e.g. OpenGL 3.1 instead of 2.0.

    If
    Code:
    cat /proc/cmdline
    includes nomodeset, then it hasn't been optimized. Please fetch the latest version of the inxi information gathering script and paste here, using code tags, output in Konsole from
    Code:
    inxi -GxxSza
    We may need also to see the entire content of /var/log/Xorg.0.log or ~/.local/share/xorg/Xorg.0.log, which you can upload to https://susepaste.org or http://pastebin.com and paste in here only the URL provided when you upload.



    Hello, to output of commands it's is link:
    https://pastebin.com/F3R0dL4i

  6. #6
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,700

    Default Re: Tearing in OpenSUSE KDE

    Please do
    Code:
    sudo zypper in xdpyinfo
    sudo zypper rm xf86-video-intel
    then restart and paste here output from
    Code:
    inxi -GxxSCza
    inxi -V | head -n1
    and upload Xorg.0.log if it doesn't help the tearing.

    I have two Kaby Lake systems on which I've never observed tearing. Mine use the modesetting DDX, which is automatically enabled by Intel DDX removal.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  7. #7

    Default Re: Tearing in OpenSUSE KDE

    Try going into System Settings -> Display and Monitor -> Compositor and set "tearing prevention(vsync)" to "Full screen repaints" if that doesn't degrade performance for you.

  8. #8
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    179

    Default Re: Tearing in OpenSUSE KDE

    Should you decide to taint your system with those proprietary binary Nvidia blobs (like I did with my GTX 1050), the following config file has been proven helpful:
    Code:
    ~ ▶ cat /etc/X11/xorg.conf.d/80-nvidia.conf
    Section "Screen"
        Identifier "Screen0"
        Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
        Option "AllowIndirectGLXProtocol" "off"
        Option "TripleBuffer" "on"
    EndSection
    
    Section "Device"
      Identifier "Device0"
      Driver "nvidia"
      Option "ConnectToAcpid" "0"
    EndSection
    Just searched for »triplebuffer« and »forcefullcompositionpipeline« online and in my browser history, I’m pretty sure I’ve got those settings from devtalk.nvidia.com and the Arch-Linux Wiki. They proved effective independent from user account, desktop environment, web browser, game, editor, pager or other application.

    The only disadvantage seems to be a slight latency (2 to 3 frames; with 60fps this translates to 33ms to 50ms), arguably a problem for hardcore-competitive gamers, not a problem for me.

    Some Steam games seem to do their own thing. For example, Talos Principle, Firewatch and Alien Isolation run tear-free, not matter what; whereas Portal, Portal 2 and Lifeless Planet show tearing, especially when I toggle OpenGL compositing while playing the game. (Thanks to KDE/Plasma5/Kwin I can switch the compositor on an off any time; Kwin has a global keyboard shortcut named »Suspend Compositing« which I set to function key F15.)

    In case of Lifeless Planet and Firewatch it’s remarkable how they display different tearing behavior, considering both games are Unity3D-based.

  9. #9

    Default Re: Tearing in OpenSUSE KDE

    Guys, basically my machine settings are:
    Model: Acer Aspire 5 A515-51-51UX
    Processor: Intel Core i5-7200U 2.5Ghz Intel HD Graphics
    Memory: 8 GB DDR4
    Internal Storage: 1TB HDD
    (sorry if English is not clear, I'm using Google Translator)

  10. #10
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: Tearing in OpenSUSE KDE

    Tumbleweed, Xfce, Firefox, uBlock Origin

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •