Results 1 to 4 of 4

Thread: (Older) Feral games: SDL_RWseek version SUSE_2.0.10 not defined in file libSDL2-2.0.so.0

  1. #1
    Join Date
    Oct 2017
    Location
    Germany
    Posts
    27

    Default (Older) Feral games: SDL_RWseek version SUSE_2.0.10 not defined in file libSDL2-2.0.so.0

    Hey there I posted this earlier over in applications but I think this belongs here.

    I played a lot of Feral games on openSUSE Leap 13, 12, 42, 43, 15.0 and 15.1 and never had much issues except of some Ubuntu libraries distributed along side with the game causing problems on any other non Ubuntu Distro and probably newer Ubuntu releases too.
    All a head an issue with libcurl.so.4 which has a lot of dependencies issues because it tries to work along with openSUSE's libraries which just don't work quiet well.
    How ever fixing this is rather simple and a lot of community posts are out there covering this issue, you simply need to make a symlink to libcurl.so.4 from openSUSE and place it where the original libcurl.so.4 from that specific Feral game is placed.

    So but recently I tried to play some of the older games on Tumbleweed (Which I upgraded to to have more recent packages also for gaming purpose) but now facing the issue that (after the above fix) I ran into another one:
    Code:
    /z004/sdc1/user/vortex/Games/SteamLibrary/steamapps/common/Dawn of War 2/bin/DawnOfWar2: relocation error: /usr/lib64/libSDL2_image-2.0.so.0: symbol SDL_RWseek version SUSE_2.0.10 not defined in file libSDL2-2.0.so.0 with link time reference
    I ask the duck over on duckduckgo and found out, according to the SDL Wiki: SDL_RWseek() is actually a macro that calls the SDL_RWops's seek method appropriately, to simplify application development.
    So I assume that in the latest Tumblweed release of this library SDL_RWseek was simply dropped because it's a macro anyway?
    My question is can I fixes this on my own (with out recompiling stuff obviously) or would it be a better approach to contact the SLD maintainers for Tumbleweed on this issue?
    Or is the issue somewhere else?

    Furthermore I tired a couple of thing such as running steam with out preferring the host libraries and using it's own, I think, like this:
    Code:
    STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 steam
    After all the game did start but the sound was very distorted and also the video playback was way to fast (I think the actual frame rate of the game)

    Thanks for your help in advance
    Vortex

  2. #2

    Default Re: (Older) Feral games: SDL_RWseek version SUSE_2.0.10 not defined in file libSDL2-2.0.so.0

    Sounds like an update in SDL has caused this possibly.
    Maybe symlinking to an older SDL so file could could resolve this?
    Otherwise there may be older versions of SDL available in the build service and other repos which you could replace the system packages with if
    you think that's worth trying since SDL isn't used by too many applications besides games.

  3. #3
    Join Date
    Oct 2017
    Location
    Germany
    Posts
    27

    Default Re: (Older) Feral games: SDL_RWseek version SUSE_2.0.10 not defined in file libSDL2-2.0.so.0

    Hey there,

    thank you a lot that indeed solved my problem!
    I switched from 2.0.5-35.1 to 2.0.5-1.1 and now the native version works just fine
    Thank you very much for the hint did not thought of just switching the SDL version.
    And locked it to avoid updating it by accident

  4. #4

    Smile Re: (Older) Feral games: SDL_RWseek version SUSE_2.0.10 not defined in file libSDL2-2.0.so.0

    Glad that fixed it, happy gaming

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •