Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: KMail won't send: Invalid D-bus reply from mailfilteragent

  1. #1

    Default KMail won't send: Invalid D-bus reply from mailfilteragent

    Kmail has stopped reliably sending emails. After a long delay, I get a mail not sent message with the error message being "invalid D-bus reply from mailfilteragent". I have no idea as to what is going wrong and can find no reference to this in the forums or Google. Can anyone help me?

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,475
    Blog Entries
    2

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Actually, a Google search on your error returns plenty of hits... but not all of them match your situation that well.

    Although very old, the following contains a number of things you can try from restarting the Akonadi service to re-installing the KDE-PIM modules to checking and possibly clearing out various folders...

    (Start somehwere around comment 19)
    https://bugs.kde.org/show_bug.cgi?id=290774

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Don't see this on 15.0, 15.1 and Tumbleweed. Which makes me wonder which repos are involved. Please show:
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Quote Originally Posted by tsu2 View Post
    Actually, a Google search on your error returns plenty of hits... but not all of them match your situation that well.

    Although very old, the following contains a number of things you can try from restarting the Akonadi service to re-installing the KDE-PIM modules to checking and possibly clearing out various folders...

    (Start somehwere around comment 19)
    https://bugs.kde.org/show_bug.cgi?id=290774

    TSU
    Most of the directories mentioned are no longer relevant. Akonadictl restart allows the email to be sent, but then the problem recurs.

  5. #5

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Quote Originally Posted by Knurpht View Post
    Don't see this on 15.0, 15.1 and Tumbleweed. Which makes me wonder which repos are involved. Please show:
    Code:
    zypper lr -d
    Code:
    #  | Alias                               | Name                               | Enabled | GPG Check | Refresh | Priority | Type     | URI                                                                                          | Service---+-------------------------------------+------------------------------------+---------+-----------+---------+----------+----------+----------------------------------------------------------------------------------------------+--------
     1 | Dickens_-_Ubuntu_Fonts              | Dickens - Ubuntu Fonts             | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/repositories/home:/gldickens3/openSUSE_Leap_15.1/               |        
     2 | Local                               | Local                              | Yes     | ( p) Yes  | Yes     |   99     | plaindir | dir:/home/charlie/RPMS                                                                       |        
     3 | Mono                                | Mono                               | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/repositories/Mono/openSUSE_Leap_15.1/                           |        
     4 | Mozilla                             | Mozilla                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.1/                        |        
     5 | Perl_Language                       | Perl Language                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_15.1/         |        
     6 | PlexRepo                            | PlexRepo                           | Yes     | (r ) Yes  | No      |   99     | rpm-md   | https://downloads.plex.tv/repo/rpm/x86_64/                                                   |        
     7 | Subpixel_-_namtrac                  | Subpixel - namtrac                 | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/repositories/home:/namtrac:/subpixel/openSUSE_Leap_15.1/        |        
     8 | Utilities                           | Utilities                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/utilities/openSUSE_Leap_15.1/                      |        
     9 | download.nvidia.com-leap_1          | nVidia Graphics Drivers            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://download.nvidia.com/opensuse/leap/15.1                                               |        
    10 | google-chrome                       | google-chrome                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                          |        
    11 | http-download.opensuse.org-67f86a4a | home:dnh                           | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/repositories/home:/dnh/openSUSE_Leap_15.1_standard/             |        
    12 | http-download.opensuse.org-807de918 | Ximi1970 - Pipelight               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/repositories/home:/Ximi1970:/openSUSE:/Extra/openSUSE_Leap_15.1 |        
    13 | http-download.opensuse.org-8d637abc | GNOME:Apps                         | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_15.1/                    |        
    14 | openSUSE-Leap-15.1-1                | openSUSE-Leap-15.1-1               | No      | ----      | ----    |   99     | rpm-md   | cd:/?devices=/dev/disk/by-id/ata-ASUS_DRW-24B1ST_i_E5D0CL057665                              |        
    15 | openSUSE_Leap_15.0_1                | Network Telephony                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | https://download.opensuse.org/repositories/network:/telephony/openSUSE_Leap_15.1/            |        
    16 | openSUSE_Leap_15.0_2                | Games                              | No      | ----      | ----    |   99     | NONE     | http://download.opensuse.org/repositories/games/openSUSE_Leap_15.1/                          |        
    17 | opensuse-guide.org-repo             | Libdvdcss Repository               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                                           |        
    18 | packman.inode.at-suse               | Packman                            | Yes     | (r ) Yes  | Yes     |   98     | rpm-md   | http://packman.inode.at/suse/openSUSE_Leap_15.1/                                             |        
    19 | repo-debug                          | Debug Repository                   | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/                          |        
    20 | repo-debug-non-oss                  | Debug Repository (Non-OSS)         | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/                      |        
    21 | repo-debug-update                   | Update Repository (Debug)          | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/debug/update/leap/15.1/oss/                                     |        
    22 | repo-debug-update-non-oss           | Update Repository (Debug, Non-OSS) | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/debug/update/leap/15.1/non-oss/                                 |        
    23 | repo-non-oss                        | Non-OSS Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                            |        
    24 | repo-oss                            | Main Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                                |        
    25 | repo-source                         | Source Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/                         |        
    26 | repo-source-non-oss                 | Source Repository (Non-OSS)        | No      | ----      | ----    |   99     | rpm-md   | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/                     |        
    27 | repo-update                         | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/leap/15.1/oss                                            |        
    28 | repo-update-non-oss                 | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md   | http://download.opensuse.org/update/leap/15.1/non-oss/                                       |

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    What I would do in your case is:
    - (temporarily) disable all the home:/ repos ( I don't use any but my own )
    - Run
    Code:
    sudo zypper ref
    sudo zypper dup
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Quote Originally Posted by Knurpht View Post
    What I would do in your case is:
    - (temporarily) disable all the home:/ repos ( I don't use any but my own )
    - Run
    Code:
    sudo zypper ref
    sudo zypper dup
    Thanks, I'll try it. It turns out I only had one home:/ directory enabled and that was to get a copy of pipelight, a close of silverlight. I notice that it did replace some other packages. I'll keep my fingers crossed.

  8. #8

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    I'm sorry to revisit this, but the problem keeps recurring. I've tried everything that was suggested in this thread and the old one from kde.org, and the only thing that works is akonadictl restart. However, the cure is temporary and sooner or later (often sooner) the problem comes back. I'm guessing it has to do with an akonadi agent or some other akonadi component. I've tried akonadictl fsck and akonadictl vacuum, but they seem to have no effect. Is there some way to start from scratch that could cure the problem without losing my whole configuration?

    Thanks for your help.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Quote Originally Posted by bearymore View Post
    I'm sorry to revisit this, but the problem keeps recurring. I've tried everything that was suggested in this thread and the old one from kde.org, and the only thing that works is akonadictl restart. However, the cure is temporary and sooner or later (often sooner) the problem comes back. I'm guessing it has to do with an akonadi agent or some other akonadi component. I've tried akonadictl fsck and akonadictl vacuum, but they seem to have no effect. Is there some way to start from scratch that could cure the problem without losing my whole configuration?

    Thanks for your help.
    There is, but if the Pipelight install removed some packages .... well we cannot see which ones. FWIW you shouldn't use any website using Silverlight. Those who still do do so against all advice from MS.......

    What you can do to restart an akonadi only reconfiguration is this:
    Code:
    akonadictl stop
    akonadictl status             # wait until this reports that it's stopped
    rm -rf ~/.config/akonadi*    # optional, this removes the email- and other accounts 
    rm -rf ~/.local/share/akonadi*          # removes the akonadi database
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: KMail won't send: Invalid D-bus reply from mailfilteragent

    Please also show
    Code:
    rpm -qa | grep -i dbus
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •