Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Missing package for libavcodec ffmpeg

  1. #1
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Question Missing package for libavcodec ffmpeg

    I need the libavcodec-ffmpeg.so, but I there is no such package for OpenSUSE

    libavcodec-ffmpeg.so.56()(64bit)
    libavcodec-ffmpeg.so.56(LIBAVCODEC_FFMPEG_56)(64bit)

    Does the package exist under a different name? I have searched my Leap 15.1, and cannot find any package that provides ibavcodec-ffmpeg.so

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,786
    Blog Entries
    3

    Default Re: Missing package for libavcodec ffmpeg

    Checking, I have "libavcodec56", "libavcodec57", "libavcodec58", "libavdevice56", "libavdevice57", "libavdevice58".

    Those are all from the packman repo. The description for each says "FFmpeg codec library".

    I'll note that the "57" and "58" can also be installed from the main repo, but the "56" is only in packman. In any case, it is probably best to use all from packman.

    I'll note that this is not what you asked for. But it might be what you need.

    What are you doing that seems to want the package you are asking about?
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,397
    Blog Entries
    2

    Default Re: Missing package for libavcodec ffmpeg

    IMO possibly the User may not be aware of the openSUSE strict policy to support only FOSS and not re-distribute anything with even a moderately restrictive license... and that is why most codecs cannot be found in openSUSE repos and has to come from a repo like Packman.

    The stickies at the beginning of this Forum describe how to add and give priority to packages from Packman to ensure you have just about all the codecs you'll need.

    For new Users to openSUSE, you'll find this and other things you should know in the slide deck of my presentation that walks Users through pre-install decisions, an install, first recommended steps after install and more you'll want to know about using openSUSE

    https://slides.com/tonysu/opensuse#/

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,786
    Blog Entries
    3

    Default Re: Missing package for libavcodec ffmpeg

    I'm guessing that the user got some software from elsewhere, and is following instructions based on different naming conventions.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Missing package for libavcodec ffmpeg

    I am building an JavaFX application and am using the jpackage tool to create an RPM installer of the application.
    The jpackage has many Requires it add to the RPM, and the libavcodec-ffmpeg are one of them.

    Both libavcodec.so and libavcoded-ffmpeg.so are listed, so they are not the same library.
    I cannot find the RPM package for libavcodec-ffmpeg on www.rpmfind.net

    libGL.so.1()(64bit)
    libX11.so.6()(64bit)
    libXext.so.6()(64bit)
    libXi.so.6()(64bit)
    libXrender.so.1()(64bit)
    libXtst.so.6()(64bit)
    libasound.so.2()(64bit)
    libasound.so.2(ALSA_0.9)(64bit)
    libasound.so.2(ALSA_0.9.0rc4)(64bit)
    libavcodec-ffmpeg.so.56()(64bit)
    libavcodec-ffmpeg.so.56(LIBAVCODEC_FFMPEG_56)(64bit)
    libavcodec.so.54()(64bit)
    libavcodec.so.54(LIBAVCODEC_54)(64bit)
    libavcodec.so.56()(64bit)
    libavcodec.so.56(LIBAVCODEC_56)(64bit)
    libavcodec.so.57()(64bit)
    libavcodec.so.57(LIBAVCODEC_57)(64bit)
    libavformat-ffmpeg.so.56()(64bit)
    libavformat-ffmpeg.so.56(LIBAVFORMAT_FFMPEG_56)(64bit)
    libavformat.so.54()(64bit)
    libavformat.so.54(LIBAVFORMAT_54)(64bit)
    libavformat.so.56()(64bit)
    libavformat.so.56(LIBAVFORMAT_56)(64bit)
    libavformat.so.57()(64bit)
    libavformat.so.57(LIBAVFORMAT_57)(64bit)
    libawt.so()(64bit)
    libawt_xawt.so()(64bit)
    libc.so.6()(64bit)
    libc.so.6(GLIBC_2.11)(64bit)
    libc.so.6(GLIBC_2.14)(64bit)
    libc.so.6(GLIBC_2.15)(64bit)
    libc.so.6(GLIBC_2.17)(64bit)
    libc.so.6(GLIBC_2.2.5)(64bit)
    libc.so.6(GLIBC_2.3)(64bit)
    libc.so.6(GLIBC_2.3.2)(64bit)
    libc.so.6(GLIBC_2.3.4)(64bit)
    libc.so.6(GLIBC_2.4)(64bit)
    libc.so.6(GLIBC_2.6)(64bit)
    libc.so.6(GLIBC_2.7)(64bit)
    libcairo.so.2()(64bit)
    libdl.so.2()(64bit)
    libdl.so.2(GLIBC_2.2.5)(64bit)
    libfreetype.so()(64bit)
    libfreetype.so.6()(64bit)
    libgdk-3.so.0()(64bit)
    libgdk-x11-2.0.so.0()(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libgio-2.0.so.0()(64bit)
    libglib-2.0.so.0()(64bit)
    libgmodule-2.0.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgstreamer-lite.so()(64bit)
    libgthread-2.0.so.0()(64bit)
    libgtk-3.so.0()(64bit)
    libgtk-x11-2.0.so.0()(64bit)
    libjava.so()(64bit)
    libjli.so()(64bit)
    libjvm.so()(64bit)
    libjvm.so(SUNWprivate_1.1)(64bit)
    libm.so.6()(64bit)
    libm.so.6(GLIBC_2.15)(64bit)
    libm.so.6(GLIBC_2.2.5)(64bit)
    libnet.so()(64bit)
    libpango-1.0.so.0()(64bit)
    libpangoft2-1.0.so.0()(64bit)
    libpthread.so.0()(64bit)
    libpthread.so.0(GLIBC_2.2.5)(64bit)
    libpthread.so.0(GLIBC_2.3.2)(64bit)
    librt.so.1()(64bit)
    librt.so.1(GLIBC_2.2.5)(64bit)
    libverify.so()(64bit)
    libz.so.1()(64bit)

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,023

    Default AW: Missing package for libavcodec ffmpeg


  7. #7
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: AW: Missing package for libavcodec ffmpeg

    Quote Originally Posted by Sauerland View Post
    I do not have access to that link: "Sorry, you are not authorized to perform this action".

    Leap 15.1 has libavcodec57 and libavcodec58, so I am covered there, but I was actually looking for the libavcodec-ffmpeg56.
    The list of Requires I have does not list this for anyone newer than 56.
    The ffmpeg2 package builds the libavcoded56, but there is nothing about libavcodec-ffmpeg there in its Spec file.

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,023

    Default AW: Missing package for libavcodec ffmpeg

    What app do you want to build?
    Link?
    You can build ffmpeg on OBS.

    Please do not use rpmfind or such sides, only use the official 4 Repos and Packman.

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,023

    Default AW: Missing package for libavcodec ffmpeg

    but I was actually looking for the libavcodec-ffmpeg56
    I think its a naming problem of the sources or spec-file.
    Where do you get them?

  10. #10
    Join Date
    Dec 2008
    Location
    Norway
    Posts
    550

    Default Re: Missing package for libavcodec ffmpeg

    I am building an JavaFX application we have made and we are using the jpackage tool to build native application installers for Linux, Mac and Windows.

    For Linux this tool adds additional RPM Requires, based on which JavaFX modules are used with the Java runtime image.
    javafx.base javafx.controls javafx.graphics javafx.fxml javafx.media javafx.web javafx.swing

    It is the javafx web module that am dragging in these libavcodec/ffmpeg requires.

    I have looked at ffmpeg2, ffmpeg3 and ffmpeg4 from OBS, none have anything with libavcodec-ffmpeg, just libavcodec.

    I have tried searching the web for this package, Fedora package search, OpenSUSE package search, and RPMFind. There is no trace of this as a package nowhere.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •