Results 1 to 8 of 8

Thread: Cannot get over zypper "segmentation fault"

  1. #1

    Default Cannot get over zypper "segmentation fault"

    I had problem with the zypper update a few days ago as I always got this error:

    "File './repodata/79df06e14cf43d8da70dffd32324dc71ac102b22042dc88fae3f4520bbba5f20-deltainfo.xml.gz' not found on medium 'http://download.opensuse.org/update/leap/15.0/oss/'"

    showing in the thread : https://forums.opensuse.org/showthre...n-kde-and-yast

    Now I seem to get over that error but I get the new error when I do "zypper ref": it finishes with "segmentation error".

    I have tried rpm --builddb but it ain't working.

    Any suggestion?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,330
    Blog Entries
    3

    Default Re: Cannot get over zypper "segmentation fault"

    This might be a good time to do a clean install of Leap 15.1. If you have a separate "/home", then just use the same partitions but do not reformat "/home". That should do a clean replacement of the operating system, while keeping home directories (and most user data).

    I'm not sure how your system got messed up. But a clean install would be easier than trying to repair it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,031
    Blog Entries
    2

    Default Re: Cannot get over zypper "segmentation fault"

    Try running the following and then refreshing afterwards
    Code:
    zypper clean -a
    Usually that works, in the very rare cases there is a "rpm purge" command but I'd have to look up it's so rare to use.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,074

    Default Re: Cannot get over zypper "segmentation fault"

    On several 15.0 installations I've been getting segfaults trying to run zypper up.
    https://lists.opensuse.org/opensuse-.../msg00037.html
    I wonder if this could be related?
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  5. #5
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    473

    Default Re: Cannot get over zypper "segmentation fault"

    Quote Originally Posted by moshpuke View Post

    Now I seem to get over that error but I get the new error when I do "zypper ref": it finishes with "segmentation error".

    I have tried rpm --builddb but it ain't working.

    Any suggestion?
    Did you try with rpm --rebuilddb or with the above? If the above, re-try it with the proper command: rpm --rebuilddb
    "Making rich people richer doesn't make the rest of us richer." Ha-Joon Chang
    openSUSE 15.1 4.12.14-lp151.28.16-default x64

  6. #6

    Default Re: Cannot get over zypper "segmentation fault"

    Quote Originally Posted by kerijan2003 View Post
    Did you try with rpm --rebuilddb or with the above? If the above, re-try it with the proper command: rpm --rebuilddb
    I might tried with the correct command but posted the wrong one.

    Anyway, I just ignored the segmentation fault from "zypper ref" and continued "zypper dup" (without any error). For the moment the system seems running fine.

    It does seem to me there is something wrong with Leap 15.0.

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,074

    Default Re: Cannot get over zypper "segmentation fault"

    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,074

    Default Re: Cannot get over zypper "segmentation fault"

    Quote Originally Posted by mrmazda View Post
    Bug 1150976 was dup'd to bug 1146027, which describes a workaround immediately available, and indicates a fix is to be included in libzypp-17.14.1.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •