Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Sddm/Plamsa/X-failure after dist-upgrade

  1. #1

    Default Sddm/Plamsa/X-failure after dist-upgrade

    Hi!

    Did a zypper dup on my Tumbleweed earlier this week. It was a rather large quantity of packages that was upgraded and I think it also involved a kernel. Since then I'm not able to logon to any KDE-sessions.

    After boot I get a cli login prompt and a flashing screen. About every other second the screen goes black and then I get the prompt back again. I can ssh into the machine and everything else is working.

    I've looked into the /var/log/Xorg.0.log and finds the follwoing entry.

    Code:
    [  1999.496] (EE) Failed to open authorization file "/run/sddm/{38bf293f-6a39-49a2-a65a-17dabd7f5974}": No such file or directory
    [  1999.738] (EE)
    [  1999.738] (EE) Backtrace:
    [  1999.738] (EE) 0: /usr/bin/X (xorg_backtrace+0x52) [0x64feb2]
    [  1999.738] (EE) 1: /usr/bin/X (0x4a9000+0x1aad92) [0x653d92]
    [  1999.738] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7f13874]
    [  1999.738] (EE) 3: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb70bd000+0x14e9f) [0xb70d1e9f]
    [  1999.738] (EE) 4: /usr/bin/X (miSyncInitFence+0x6c) [0x624cbc]
    [  1999.738] (EE) 5: /usr/bin/X (0x4a9000+0x17c520) [0x625520]
    [  1999.738] (EE) 6: /usr/bin/X (0x4a9000+0xdf4d1) [0x5884d1]
    [  1999.738] (EE) 7: /usr/bin/X (0x4a9000+0x177f5c) [0x620f5c]
    [  1999.738] (EE) 8: /usr/bin/X (0x4a9000+0x469c6) [0x4ef9c6]
    [  1999.738] (EE) 9: /usr/bin/X (0x4a9000+0x4aebb) [0x4f3ebb]
    [  1999.738] (EE) 10: /usr/bin/X (0x4a9000+0x33f5b) [0x4dcf5b]
    [  1999.738] (EE) 11: /lib/libc.so.6 (__libc_start_main+0xf1) [0xb77007e1]
    [  1999.738] (EE) 12: /usr/bin/X (_start+0x31) [0x4dcfa1]
    [  1999.739] (EE)
    [  1999.739] (EE) Segmentation fault at address 0x8
    [  1999.739] (EE)
    Fatal server error:
    [  1999.739] (EE) Caught signal 11 (Segmentation fault). Server aborting
    [  1999.739] (EE)
    [  1999.739] (EE)
    Please consult the The X.Org Foundation support
             at http://wiki.x.org
     for help.
    [  1999.739] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [  1999.739] (EE)
    [  1999.739] (II) AIGLX: Suspending AIGLX clients for VT switch
    [  1999.758] (EE) Server terminated with error (1). Closing log file.
    Any suggestions on whats wrong?

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,308
    Blog Entries
    14

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Any additional repos involved? Please show:
    Code:
    zypper lr -d
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Nothing extraordinary I think..

    Code:
    # | Alias                               | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                    | Service
    --+-------------------------------------+-----------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------+--------
    1 | Mozilla                             | Mozilla                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Tumbleweed/ |        
    2 | http-download.opensuse.org-8058c52a | openSUSE:Factory            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory/snapshot/  |        
    3 | openSUSE-20180206-0                 | openSUSE-20180206-0         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                      |        
    4 | packman                             | packman                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/    |        
    5 | repo-debug                          | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                |        
    6 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                  |        
    7 | repo-source                         | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/               |        
    8 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                        |

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,308
    Blog Entries
    14

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    No, the only one unneeded is #2.

    Is sddm installed?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Quote Originally Posted by Knurpht View Post
    No, the only one unneeded is #2.

    Is sddm installed?
    Yes, it is.
    Code:
    i+ | sddm                   | package | 0.18.0-8.1

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,389

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Quote Originally Posted by habr71 View Post
    Did a zypper dup on my Tumbleweed earlier this week. It was a rather large quantity of packages that was upgraded
    How old was the snapshot you were updating from, ie very recent, or several/many snapshots ago?

    and I think it also involved a kernel. Since then I'm not able to logon to any KDE-sessions.
    Have you tried booting from a previous kernel?

    After boot I get a cli login prompt and a flashing screen. About every other second the screen goes black and then I get the prompt back again. I can ssh into the machine and everything else is working.
    Video driver problem maybe, have you tried booting with "nomodeset"?


    I've looked into the /var/log/Xorg.0.log and finds the follwoing entry.

    Code:
    [  1999.496] (EE) Failed to open authorization file "/run/sddm/{38bf293f-6a39-49a2-a65a-17dabd7f5974}": No such file or directory
    ...
    ...
    If you believe sddm is implicated you could try removing all traces of it's cache/config files by manually removing:

    /var/lib/sddm/.cache
    /var/lib/sddm/.config
    /var/lib/sddm/.local
    /etc/sddm.conf
    ~/.local/share/sddm

    Probably also worth renaming the ".Xauthority" file in your home directory.

    They will (should) all be recreated at next start-up.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  7. #7

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Quote Originally Posted by tannington View Post
    How old was the snapshot you were updating from, ie very recent, or several/many snapshots ago?
    I usually run zypper dup at least once a week depending on how often I got notified about pending updates. So it was not a long time since last update.

    Have you tried booting from a previous kernel?
    Tried but got the same result


    Video driver problem maybe, have you tried booting with "nomodeset"?
    Tried now to add the nomodeset option and I got a working login.Not with correct display settings but I got a login prompt and can login to a working desktop.

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,389

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Quote Originally Posted by habr71 View Post
    ... Tried now to add the nomodeset option and I got a working login.Not with correct display settings but I got a login prompt and can login to a working desktop.
    As it had previously been working OK (I assume), I'd initially try another "zypper dup", maybe a transient problem with one of the mirrors, missing a package perhaps.

    Video details?

    Code:
    sudo hwinfo --gfxcard
    Code:
    inxi -Gxx
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    Quote Originally Posted by tannington View Post
    As it had previously been working OK (I assume), I'd initially try another "zypper dup", maybe a transient problem with one of the mirrors, missing a package perhaps.
    Yes, its been working for quite awhile. Already tried another zypper dup without any luck. Some other applications got updated however.

    Video details?

    Code:
    sudo hwinfo --gfxcard
    Code:
    32: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.386]
      Unique ID: VCu0.nhHMAErIyOA
      Parent ID: _Znp.EGK9zsdSruB
      SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "ATI Bonaire XTX [Radeon R7 260X/360]"
      Vendor: pci 0x1002 "ATI Technologies Inc"
      Device: pci 0x6658 "Bonaire XTX [Radeon R7 260X/360]"
      SubVendor: pci 0x1682 "XFX Pine Group Inc."
      SubDevice: pci 0x7260 
      Driver: "radeon"
      Driver Modules: "radeon"
      Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
      Memory Range: 0xd0000000-0xd07fffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0xfea00000-0xfea3ffff (rw,non-prefetchable)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 37 (2435 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v00001002d00006658sv00001682sd00007260bc03sc00i00"
      Driver Info #0:
        Driver Status: radeon is active
        Driver Activation Cmd: "modprobe radeon"
      Driver Info #1:
        Driver Status: amdgpu is active
        Driver Activation Cmd: "modprobe amdgpu"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #19 (PCI bridge)
    
    Primary display adapter: #32
    Code:
    inxi -Gxx
    Code:
    Graphics:
      Device-1: AMD Bonaire XTX [Radeon R7 260X/360] vendor: XFX Pine driver: radeon 
      v: kernel bus ID: 01:00.0 chip ID: 1002:6658 
      Display: tty server: X.org 1.20.5 driver: radeon FAILED: ati 
      unloaded: fbdev,modesetting,vesa tty: 88x29 
      Message: Advanced graphics data unavailable in console for root.
    Both commands executed when system is booted in original configuration without nomodeset

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,389

    Default Re: Sddm/Plamsa/X-failure after dist-upgrade

    OK... Unfortunately I'm not familiar with AMD/ATI/Radeon graphics, I don't think I'm able to assist any further.

    Looking at your initial post it seems that "radeon_drv.so" segfaults.

    You've confirmed it's a video driver problem.

    Perhaps best to edit the thread title to reflect the problem is with the radeon driver after a zypper dup, then others more familiar with your hardware may reply.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200211) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •