Results 1 to 2 of 2

Thread: Yast 'HTTP Server' startup: "Internal error - yast.rb: Component cannot import namespace 'HTTPDData'

  1. #1

    Default Yast 'HTTP Server' startup: "Internal error - yast.rb: Component cannot import namespace 'HTTPDData'

    when I run 'HTTP Server' in Yast, it reports: "Internal error. ... Caller: /usr/lib64&ruby/vendor_ruby/2.6.0/yast/yast.rb:186in 'import_pure' Details: component cannot import namespace 'HTTPDData'. y2log . Other Yast modules seem to work. I've dup'ed recently. No related repos added. Ideas what might be wrong? I've Xampp installed in /opt, could that affect this? (Xampp is working, but going to configure Apache so I wouldn't need that).

    Deps seem fine:
    Code:
    $ sudo zypper verify
    Dependencies of all installed packages are satisfied.
    I've installed the lamp_server pattern as zypper shows:

    Code:
    i+ | lamp_server   | Web and LAMP Server               | pattern

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Yast 'HTTP Server' startup: "Internal error - yast.rb: Component cannot import namespace 'HTTPDD

    Since all here works as expected, both on my laptop and VPS, I suspect Xampp to be the culprit, yes. The lamp-server pattern should be enough to have an apache server up and running with php and mysql ...
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •