Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Really really strange openSuse booting problem

  1. #1

    Question Really really strange openSuse booting problem

    hi guys,
    so i have this really strange issue when trying to boot. Short story is that it doesn't boot at all if i don't have a working ethernet cable plugged in - it just loads forerver. And as soon as I plug it it magically boots without any problems.
    I actually reinstalled the distro and only after hours of baffling i figured that when the cable is plugged it works.
    So does anyone have a similar problem and does anyone have any suggestions on how to boot offline.
    thanks in advance and have a nice day
    PS - i use OpenSuSe Tumbleweed

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,680
    Blog Entries
    15

    Default Re: Really really strange openSuse booting problem

    Quote Originally Posted by pkaterski View Post
    hi guys,
    so i have this really strange issue when trying to boot. Short story is that it doesn't boot at all if i don't have a working ethernet cable plugged in - it just loads forerver. And as soon as I plug it it magically boots without any problems.
    I actually reinstalled the distro and only after hours of baffling i figured that when the cable is plugged it works.
    So does anyone have a similar problem and does anyone have any suggestions on how to boot offline.
    thanks in advance and have a nice day
    PS - i use OpenSuSe Tumbleweed
    Hi and welcome to the Forum
    So do you know if your using Network Manager or wicked for the network? You can fire up YaST and Network Settings to see (on the general tab). At boot (with cable plugged in) after grub press the esc key to see boot messages on the screen and it might indicate where it's stalling.

    What is the hardware, desktop, laptop? What desktop environment, Gnome, KDE etc?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Really really strange openSuse booting problem

    hey thanks for the quick reply
    I think i'm using NetworkManager (YaST gives me" "Network is currently handled by NetworkManager or completely disabled. YaST is unable to configure some options" dialog box).
    When i press ESC after grub i get the following


    im on Asus K550J laptop with KDE

  4. #4

    Default Re: Really really strange openSuse booting problem

    if i wait exactly 10 mins it boots
    the problem was with chrony-wait.service (for time sync)

    so i did
    sudo systemctl edit --full chrony-wait.service

    and changed
    ExecStart=/usr/bin/chronyc -h 127.0.0.1,::1 waitsync 600 0.1 0.0 1
    to
    ExecStart=/usr/bin/chronyc -h 127.0.0.1,::1 waitsync 2 0.1 0.0 1
    now insted of 10mins its 2 secs and boots perfectly fine offline

  5. #5
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default Re: Really really strange openSuse booting problem

    Tumbleweed, Xfce, Firefox, uBlock Origin

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,807
    Blog Entries
    14

    Default Re: Really really strange openSuse booting problem

    Quote Originally Posted by pkaterski View Post
    if i wait exactly 10 mins it boots
    the problem was with chrony-wait.service (for time sync)

    so i did
    sudo systemctl edit --full chrony-wait.service

    and changed
    ExecStart=/usr/bin/chronyc -h 127.0.0.1,::1 waitsync 600 0.1 0.0 1
    to
    ExecStart=/usr/bin/chronyc -h 127.0.0.1,::1 waitsync 2 0.1 0.0 1
    now insted of 10mins its 2 secs and boots perfectly fine offline
    That's only a workaround. Put it back, and stop the ntp service. You are now running both chrony and ntpd .... And openSUSE has moved to chrony ......
    Can be done from YaST > System > Service manager. Disable npt(d?).
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default Re: Really really strange openSuse booting problem

    There is no ntp or npt(d) service on Tumbleweed.

    The workaround is fine. Disabling chrony-wait.service also works. If you actually need the service, then you just need to go bake a cake while your computer boots. Apparently, most people that aren't using Kubic don't need it, since there have been no reported side effects from disabling it so far.

    You can read the bug report to see that this is a widespread issue, and the developers are apparently still debating about the proper solution.
    Tumbleweed, Xfce, Firefox, uBlock Origin

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,706

    Default Re: Really really strange openSuse booting problem

    NTP may come from an old os via an upgrade.

    I have 15.1 an I have chrony but no ntp

  9. #9
    Join Date
    Apr 2016
    Location
    North America
    Posts
    532

    Default Re: Really really strange openSuse booting problem

    If we are talking about the NTP messages in the photo, that's most likely associated with "chronyd.service".

    "systemctl status chronyd" shows "Starting NTP client/server..."
    Tumbleweed, Xfce, Firefox, uBlock Origin

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,706

    Default Re: Really really strange openSuse booting problem

    ntp(d) and chrony are known to interfere with each other.There have been several recent threads about slow boots do to this.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •