Results 1 to 3 of 3

Thread: Notebook WLAN interface not recognized any more

  1. #1
    Join Date
    Oct 2008
    Location
    Germany, Bremen
    Posts
    26

    Question Notebook WLAN interface not recognized any more

    Hello Forum,

    on an ASUS K73E laptop (core i3, 4GiB, SDD), about 7 years old, running OpenSUSE 15.0, the WLAN interface suddenly became unavailable.
    • "hwinfo --wlan" showed nothing
    • "hwinfo --network" showed (of course) only "Ethernet" and "lo" interface ...
    • ... so did "ip link list"
    • "lspci" did only show Ethernet controller, no WLAN
    • manually loading the required driver "ath9k" did not change anything, also no outputs on syslog while loading
    • booting Leap 15.1 "Network Installation" as test did not detect the WLAN


    So, I guess this is a HW defect ? Or is there something else I have overseen or I can check ?

    Regards, Wumpus

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,975

    Default AW: Notebook WLAN interface not recognized any more

    Please post
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    or if it is an USB-Adapter:
    Code:
    lsusb

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,375
    Blog Entries
    1

    Default Re: Notebook WLAN interface not recognized any more

    Along with sauerland's suggestion, make sure to check that you haven't accidentally disabled the wifi via a switch or function key perhaps.
    openSUSE Leap 15.0; KDE Plasma 5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •