Results 1 to 4 of 4

Thread: LDB updated to 1.5.5, Samba still at 1.5.4 -- breaks.

  1. #1

    Default LDB updated to 1.5.5, Samba still at 1.5.4 -- breaks.

    It looks like around Sep. 9, my nightly update on my domain controller brought in a new libldb at version 1.5.5. Unfortunately, Samba wasn't also updated, and it depends on 1.5.4. This causes:
    db: module version mismatch in ../../source4/dsdb/samdb/ldb_modules/acl.c : ldb_version=1.5.5 module_version=1.5.4
    in my samba.log.
    Looks like Samba needs to be updated. Hopefully that's in the works.
    Thanks.

    My current versions: (not working)
    libldb1-1.5.5-1.1.x86_64
    samba-ad-dc-4.10.5+git.105.2bd98587873-1.2.x86_64

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,802
    Blog Entries
    14

    Default Re: LDB updated to 1.5.5, Samba still at 1.5.4 -- breaks.

    Two questions:
    - How did you update?
    - Please show
    Code:
    zypper lr -d
    between CODE (#) tags
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: LDB updated to 1.5.5, Samba still at 1.5.4 -- breaks.

    Quote Originally Posted by Knurpht View Post
    Two questions:
    - How did you update?
    - Please show
    Code:
    zypper lr -d
    between CODE (#) tags
    Code:
    # | Alias        | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                      | Service
    --+--------------+-----------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------+--------
    1 | repo-debug   | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/  |        
    2 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/    |        
    3 | repo-oss     | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/        |        
    4 | repo-source  | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/ |        
    5 | repo-update  | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/          |
    I update using "zypper dup --no-allow-vendor-change"

    Thanks.

  4. #4

    Default Re: LDB updated to 1.5.5, Samba still at 1.5.4 -- breaks.

    As of today's update, Tues. Sep. 17, 2019, the new samba packages now match the libldb1 packages, and my domain controllers are working again. So my issue is fixed. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •