Results 1 to 3 of 3

Thread: Blanks screen with cursor

  1. #1
    Join Date
    Jan 2018
    Location
    Annandale, VA
    Posts
    124

    Default Blanks screen with cursor

    When I boot I get a blank screen with a cursor that tracks mouse movements, but no login menu. Ctrl-Alt-F1 does nothing.

    I've seen this before after an interrupted update, and a reinstall resolved it. Should I just reinstall, or is corrective action possible from advanced Options? Thanks.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,706

    Default Re: Blanks screen with cursor

    Mostly this indicates a graphic driver issue. Graphic card? Driver?

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,645

    Default Re: Blanks screen with cursor

    Is this by any chance a laptop with Optimus graphics?

    There are a number of possible causes for black screen after making a Grub menu selection. Finding your cause can take some effort. I'm actually in the middle of the same problem with an 11 year old Sony VAIO laptop and 15.0, having posted both here and on an openSUSE mailing list thread. The common fixes so far haven't worked for me, but I'm not yet sure it isn't a hardware failure. Nomodeset is working as best it can.

    Usually nomodeset (as here instructed) can be appended to the linux line at the grub menu to avoid the black screen, but it's intended only for troubleshooting, as it limits screen resolution and graphics speed. By booting this way you should be able to do the following on a nomodeset boot that follows a black screen boot:
    Code:
    sudo susepaste -n shmuelmetz /var/log/Xorg.0.log.old
    If if doesn't return an error or hang, you should get an URL you can post here so we can examine that log for error messages pointing to the problem. If you do get an error, then that file needs to be uploaded to https://susepaste.org or http://pastebin.com/ or similar FOSS pastebinning site with a web browser. Also ~/.local/share/xorg/Xorg.0.log.old might be needed in addition or instead, so post both if both exist. The susepaste command might need to be installed first. Also, after booting with nomodeset you can collect other information about hardware and configuration to paste in here, probably in this manner from an xterm or konsole:
    Code:
    sudo zypper in susepaste inxi Mesa-demo-x xdpyinfo
    inxi -GxxSMaz
    xrandr --listproviders
    Please use [ code ] tags (# icon above input window) around your paste to preserve the formatting.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •