Results 1 to 7 of 7

Thread: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

  1. #1
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,691

    Default G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    I have probably at least ten hours into trying to figure this out just since beginning using an SSD with openSUSE 15.0 already installed. It's a Sony VAIO 11 years old belonging to a church deacon that seemed to have graphics card failing in Win7, which I brought home Saturday afternoon and started working on that night. Eventually I figured out that the corruption was due to overheating, cooled it down, and put a big fan aimed at its bottom to keep the heat down, but in the process of discovery I managed to make Windows unable to boot. I spent the better part of Sunday trying to figure out how to get Windows repaired, without success as yet.

    The BIOS is wacky, producing corruption any time BIOS video mode 80x25 is used. I was unable to find any downloadable BIOS on Sony's support site. The graphics modes it should be supporting go up to at least 1440x900 if this mobilespecs.net VGN-AR730E page is to be believed. Sony's support seems to have specifications well hidden if anywhere. Since it's a 17", 1920x1080 or 1920x1200 would make much more sense.

    Video is perfect in VESA or FBDEV 1024x768, one of which is used either starting 15.1 installation or booting with nomodeset. Booting Knoppix or TW 20180812 & kernel-default 4.17.13 (dup currently in progress) the results are the same, corruption if mode is 80x25 text, 1024x768 at best otherwise. Inclusion of any video= on cmdline, absent nomodeset to accompany it, always causes black screen when KMS kicks in.

    http://fm.no-ip.com/Tmp/Linux/Xorg/Nv/ has lspci, inxi, lsmod, xrandr, gfx hwinfo, several Xorg.0.logs, and journals from boots with various cmdline options I tried that didn't help, such as iommu= and iomem=, as indicated in each of the filenames.

    Can anyone suggest other cmdline options that are worth a try, or might even fix this? Anything else?
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,830
    Blog Entries
    15

    Default Re: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    Hi
    Power supply rails all ok? Overheating doesn't sound good, failing components?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,691

    Default Re: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    Owner instructed me not to open it up except to reseat the RAM. I blew compressed air through it to try to remove accumulated detritus, and I keep the bottom exposed to lots of air while I'm running it, so at least for now heat seems to be a non-issue.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,691

    Default Re: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    Since this is somehow kernel related and not openSUSE only, I opened a thread on linuxquestions.org.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  5. #5
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,691

    Default Re: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    No fruit from linuxquestions.org, so I filed a kernel bug: https://bugzilla.kernel.org/show_bug.cgi?id=204851
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    Sounds like failing hardware it is 11 years old.


    Best to rescue any important data before doing anything else

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,691

    Default Re: G96 [GeForce 9500 GT] Xorg fails to start with "(EE) [drm] failed to open device"

    It's been a rescue operation from the start. The object is to determine if there is a hardware failure, and if not, what to do to get the display's native mode to be utilized. It's original HD isn't in it. It has had my SSD in it prior to starting the thread. Video works fine as long as acpi=off is used, and none of the display's widescreen modes are needed. The nouveau kernel module refuses to load, which smells strongly like a software issue.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •