Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 55

Thread: HP All-in-One Printer No Longer Scanning

  1. #21

    Default Re: HP All-in-One Printer No Longer Scanning

    Quote Originally Posted by deano_ferrari View Post
    Another thought that I had is to check which print driver you are currently using for your HP device. The hpaio scanner backend relies on the HPLIP URI being correctly configured as I once wrote here.

    This may be useful in determining how CUPS is currently configured...
    Code:
    lpstat -t

    Code:
    alastair@AJBR-W530:~> lpstat -t
    scheduler is running
    system default destination: HP_LaserJet_600_M602
    device for hp_Color_Laserjet_2840: socket://192.168.169.141:9100
    device for HP_LaserJet_600_M602: hp:/net/HP_LaserJet_600_M602?ip=192.168.169.140
    hp_Color_Laserjet_2840 accepting requests since Tue 10 Sep 2019 11:03:10 BST
    HP_LaserJet_600_M602 accepting requests since Mon 09 Sep 2019 18:53:05 BST
    printer hp_Color_Laserjet_2840 is idle.  enabled since Tue 10 Sep 2019 11:03:10 BST
    printer HP_LaserJet_600_M602 is idle.  enabled since Mon 09 Sep 2019 18:53:05 BST
    alastair@AJBR-W530:~>
    Code:
    egrep -i "name|model|filter" /etc/cups/ppd/*
    I think the next output will blow the character limit so will start a new reply.

  2. #22

    Default Re: HP All-in-One Printer No Longer Scanning

    Sorry I have conflated the quotes somehow but it should all be clear. Here is the result from your last instruction:-

    Code:
    alastair@AJBR-W530:~> sudo egrep -i "name|model|filter" /etc/cups/ppd/*
    [sudo] password for root: 
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*PCFileName: "HP2800.PPD"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*% Product Name and Version Information
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*ModelName:    "HP Color LaserJet 2800 Series"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*ShortNickName: "HP Color LaserJet 2800 Series"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*NickName: "HP Color LaserJet 2800 Series Postscript (recommended)"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*% CMYK Ink Model
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*% Chose NOT to use standard *ColorModel keyword because color on or off is simpler
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*OpenUI *ColorModel/Print Color as Gray:  PickOne
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*OrderDependency: 20 AnySetup *ColorModel
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*DefaultColorModel: CMYK
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*de.Translation ColorModel/In Graustufen drucken: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*es.Translation ColorModel/Imprimir colores como grises: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*fr.Translation ColorModel/Imprimer couleur en gris: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*it.Translation ColorModel/Stampa colore in grigio: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*nl.Translation ColorModel/Kleuren afdrukken in grijstinten: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*ColorModel Gray/On: "<</ProcessColorModel /DeviceGray>> setpagedevice"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*de.ColorModel Gray/Ein: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*es.ColorModel Gray/Sí: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*fr.ColorModel Gray/Oui: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*it.ColorModel Gray/Attiva: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*nl.ColorModel Gray/Aan: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*ColorModel CMYK/Off: "<</ProcessColorModel /DeviceCMYK>> setpagedevice"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*de.ColorModel CMYK/Aus: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*es.ColorModel CMYK/No: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*fr.ColorModel CMYK/Non: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*it.ColorModel CMYK/Disattiva: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*nl.ColorModel CMYK/Uit: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*?ColorModel: "
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:    currentpagedevice /ProcessColorModel get
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*CloseUI: *ColorModel
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd:*Message: "\FontName\ not found, using Courier"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*PCFileName: "HP2800.PPD"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*% Product Name and Version Information
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*ModelName:  "HP Color LaserJet 2800 Series"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*ShortNickName: "HP Color LaserJet 2800 Series"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*NickName: "HP Color LaserJet 2800 Series Postscript (recommended)"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*% CMYK Ink Model
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*% Chose NOT to use standard *ColorModel keyword because color on or off is simpler
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*OpenUI *ColorModel/Print Color as Gray:  PickOne
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*OrderDependency: 20 AnySetup *ColorModel
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*DefaultColorModel: CMYK
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*de.Translation ColorModel/In Graustufen drucken: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*es.Translation ColorModel/Imprimir colores como grises: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*fr.Translation ColorModel/Imprimer couleur en gris: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*it.Translation ColorModel/Stampa colore in grigio: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*nl.Translation ColorModel/Kleuren afdrukken in grijstinten: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*ColorModel Gray/On: "<</ProcessColorModel /DeviceGray>> setpagedevice"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*de.ColorModel Gray/Ein: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*es.ColorModel Gray/Sí: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*fr.ColorModel Gray/Oui: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*it.ColorModel Gray/Attiva: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*nl.ColorModel Gray/Aan: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*ColorModel CMYK/Off: "<</ProcessColorModel /DeviceCMYK>> setpagedevice"
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*de.ColorModel CMYK/Aus: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*es.ColorModel CMYK/No: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*fr.ColorModel CMYK/Non: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*it.ColorModel CMYK/Disattiva: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*nl.ColorModel CMYK/Uit: ""
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*?ColorModel: "
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:    currentpagedevice /ProcessColorModel get
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*CloseUI: *ColorModel
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*Message: "\FontName\ not found, using Courier"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*PCFileName: "HPP00009.PPD"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*ModelName: "HP LaserJet 600 M601 M602 M603"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*ShortNickName: "HP LaserJet 600 M601 M602 M603"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*NickName: "HP LaserJet 600 M601 M602 M603 Postscript (recommended)"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*cupsMarkerName black/Black: ""
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*cupsMarkerName maintenancekit/Maintenance Kit: ""
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*HPCustomJobName Title/Job Name: ""
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*HPCustomJobName Range: "1 15"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*HPCustomJobName Type: "string"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*HPCustomUserName Title/User Name: ""
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*HPCustomUserName Range: "1 15"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*HPCustomUserName Type: "string"
    /etc/cups/ppd/HP_LaserJet_600_M602.ppd:*cupsModelNumber: 0
    Sorry, I had to shorten this but you will get the gist and if you tell me what to grep I can follow your instruction but the output ran to 60,000 characters!!!
    Last edited by hcvv; 11-Sep-2019 at 11:34. Reason: repaired CODE tags

  3. #23
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: HP All-in-One Printer No Longer Scanning

    1. When wanting to share lengthy output, please use https://paste.opensuse.org/ and post the link that it generates here. That saves long posts of code output.

    2. The HP Color Laserjet 2840 printer configuration shows that you're currently using a postscript driver (definitely not configured with HPLIP driver and backend), so scanning via the hpaio backend will NOT be possible as is....
    Code:
    device for hp_Color_Laserjet_2840: socket://192.168.169.141:9100
    Code:
    /etc/cups/ppd/hp_Color_Laserjet_2840.ppd.O:*NickName: "HP Color LaserJet 2800 Series Postscript (recommended)"
    3. Was 'hp-doctor' not able to assist you with installing the missing dependencies?
    openSUSE Leap 15.0; KDE Plasma 5

  4. #24

    Default Re: HP All-in-One Printer No Longer Scanning

    Hi Deano,
    Will use paste site for the long output but meanwhile I had a good go at installing the missing dependencies. Here is the output from hp-doctor now. I do not understand the DBUS comment and the other dependencies were not on the repos I have installed but here goes:-

    Code:
    alastair@AJBR-W530:~> hp-doctor
    
    HP Linux Imaging and Printing System (ver. 3.19.6)
    Self Diagnse Utility and Healing Utility ver. 1.0
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    
    HP Linux Imaging and Printing System (ver. 3.19.6)
    Self Diagnse Utility and Healing Utility ver. 1.0
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
     
    
    Checking for Deprecated items....
    error: This distro (i.e suse  20190907) is either deprecated or not yet supported.
    The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y
    
    
    Checking for HPLIP updates....
    
    HP Linux Imaging and Printing System (ver. 3.19.6)
    HPLIP upgrade latest version ver. 1.0
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    error: HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.
    
    Done.
    error: Failed to upgrade latest HPLIP. Is hp-upgrade already running (i.e. foreground or background)?
    
    
    Checking for Dependencies....
    warning: 3-20190907 version is not supported. Using 3-15.0 versions dependencies to verify and install...
    
    ---------------
    | SYSTEM INFO |
    ---------------
    
     Kernel: 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) GNU/Linux
     Host: AJBR-W530
     Proc: 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) GNU/Linux
     Distribution: 3 20190907
     Bitness: 64 bit
    
    
    -----------------------
    | HPLIP CONFIGURATION |
    -----------------------
    
    HPLIP-Version: HPLIP 3.19.6
    HPLIP-Home: /usr/share/hplip
    warning: HPLIP-Installation: Auto installation is not supported for 3 distro  20190907 version 
    
    Current contents of '/etc/hp/hplip.conf' file:
    # hplip.conf.  Generated from hplip.conf.in by configure.
    
    [hplip]
    version=3.19.6
    
    [dirs]
    home=/usr/share/hplip
    run=/var/run
    ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
    ppdbase=/usr/share/cups/model/manufacturer-PPDs
    doc=/usr/share/doc/packages/hplip
    html=/usr/share/doc/packages/hplip
    icon=/usr/share/applications
    cupsbackend=/usr/lib/cups/backend
    cupsfilter=/usr/lib/cups/filter
    drv=/usr/lib/cups/driver
    bin=/usr/bin
    apparmor=/etc/apparmor.d
    # Following values are determined at configure time and cannot be changed.
    [configure]
    network-build=yes
    libusb01-build=no
    pp-build=no
    gui-build=yes
    scanner-build=yes
    fax-build=yes
    dbus-build=yes
    cups11-build=no
    doc-build=yes
    shadow-build=no
    hpijs-install=yes
    foomatic-drv-install=no
    foomatic-ppd-install=yes
    foomatic-rip-hplip-install=no
    hpcups-install=yes
    cups-drv-install=no
    cups-ppd-install=yes
    internal-tag=3.19.6
    restricted-build=no
    ui-toolkit=qt5
    qt3=no
    qt4=no
    qt5=yes
    policy-kit=no
    lite-build=no
    udev_sysfs_rules=no
    hpcups-only-build=no
    hpijs-only-build=no
    apparmor_build=no
    class-driver=no
    
    
    Current contents of '/var/lib/hp/hplip.state' file:
    Plugins are not installed. Could not access file: No such file or directory
    
    Current contents of '~/.hplip/hplip.conf' file:
    [installation]
    date_time = 09/11/19 20:14:55
    version = 3.19.6
    
    
     <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
    
    -------------------------
    | External Dependencies |
    -------------------------
    
     cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.3             OK         'CUPS Scheduler is running'
     gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.27            OK         -
     xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
     scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
     error: dbus          DBus - Message bus system                                    REQUIRED        -               1.12.12         MISSING    'DBUS may not be installed or not running'
     policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.116           OK         -
     network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
     avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -
    
    ------------------------
    | General Dependencies |
    ------------------------
    
     error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
     cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.3             OK         -
     cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.3             OK         -
     libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.29'         OK         -
     libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
     sane                 SANE - Scanning library                                      REQUIRED        -               1.0.27          OK         -
     sane-devel           SANE - Scanning library development files                    REQUIRED        -               1.0.27          OK         -
     libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
     libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
     python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.7.3           OK         -
     python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
    Traceback (most recent call last):
      File "/usr/bin/hp-doctor", line 297, in <module>
        num_errors, num_warns = dep.validate(DEPENDENCY_RUN_AND_COMPILE_TIME, False)
      File "/usr/share/hplip/check.py", line 368, in validate
        self.core.dependencies[dep])
      File "/usr/share/hplip/check.py", line 210, in __update_deps_info
        installed_ver = self.core.version_func[deps_info[6]]()
      File "/usr/share/hplip/installer/dcheck.py", line 303, in get_pyQt4_version
        from PyQt4 import QtCore
    ImportError: cannot import name 'QtCore' from 'PyQt4' (unknown location)
    alastair@AJBR-W530:~>

  5. #25

    Default Re: HP All-in-One Printer No Longer Scanning

    Deano I have posted the output from your earlier command. Here is the link:-

    Hope this means more to you than me.

    On your remark about the driver being postscript this was "recommended" and there were only postscript drivers offered.
    As I mentioned on my Leap 15.0 installation the printer did not appear at all. I must have something wrong with the installation unless the drivers are on the community repos.

    OT. Finally are you working very early or were you up all night? My grandson just started the football season in NZ and I had a great picture from him on the pitch and it wasn't raining!!!

  6. #26
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: HP All-in-One Printer No Longer Scanning

    Quote Originally Posted by Budgie2 View Post
    Deano I have posted the output from your earlier command. Here is the link:-



    Hope this means more to you than me.

    On your remark about the driver being postscript this was "recommended" and there were only postscript drivers offered.
    As I mentioned on my Leap 15.0 installation the printer did not appear at all. I must have something wrong with the installation unless the drivers are on the community repos.
    My observation was from reading the lpstat output (for CUPS backend details and status), and the ppd details showing which driver is currently configured. As your thread title is about scanning, I wanted to shed light on why that isn't working for you, and it all has to do with HPLIP.

    OT. Finally are you working very early or were you up all night? My grandson just started the football season in NZ and I had a great picture from him on the pitch and it wasn't raining!!!
    It's morning here in NZ...was eating breakfast and catching up with forum posts.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #27

    Default Re: HP All-in-One Printer No Longer Scanning

    I think I have solved the dependencies so here is the output of hp-doctor again:-

    Code:
    alastair@AJBR-W530:~> hp-doctor
    
    HP Linux Imaging and Printing System (ver. 3.19.6)
    Self Diagnse Utility and Healing Utility ver. 1.0
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    
    HP Linux Imaging and Printing System (ver. 3.19.6)
    Self Diagnse Utility and Healing Utility ver. 1.0
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
     
    
    Checking for Deprecated items....
    error: This distro (i.e suse  20190907) is either deprecated or not yet supported.
    The diagnosis is limited on unsupported platforms. Do you want to continue?(y=yes*, n=no):y
    
    
    Checking for HPLIP updates....
    
    HP Linux Imaging and Printing System (ver. 3.19.6)
    HPLIP upgrade latest version ver. 1.0
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    error: HPLIP upgrade is disabled by openSUSE for security reasons, see https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.
    
    Done.
    error: Failed to upgrade latest HPLIP. Is hp-upgrade already running (i.e. foreground or background)?
    
    
    Checking for Dependencies....
    warning: 3-20190907 version is not supported. Using 3-15.0 versions dependencies to verify and install...
    
    ---------------
    | SYSTEM INFO |
    ---------------
    
     Kernel: 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) GNU/Linux
     Host: AJBR-W530
     Proc: 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) GNU/Linux
     Distribution: 3 20190907
     Bitness: 64 bit
    
    
    -----------------------
    | HPLIP CONFIGURATION |
    -----------------------
    
    HPLIP-Version: HPLIP 3.19.6
    HPLIP-Home: /usr/share/hplip
    warning: HPLIP-Installation: Auto installation is not supported for 3 distro  20190907 version 
    
    Current contents of '/etc/hp/hplip.conf' file:
    # hplip.conf.  Generated from hplip.conf.in by configure.
    
    [hplip]
    version=3.19.6
    
    [dirs]
    home=/usr/share/hplip
    run=/var/run
    ppd=/usr/share/cups/model/manufacturer-PPDs/hplip
    ppdbase=/usr/share/cups/model/manufacturer-PPDs
    doc=/usr/share/doc/packages/hplip
    html=/usr/share/doc/packages/hplip
    icon=/usr/share/applications
    cupsbackend=/usr/lib/cups/backend
    cupsfilter=/usr/lib/cups/filter
    drv=/usr/lib/cups/driver
    bin=/usr/bin
    apparmor=/etc/apparmor.d
    # Following values are determined at configure time and cannot be changed.
    [configure]
    network-build=yes
    libusb01-build=no
    pp-build=no
    gui-build=yes
    scanner-build=yes
    fax-build=yes
    dbus-build=yes
    cups11-build=no
    doc-build=yes
    shadow-build=no
    hpijs-install=yes
    foomatic-drv-install=no
    foomatic-ppd-install=yes
    foomatic-rip-hplip-install=no
    hpcups-install=yes
    cups-drv-install=no
    cups-ppd-install=yes
    internal-tag=3.19.6
    restricted-build=no
    ui-toolkit=qt5
    qt3=no
    qt4=no
    qt5=yes
    policy-kit=no
    lite-build=no
    udev_sysfs_rules=no
    hpcups-only-build=no
    hpijs-only-build=no
    apparmor_build=no
    class-driver=no
    
    
    Current contents of '/var/lib/hp/hplip.state' file:
    Plugins are not installed. Could not access file: No such file or directory
    
    Current contents of '~/.hplip/hplip.conf' file:
    [installation]
    date_time = 09/11/19 20:55:30
    version = 3.19.6
    
    
     <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>
    
    -------------------------
    | External Dependencies |
    -------------------------
    
     cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.3             OK         'CUPS Scheduler is running'
     gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.27            OK         -
     xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
     scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
     dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.12         OK         -
     policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.116           OK         -
     network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
     avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -
    
    ------------------------
    | General Dependencies |
    ------------------------
    
     libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
     cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.3             OK         -
     cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.3             OK         -
     libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.29'         OK         -
     libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
     sane                 SANE - Scanning library                                      REQUIRED        -               1.0.27          OK         -
     sane-devel           SANE - Scanning library development files                    REQUIRED        -               1.0.27          OK         -
     libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
     libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
     python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.7.3           OK         -
     python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
    Traceback (most recent call last):
      File "/usr/bin/hp-doctor", line 297, in <module>
        num_errors, num_warns = dep.validate(DEPENDENCY_RUN_AND_COMPILE_TIME, False)
      File "/usr/share/hplip/check.py", line 368, in validate
        self.core.dependencies[dep])
      File "/usr/share/hplip/check.py", line 210, in __update_deps_info
        installed_ver = self.core.version_func[deps_info[6]]()
      File "/usr/share/hplip/installer/dcheck.py", line 303, in get_pyQt4_version
        from PyQt4 import QtCore
    ImportError: cannot import name 'QtCore' from 'PyQt4' (unknown location)
    alastair@AJBR-W530:~>
    There still seem to be some errors but await your advice.
    Many thanks for all your efforts on my behalf.
    Regards

  8. #28
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: HP All-in-One Printer No Longer Scanning

    Quote Originally Posted by Budgie2 View Post
    I think I have solved the dependencies so here is the output of hp-doctor again:-
    That looks similar to the output I get (with a working HPLIP environment). Are you able to configure CUPS using the 'hp-setup' utility now?
    openSUSE Leap 15.0; KDE Plasma 5

  9. #29

    Default Re: HP All-in-One Printer No Longer Scanning

    Quote Originally Posted by deano_ferrari View Post
    That looks similar to the output I get (with a working HPLIP environment). Are you able to configure CUPS using the 'hp-setup' utility now?
    Alas still not. Here is the crash handler output:-


    Code:
    Application: python3.7 (python3.7), signal: Aborted
     Using host libthread_db library "/lib64/libthread_db.so.1".
     [Current thread is 1 (Thread 0x7f8ed6612680 (LWP 32663))]
     
    
     Thread 4 (Thread 0x7f8ec69d3700 (LWP 32667)):
     #0  0x00007f8ed6770e05 in pthread_cond_wait@@GLIBC_2.3.2 () at /lib64/libpthread.so.0
     #1  0x00007f8ec72dc35b in  () at /usr/lib64/dri/i965_dri.so
     #2  0x00007f8ec72dac97 in  () at /usr/lib64/dri/i965_dri.so
     #3  0x00007f8ed676afaa in start_thread () at /lib64/libpthread.so.0
     #4  0x00007f8ed6bd073f in clone () at /lib64/libc.so.6
     
    
     Thread 3 (Thread 0x7f8ecd331700 (LWP 32665)):
     #0  0x00007f8ed6bc5cbf in poll () at /lib64/libc.so.6
     #1  0x00007f8ed287c39e in  () at /usr/lib64/libglib-2.0.so.0
     #2  0x00007f8ed287c46f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
     #3  0x00007f8ed355998b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
     #4  0x00007f8ed35021fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
     #5  0x00007f8ed333af91 in QThread::exec() () at /usr/lib64/libQt5Core.so.5
     #6  0x00007f8ecf94b4f6 in  () at /usr/lib64/libQt5DBus.so.5
     #7  0x00007f8ed333c112 in  () at /usr/lib64/libQt5Core.so.5
     #8  0x00007f8ed676afaa in start_thread () at /lib64/libpthread.so.0
     #9  0x00007f8ed6bd073f in clone () at /lib64/libc.so.6
     
    
     Thread 2 (Thread 0x7f8ecf824700 (LWP 32664)):
     #0  0x00007f8ed6bc5cbf in poll () at /lib64/libc.so.6
     #1  0x00007f8ed24f3742 in  () at /usr/lib64/libxcb.so.1
     #2  0x00007f8ed24f43fa in xcb_wait_for_event () at /usr/lib64/libxcb.so.1
     #3  0x00007f8ecfa41f18 in  () at /usr/lib64/libQt5XcbQpa.so.5
     #4  0x00007f8ed333c112 in  () at /usr/lib64/libQt5Core.so.5
     #5  0x00007f8ed676afaa in start_thread () at /lib64/libpthread.so.0
     #6  0x00007f8ed6bd073f in clone () at /lib64/libc.so.6
     
    
     Thread 1 (Thread 0x7f8ed6612680 (LWP 32663)):
     [KCrash Handler]
     #5  0x00007f8ed6b0edd1 in raise () at /lib64/libc.so.6
     #6  0x00007f8ed6af8549 in abort () at /lib64/libc.so.6
     #7  0x00007f8ed3303a59 in  () at /usr/lib64/libQt5Core.so.5
     #8  0x00007f8ed227bf46 in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtCore.so
     #9  0x00007f8ed22837fd in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtCore.so
     #10 0x00007f8ed352e5cc in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib64/libQt5Core.so.5
     #11 0x00007f8ed4028392 in QAbstractButton::clicked(bool) () at /usr/lib64/libQt5Widgets.so.5
     #12 0x00007f8ed40285aa in  () at /usr/lib64/libQt5Widgets.so.5
     #13 0x00007f8ed402994f in  () at /usr/lib64/libQt5Widgets.so.5
     #14 0x00007f8ed4029b15 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () at /usr/lib64/libQt5Widgets.so.5
     #15 0x00007f8ed4695acb in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtWidgets.so
     #16 0x00007f8ed3f75d06 in QWidget::event(QEvent*) () at /usr/lib64/libQt5Widgets.so.5
     #17 0x00007f8ed4696c8b in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtWidgets.so
     #18 0x00007f8ed3f33c42 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
     #19 0x00007f8ed3f3d113 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
     #20 0x00007f8ed47f8516 in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtWidgets.so
     #21 0x00007f8ed35035a2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
     #22 0x00007f8ed3f3c203 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool, bool) () at /usr/lib64/libQt5Widgets.so.5
     #23 0x00007f8ed3f919c9 in  () at /usr/lib64/libQt5Widgets.so.5
     #24 0x00007f8ed3f94a24 in  () at /usr/lib64/libQt5Widgets.so.5
     #25 0x00007f8ed3f33c42 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
     #26 0x00007f8ed3f3cec0 in QApplication::notify(QObject*, QEvent*) () at /usr/lib64/libQt5Widgets.so.5
     #27 0x00007f8ed47f8516 in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtWidgets.so
     #28 0x00007f8ed35035a2 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib64/libQt5Core.so.5
     #29 0x00007f8ed39054b8 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) () at /usr/lib64/libQt5Gui.so.5
     #30 0x00007f8ed3906d3b in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) () at /usr/lib64/libQt5Gui.so.5
     #31 0x00007f8ed38dfacb in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Gui.so.5
     #32 0x00007f8ecfa42e4a in  () at /usr/lib64/libQt5XcbQpa.so.5
     #33 0x00007f8ed287a683 in g_main_context_dispatch () at /usr/lib64/libglib-2.0.so.0
     #34 0x00007f8ed287c430 in  () at /usr/lib64/libglib-2.0.so.0
     #35 0x00007f8ed287c46f in g_main_context_iteration () at /usr/lib64/libglib-2.0.so.0
     #36 0x00007f8ed3559971 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
     #37 0x00007f8ed35021fb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib64/libQt5Core.so.5
     #38 0x00007f8ed3509d72 in QCoreApplication::exec() () at /usr/lib64/libQt5Core.so.5
     #39 0x00007f8ed47f108a in  () at /usr/lib64/python3.7/site-packages/PyQt5/QtWidgets.so
     #40 0x00007f8ed68b6f61 in _PyMethodDef_RawFastCallKeywords () at /usr/lib64/libpython3.7m.so.1.0
     #41 0x00007f8ed68b7093 in _PyCFunction_FastCallKeywords () at /usr/lib64/libpython3.7m.so.1.0
     #42 0x00007f8ed68daa13 in  () at /usr/lib64/libpython3.7m.so.1.0
     #43 0x00007f8ed690d542 in _PyEval_EvalFrameDefault () at /usr/lib64/libpython3.7m.so.1.0
     #44 0x00007f8ed68bc421 in _PyEval_EvalCodeWithName () at /usr/lib64/libpython3.7m.so.1.0
     #45 0x00007f8ed68bd279 in PyEval_EvalCodeEx () at /usr/lib64/libpython3.7m.so.1.0
     #46 0x00007f8ed68bd29b in PyEval_EvalCode () at /usr/lib64/libpython3.7m.so.1.0
     #47 0x00007f8ed6984063 in  () at /usr/lib64/libpython3.7m.so.1.0
     #48 0x00007f8ed6987c17 in PyRun_FileExFlags () at /usr/lib64/libpython3.7m.so.1.0
     #49 0x00007f8ed698de2a in PyRun_SimpleFileExFlags () at /usr/lib64/libpython3.7m.so.1.0
     #50 0x00007f8ed698fe6c in  () at /usr/lib64/libpython3.7m.so.1.0
     #51 0x00007f8ed699001c in _Py_UnixMain () at /usr/lib64/libpython3.7m.so.1.0
     #52 0x00007f8ed6af9bcb in __libc_start_main () at /lib64/libc.so.6
     #53 0x000055c405fa008a in _start ()
     [Inferior 1 (process 32663) detached]
    I still do not understand why you advise the postscript driver will not work with hp-setup but the one I have is the only one offered for this printer and is marked as recommended. Does this mean it is the choice of driver that is the source of the problem? What about the crash handler. Are there clues there which would help?

  10. #30
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: HP All-in-One Printer No Longer Scanning

    Quote Originally Posted by Budgie2 View Post
    I still do not understand why you advise the postscript driver will not work with hp-setup but the one I have is the only one offered for this printer and is marked as recommended. Does this mean it is the choice of driver that is the source of the problem?
    From a printing perspective you're free to choose what works for you. However the scanner function depends on using the hplip driver for printing AFAIU. The 'hp-setup' utility will only help with configuring the hplip driver. (You've configured the postscript driver using YaST or CUPS.)

    What about the crash handler. Are there clues there which would help?
    I'll need more time to research this, or perhaps others can chime in here.
    openSUSE Leap 15.0; KDE Plasma 5

Page 3 of 6 FirstFirst 12345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •