Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: "White dots" on screen

  1. #11

    Default Re: "White dots" on screen

    Quote Originally Posted by unix111 View Post
    I remember those glitches from way back when I tried to tune some of those CrazyDots/PixelWonder and Tseng ET-4000 videocards in my Atari Mega ST to the maximum, most flicker-free sync rates and pixel resolutions back in the 1990s, and later with Matrox-based Linux boxes (remember Matrox? Man, I’m old). Maybe with this problem, we have to go old-school again and analyse the video timings.

    What are your numbers returned from xvidtune and the Xserver logs?
    Sorry! I missed your reply. I rolled back to Windows to get everything working, but here's what I'm seeing on the latest KDE Live disc:

    Code:
    xvidtune -show
    
    "1920x1080"   138.70   1920 1968 2000 2080   1080 1083 1088 1111 +hsync -vsync
    Code:
    grep -i MHz Xorg.0.log 
    
    [   154.616] (II) modeset(0): clock: 138.7 MHz   Image Size:  344 x 194 mm
    [   154.616] (II) modeset(0): clock: 111.0 MHz   Image Size:  344 x 194 mm
    [   154.837] (**) NOUVEAU(G0):  Mode "1920x1080": 173.0 MHz (scaled from 0.0 MHz), 67.2 kHz, 60.0 Hz

    Quote Originally Posted by unix111 View Post
    That’s probably because GRUB re-uses a »safe« VESA timing provided by the computer’s BIOS — or one of the power-on-default timings of the video hardware, usually some 80×25 character mode. Plymouth then tries to set at the earliest point during boot the standard resolution you specified in the Xorg config — or, whatever YaST detected the safe and native resolution to be for your system. Maybe YaST detected something wrong, and now you have display noise. (Windows video drivers may play it safe and not drive the video hardware as close to its limit.)

    Maybe, though, your X server tries to use refresh rates of 75Hz (for CRT monitors) instead of the LCD-typical 60Hz. Let’s fire up xvidtune again, but without parameters this time:

    What does it say on lower-right, how many Hertz on your system?

    (You can also try to play around further with these xvidtune controls, vary the timings slightly; whereas I don’t think this can damage modern video hardware anymore, you might end up with flicker or a garbled/black or otherwise unreadable screen. Therefor please save all work and issue a »sync« before experimenting with xvidtune.)

    Cheers!
    I'm seeing:

    Code:
    Pixel Clock (MHz): 138.70
    Horizontal Sync (kHz): 66.68
    Vertical Sync (Hz): 60.02
    So I'm not entirely sure what to do with that...

  2. #12
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    179

    Default Re: "White dots" on screen

    Quote Originally Posted by raptir View Post
    So I'm not entirely sure what to do with that...
    Neither am I, sorry; these timings seem well within the range of any graphics card and monitor sold during this decade. Safest and simplest options could be changing your monitor cable (HDMI for DVI, even VGA), replacing any video-cable adapters with ones from different vendors, if possible. If you use the Nouveau driver, try the original NVidia one instead (or vice versa) — see this wiki page on openSUSE.org.

    If all else fails, you could try and do something that’s rarely needed nowadays: slightly adjust timings with xvidtune…

    Code:
    "1920x1080"   138.70   1920 1968 2000 2080   1080 1083 1088 1111 +hsync -vsync  # your modeline
    "1920x1080"   148.5    1920 2008 2052 2200   1080 1084 1089 1125 +hsync +vsync  # Others I found searching online for …
    "1920x1080"   173.00   1920 2048 2248 2576   1080 1083 1088 1120 -hsync +vsync  # … "1080 modeline vesa"
    … until you see a clean image, and then copy the resulting modeline manually into xorg.conf.d, following countless descriptions online, or the technical description in the manual page:
    Code:
    man 5 xorg.conf.d
    Further down the rabbit hole, there are descriptions using xrandr I just found in the SUSE support database.

    I remember tweaking modelines for some ancient cards and monitors back in the 1990s. Later, in order to facilitate these settings, SuSE developed a tool called »SaX2«, and nowadays things should just work (as they usually do with Windows and macOS). And when they don’t work like in your case, things regrettably can get complicated quickly.

  3. #13
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,681

    Default Re: "White dots" on screen

    Quote Originally Posted by unix111 View Post
    (remember Matrox? Man, I’m old)
    I forget a lot more as I get older, but not Matrox: https://bugzilla.opensuse.org/show_bug.cgi?id=1004453 https://bugzilla.opensuse.org/show_bug.cgi?id=823658

    If you use the Nouveau driver, try the original NVidia one instead (or vice versa)
    Or neither, if by "Nouveau" you mean xf86-video-nouveau that provides the nouveau DDX, rather than the nouveau kernel driver. Try upstream's default: modesetting, which should be used automagically if neither NVidia tainting nor upstream's optional xf86-video-nouveau are installed. The problem here is more likely Optimus than a simple choice of DDX(s).

    How is the external display connected, VGA, or digital? Internal is digital. If external is VGA, aka analog, it might explain the difference between internal and external. Please run
    Code:
    inxi -GxxSza
    in Konsole and paste input & output here in code tags.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •