Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: Gimp error with nvidia blob, OK with intel graphics

  1. #21
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: Gimp error with nvidia blob, OK with intel graphics

    Leap 15.1 comes with libIex-2_2. If your openSUSE OSS repo has version 2.1, your OSS repo is not Leap 15.1 repository.
    qed
    Code:
    zypper se -s libIex
    Loading repository data...
    Reading installed packages...
    
    S | Name                    | Type    | Version          | Arch   | Repository     
    --+-------------------------+---------+------------------+--------+----------------
    i | libIex-2_2-23           | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
      | libIex-2_2-23-32bit     | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
    i | libIex-2_3-24           | package | 2.3.0-lp151.54.1 | x86_64 | Sauerland-15.1 
      | libIexMath-2_2-23       | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
      | libIexMath-2_2-23-32bit | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
      | libIexMath-2_3-24       | package | 2.3.0-lp151.54.1 | x86_64 | Sauerland-15.1
    @brunomcl

    Leap 15.x packages has a lp15x in their Version string.
    I think you have a mix from Leap 42.3 and Leap 15.1 packages.......

  2. #22
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Reinstalled nvidia G05 and gimp is working.

  3. #23
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: AW: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by Sauerland View Post
    Please post:
    Code:
    zypper se -sir home:Sauerland
    Code:
    :~> zypper se -sir home:Sauerland
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome                  | Tipo   | Versão                                | Arquitetura | Repositório   
    ---+-----------------------+--------+---------------------------------------+-------------+---------------
    i  | gegl                  | pacote | 0.4.17-lp151.14.6                     | x86_64      | home:Sauerland
    i  | gegl-0_4              | pacote | 0.4.17-lp151.14.6                     | x86_64      | home:Sauerland
    i  | gegl-0_4-lang         | pacote | 0.4.17-lp151.14.6                     | noarch      | home:Sauerland
    i  | gegl-0_4-orig-addon   | pacote | 0.4.17-lp151.14.6                     | x86_64      | home:Sauerland
    i+ | gimp                  | pacote | 2.10.12-lp151.2.5                     | x86_64      | home:Sauerland
    i  | gimp-lang             | pacote | 2.10.12-lp151.2.5                     | noarch      | home:Sauerland
    i  | gimp-plugin-aa        | pacote | 2.10.12-lp151.2.5                     | x86_64      | home:Sauerland
    i  | gimp-plugins-python   | pacote | 2.10.12-lp151.2.5                     | x86_64      | home:Sauerland
    i+ | glib2-lang            | pacote | 2.62.0-lp151.666.1                    | noarch      | home:Sauerland
    i  | libHalf24             | pacote | 2.3.0-lp151.54.1                      | x86_64      | home:Sauerland
    i  | libIex-2_3-24         | pacote | 2.3.0-lp151.54.1                      | x86_64      | home:Sauerland
    i  | libIlmImf-2_3-24      | pacote | 2.3.0-lp151.35.1                      | x86_64      | home:Sauerland
    i  | libIlmThread-2_3-24   | pacote | 2.3.0-lp151.54.1                      | x86_64      | home:Sauerland
    i+ | libbabl-0_1-0         | pacote | 0.1.73-lp151.4.1                      | x86_64      | home:Sauerland
    i  | libgegl-0_4-0         | pacote | 0.4.17-lp151.14.6                     | x86_64      | home:Sauerland
    i+ | libgimp-2_0-0         | pacote | 2.10.12-lp151.2.5                     | x86_64      | home:Sauerland
    i+ | libgimpui-2_0-0       | pacote | 2.10.12-lp151.2.5                     | x86_64      | home:Sauerland
    i+ | libglib-2_0-0         | pacote | 2.62.0-lp151.666.1                    | x86_64      | home:Sauerland
    i  | libmypaint-1_3-0      | pacote | 1.3.0-lp151.14.9                      | x86_64      | home:Sauerland
    i  | libmypaint-lang       | pacote | 1.3.0-lp151.14.9                      | noarch      | home:Sauerland
    i  | libwebp7              | pacote | 1.0.3-lp151.2.1                       | x86_64      | home:Sauerland
    i  | libwebpmux3           | pacote | 1.0.3-lp151.2.1                       | x86_64      | home:Sauerland
    i  | mypaint-brushes       | pacote | 1.3.0-lp151.7.1                       | noarch      | home:Sauerland
    i+ | r8168-blacklist-r8169 | pacote | 8.047.04-lp151.60.8                   | x86_64      | home:Sauerland
    i+ | r8168-kmp-default     | pacote | 8.047.04_k4.12.14_lp151.27-lp151.60.8 | x86_64      | home:Sauerland
    i+ | wallpaperswitch       | pacote | 1.0.0.git20190413-lp151.7.1           | x86_64      | home:Sauerland
    :~>

  4. #24
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: AW: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by Sauerland View Post
    qed
    Code:
    zypper se -s libIex
    Loading repository data...
    Reading installed packages...
    
    S | Name                    | Type    | Version          | Arch   | Repository     
    --+-------------------------+---------+------------------+--------+----------------
    i | libIex-2_2-23           | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
      | libIex-2_2-23-32bit     | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
    i | libIex-2_3-24           | package | 2.3.0-lp151.54.1 | x86_64 | Sauerland-15.1 
      | libIexMath-2_2-23       | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
      | libIexMath-2_2-23-32bit | package | 2.2.1-lp151.2.3  | x86_64 | Main Repository
      | libIexMath-2_3-24       | package | 2.3.0-lp151.54.1 | x86_64 | Sauerland-15.1
    @brunomcl

    Leap 15.x packages has a lp15x in their Version string.
    I think you have a mix from Leap 42.3 and Leap 15.1 packages.......
    It seems so, although all defined repos are for 15.1 (post #12 above).

    It is possible that during the upgrade form 42.3 to 15.1 I left the OSS repo and for some reason the installer kept these libraries.
    And indeed Yast show libIex-2_1-11 version is 2.1.0-7.3-x86_64, without the lp51.x.x in the package name.

    I'll remove it, revert to the OSS gimp packages and post back here.

  5. #25
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,680
    Blog Entries
    15

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Hi
    Have you tried the G05 Nvidia drivers instead of the G04 series? I have the same card here, but a) manually installed 430.21 driver and b) it's an openSUSE Leap 15.1 KVM guest with GPU passthrough.

    For me, no issues seen with Gimp....

    Click image for larger version. 

Name:	Screenshot from 2019-09-08 15-09-30.jpg 
Views:	3 
Size:	279.5 KB 
ID:	870
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #26
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: AW: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by brunomcl View Post
    I'll remove it, revert to the OSS gimp packages and post back here.
    No joy, same error as before.

    Code:
    :~> gimp
    GEGL-Message: Erro ao carregar módulo "/usr/lib64/gegl-0.3/exr-load.so": /usr/lib64/libIlmImf-2_2.so.23: undefined symbol: _ZN7Iex_2_27BaseExc6assignERNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE Falha de segmentação (imagem do núcleo gravada)
    Remaining Sauerland package:

    Code:
    :~> zypper se -sir home:Sauerland
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome            | Tipo   | Versão                      | Arquitetura | Repositório   
    ---+-----------------+--------+-----------------------------+-------------+---------------
    i+ | wallpaperswitch | pacote | 1.0.0.git20190413-lp151.7.1 | x86_64      | home:Sauerland
    :~>

  7. #27
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Gimp packages installed, all from Main repo (Repositório principal):

    Code:
    :~> zypper se -i -v gimp
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome                     | Tipo   | Versão           | Arquitetura | Repositório          
    ---+--------------------------+--------+------------------+-------------+----------------------
    i+ | gimp                     | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp
    i+ | gimp-help-pt_BR          | pacote | 2.8.2-lp151.2.1  | noarch      | Repositório principal
        name: gimp-help-pt_BR
    i  | gimp-lang                | pacote | 2.8.22-lp151.4.6 | noarch      | Repositório principal
        name: gimp-lang
    i  | gimp-plugin-aa           | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp-plugin-aa
    i  | gimp-plugins-python      | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp-plugins-python
    i  | inkscape-extensions-gimp | pacote | 0.92.2-lp151.5.4 | x86_64      | Repositório principal
        name: inkscape-extensions-gimp
    i+ | libgimp-2_0-0            | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: libgimp-2_0-0
    i+ | libgimpui-2_0-0          | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: libgimpui-2_0-0
    :~>
    Code:
    :~> zypper se -i -v libIex
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome          | Tipo   | Versão    | Arquitetura | Repositório         
    ---+---------------+--------+-----------+-------------+---------------------
    i+ | libIex-2_2-23 | pacote | 2.2.1-4.2 | x86_64      | (Pacotes do sistema)
        name: libIex-2_2-23
    :~>
    Code:
    :~> zypper se -i -v gegl
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome          | Tipo   | Versão           | Arquitetura | Repositório          
    ---+---------------+--------+------------------+-------------+----------------------
    i+ | gegl          | pacote | 0.3.34-lp151.2.5 | x86_64      | Repositório principal
        name: gegl
    i  | gegl-0_3      | pacote | 0.3.34-lp151.2.5 | x86_64      | Repositório principal
        name: gegl-0_3
    i  | gegl-0_3-lang | pacote | 0.3.34-lp151.2.5 | noarch      | Repositório principal
        name: gegl-0_3-lang
    i  | libgegl-0_3-0 | pacote | 0.3.34-lp151.2.5 | x86_64      | Repositório principal
        name: libgegl-0_3-0
    :~>
    and

    Code:
    :~> zypper se -i -v libIlmImf
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S | Nome             | Tipo   | Versão            | Arquitetura | Repositório                         
    --+------------------+--------+-------------------+-------------+-------------------------------------
    i | libIlmImf-2_2-23 | pacote | 2.2.1-lp151.4.6.1 | x86_64      | Repositório principal de atualização
        name: libIlmImf-2_2-23
    :~>

  8. #28
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have you tried the G05 Nvidia drivers instead of the G04 series? I have the same card here, but a) manually installed 430.21 driver and b) it's an openSUSE Leap 15.1 KVM guest with GPU passthrough.

    For me, no issues seen with Gimp....

    Click image for larger version. 

Name:	Screenshot from 2019-09-08 15-09-30.jpg 
Views:	3 
Size:	279.5 KB 
ID:	870
    Yes, both nouveau and G05. It seems the problem is not with the video driver, as it works for tannington in the same configuration.

    I'm thinking now that the problem is still due to mixed libraries.

    All packages are from the main repo (Repositório principal) http://download.opensuse.org/distribution/leap/$releasever/repo/oss/, where $releasever is 15.1 as shown in the repo list (post #12) and in Yast graphical interface, EXCEPT LibIex-2_2-23, that is from (System Packages) (Pacotes do Sistema). Yast software manager, however, show that the packman version 2.2.1-4.2 is installed, not version 2.2.1-lp151-2-x from the main repo, and the weird thing is that I can't force it to downgrade (or upgrade, can't say with these version numbers) to the main repo version.

    Yast listing:

    Code:
    # Status             Pacote                         | Resumo                                   | Instalado (Disponível)    |    Tamanho
    
    [Manter]             libIex-2_2-23                  | Exception handling library for OpenEXR   | 2.2.1-4.2 (2.2.1-lp151.2.3) |  130,4 KiB
    [Não instalar]       libIex-2_2-23-32bit            | Exception handling library for OpenEXR   | (2.2.1-lp151.2.3)         |  105,6 KiB
    [Não instalar]       libIex-2_3-24                  | Exception handling library for OpenEXR   | (2.3.0-lp151.54.1)        |  172,2 KiB
    [Não instalar]       libIexMath-2_2-23              | Exception-based vector/matrix library... | (2.2.1-lp151.2.3)         |   18,2 KiB
    [Não instalar]       libIexMath-2_2-23-32bit        | Exception-based vector/matrix library... | (2.2.1-lp151.2.3)         |   13,5 KiB
    [Não instalar]       libIexMath-2_3-24              | Exception-based vector/matrix library... | (2.3.0-lp151.54.1)        |   23,3 KiB

  9. #29
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,680
    Blog Entries
    15

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by brunomcl View Post
    Yes, both nouveau and G05. It seems the problem is not with the video driver, as it works for tannington in the same configuration.

    I'm thinking now that the problem is still due to mixed libraries.

    All packages are from the main repo (Repositório principal) http://download.opensuse.org/distribution/leap/$releasever/repo/oss/, where $releasever is 15.1 as shown in the repo list (post #12) and in Yast graphical interface, EXCEPT LibIex-2_2-23, that is from (System Packages) (Pacotes do Sistema). Yast software manager, however, show that the packman version 2.2.1-4.2 is installed, not version 2.2.1-lp151-2-x from the main repo, and the weird thing is that I can't force it to downgrade (or upgrade, can't say with these version numbers) to the main repo version.

    Yast listing:

    Code:
    # Status             Pacote                         | Resumo                                   | Instalado (Disponível)    |    Tamanho
    
    [Manter]             libIex-2_2-23                  | Exception handling library for OpenEXR   | 2.2.1-4.2 (2.2.1-lp151.2.3) |  130,4 KiB
    [Não instalar]       libIex-2_2-23-32bit            | Exception handling library for OpenEXR   | (2.2.1-lp151.2.3)         |  105,6 KiB
    [Não instalar]       libIex-2_3-24                  | Exception handling library for OpenEXR   | (2.3.0-lp151.54.1)        |  172,2 KiB
    [Não instalar]       libIexMath-2_2-23              | Exception-based vector/matrix library... | (2.2.1-lp151.2.3)         |   18,2 KiB
    [Não instalar]       libIexMath-2_2-23-32bit        | Exception-based vector/matrix library... | (2.2.1-lp151.2.3)         |   13,5 KiB
    [Não instalar]       libIexMath-2_3-24              | Exception-based vector/matrix library... | (2.3.0-lp151.54.1)        |   23,3 KiB
    Hi
    Use the full name and -f option;

    Code:
    zypper in -f libIex-2_2-23-2.2.1-lp151.2.3.x86_64
    Else it's a mirror issue, as in the one your being directed to in your locale doesn't have it....

    http://download.opensuse.org/distrib...rpm.mirrorlist
    Check the mirror list above, does it show one in your locale?

    Else just download manually and force the install of the downloaded rpm.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #30
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Use the full name and -f option;

    Code:
    zypper in -f libIex-2_2-23-2.2.1-lp151.2.3.x86_64
    Thanks Malcolm, this forced the change:

    Code:
    # zypper in -f libIex-2_2-23-2.2.1-lp151.2.3.x86_64
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    Forçando a instalação de 'libIex-2_2-23-2.2.1-lp151.2.3.x86_64' do repositório 'Repositório principal'.
    Resolvendo dependências de pacote...
    
    O seguinte pacote será desatualizado:
      libIex-2_2-23
    
    O seguinte pacote irá alterar de fornecedor:
      libIex-2_2-23  http://packman.links2linux.de -> openSUSE
    
    1 pacote a desatualizar, 1 para alterar de fornecedor.
    Tamanho total do download: 34,3 KiB. Já em cache: 0 B. Após a operação, 80,0 B será liberado.
    Continuar? [s/n/v/...? exibe todas as opções] (s): 
    Baixando pacote libIex-2_2-23-2.2.1-lp151.2.3.x86_64                                                                                                                                               (1/1),  34,3 KiB (130,4 KiB descompactado)
    Baixando: libIex-2_2-23-2.2.1-lp151.2.3.x86_64.rpm ..................................................................................................................................................................[concluído (10,6 KiB/s)]
    Verificando por conflito de arquivos: ............................................................................................................................................................................................[concluído]
    (1/1) Instalando: libIex-2_2-23-2.2.1-lp151.2.3.x86_64 ...........................................................................................................................................................................[concluído]
    Existem alguns programas em execução que podem utilizar arquivos removidos pela atualização recente. Convém verificar e reiniciar alguns deles. Execute 'zypper ps -s' para listá-los.
     
    bruno:/home/blimmer # zypper ps -s
    Os seguintes processos em execução usam arquivos removidos:
    
    PID  | PPID | UID  | Usuário | Comando     | Serviço
    -----+------+------+---------+-------------+--------
    2209 | 2194 | 1000 | blimmer | kwin_x11    |        
    2213 | 1    | 1000 | blimmer | krunner     |        
    2215 | 1    | 1000 | blimmer | plasmashell |        
    2282 | 1    | 1000 | blimmer | knemo       |        
    2286 | 1    | 1000 | blimmer | qsynergy    |        
    5119 | 2168 | 1000 | blimmer | konsole     |        
    
    Convém reiniciar estes processos.
    Consulte 'man zypper' para informações sobre o significado dos valores na tabela acima.
    
    Nenhuma biblioteca ou serviço principal foi atualizado.
    A reinicialização provavelmente não é necessária.
    bruno:/home/blimmer #
    However, after a reboot gimp still gives the same error

    I'm starting to think that maybe this will only be fixed by a full system reinstall instead of an upgrade.
    For now I have reinstalled gimp 2.10 and its dependencies from Sauerland's repo and it is working. I will leave it like this, in case of instability I'll come back to this issue.
    This box is my backup work machine, it is more or less a mirror of my main box that is still running 42.3, and I want to get everything right before upgrading it to 15.1.

    Many thanks tannington, Sauerland, arvidjaar and malcolmlewis for your excellent advice!

    Best regards,

    Bruno

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •