Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Gimp error with nvidia blob, OK with intel graphics

  1. #1
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Gimp error with nvidia blob, OK with intel graphics

    Two updates from 42.3 straight to 15.1.

    In the box with intel, gimp starts OK.

    In the box with nvidia, it fails with this message:

    Code:
    :~> gimp GEGL-Message: Erro ao carregar módulo "/usr/lib64/gegl-0.3/exr-load.so": /usr/lib64/libIlmImf-2_2.so.23: undefined symbol: _ZN7Iex_2_27BaseExc6assignERNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE Falha de segmentação (imagem do núcleo gravada)
    This translates aproximatedly to:
    Code:
    :~> gimp GEGL-Message: Error loading module "/usr/lib64/gegl-0.3/exr-load.so":  /usr/lib64/libIlmImf-2_2.so.23: undefined symbol:  _ZN7Iex_2_27BaseExc6assignERNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE Segmentation fault (core image recorded*)
    
    * not sure about this...
    I couldn't find any references to this for 15.1, only 15.0/older.

    Installed nvidia packages:

    Code:
    :~> zypper se -i -v nvidia Carregando dados do reposit?rio... Lendo os pacotes instalados...
    
    S  | Nome                      | Tipo   | Vers?o                              | Arquitetura | Reposit?rio
    ---+---------------------------+--------+-------------------------------------+-------------+------------------------
    i  | nvidia-computeG04         | pacote | 390.129-lp151.6.1                   | x86_64      | nVidia Graphics Drivers
         name: nvidia-computeG04 
    i+ | nvidia-gfxG04-kmp-default | pacote | 390.129_k4.12.14_lp151.27-lp151.6.1 | x86_64      | nVidia Graphics Drivers
         name: nvidia-gfxG04-kmp-default
    i  | nvidia-glG04              | pacote | 390.129-lp151.6.1                   | x86_64      | nVidia Graphics Drivers
         name: nvidia-glG04
    i  | x11-video-nvidiaG04       | pacote | 390.129-lp151.6.1                   | x86_64      | nVidia Graphics Drivers
         name: x11-video-nvidiaG04
    Video card info:

    Code:
    # hwinfo --gfxcard
    20: PCI 100.0: 0300 VGA compatible controller (VGA)
      [Created at pci.386]
      Unique ID: VCu0.L5sDncmDVi1
      Parent ID: vSkL.3rEhpzAE0V6
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia GK208B [GeForce GT 710]"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x128b "GK208B [GeForce GT 710]"
      SubVendor: pci 0x10de "nVidia Corporation"
      SubDevice: pci 0x118b 
      Revision: 0xa1
      Driver: "nvidia"
      Driver Modules: "nvidia"
      Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
      Memory Range: 0xe8000000-0xefffffff (ro,non-prefetchable)
      Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 29 (556648 events)
      Module Alias: "pci:v000010DEd0000128Bsv000010DEsd0000118Bbc03sc00i00"
      Driver Info #0:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Driver Info #1:
        Driver Status: nvidia_drm is active
        Driver Activation Cmd: "modprobe nvidia_drm"
      Driver Info #2:
        Driver Status: nvidia is active
        Driver Activation Cmd: "modprobe nvidia"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #18 (PCI bridge)
    
    Primary display adapter: #20
    Any idea on how to fix this?

    TIA

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,219

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    I'm using the same video card and the gimp (GIMP 2.8.22) starts OK.


    Only difference I immediately see is I have the G05 driver, I guess you could try that instead.

    Code:
    paul@Orion-17:~> sudo zypper se -i -v nvidia
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    
    S  | Name                      | Type    | Version                             | Arch   | Repository                         
    ---+---------------------------+---------+-------------------------------------+--------+------------------------------------
    i+ | nvidia-computeG05         | package | 435.21-lp151.17.1                   | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: nvidia-computeG05
    i+ | nvidia-gfxG05-kmp-default | package | 435.21_k4.12.14_lp151.27-lp151.17.1 | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: nvidia-gfxG05-kmp-default
    i+ | nvidia-glG05              | package | 435.21-lp151.17.1                   | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: nvidia-glG05
    i+ | x11-video-nvidiaG05       | package | 435.21-lp151.17.1                   | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: x11-video-nvidiaG05
    paul@Orion-17:~>
    Code:
    paul@Orion-17:~> sudo hwinfo --gfxcard
    33: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.386]
      Unique ID: VCu0.ubqzgBLGrqC
      Parent ID: _Znp.mxGZ4sT7tg6
      SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia GK208B [GeForce GT 710]"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x128b "GK208B [GeForce GT 710]"
      SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
      SubDevice: pci 0x8c93 
      Revision: 0xa1
      Driver: "nvidia"
      Driver Modules: "nvidia"
      Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
      Memory Range: 0xd0000000-0xd7ffffff (ro,non-prefetchable)
      Memory Range: 0xd8000000-0xd9ffffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 34 (21757 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd0000128Bsv00001462sd00008C93bc03sc00i00"
      Driver Info #0:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Driver Info #1:
        Driver Status: nvidia_drm is active
        Driver Activation Cmd: "modprobe nvidia_drm"
      Driver Info #2:
        Driver Status: nvidia is active
        Driver Activation Cmd: "modprobe nvidia"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #19 (PCI bridge)
    
    Primary display adapter: #33
    paul@Orion-17:~>
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Hi tannington, and thanks for the good idea.

    Unfortunately it segfaults with the same error exactly.

    I've updated the driver to G05 and rebooted, composite is set to OpenGL 2.0 in systemsettings, and desktop effects are working.

    I chose G04 during the upgrade but after installation got the black screen+cursor due to lack of kernel-sources - an omission in the driver dependencies in nvidia repo, I believe.
    So I removed G04 from a console, and after rebooting to the desktop with nouveau. I reinstalled it, and it compiled the ko module OK.

    I've avoided G05 because I had serious trouble when I installed a GFX1050 in a box with G03 and oS 42.3. Thanks to outstanding help from this forum I could fix it.

    I tought about downgrading to G03, but since G05 works for you - and for me, except gimp - I doubt it will make a difference.

    We are both with the same card and driver version, so I'm really lost.

    Code:
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome                      | Tipo   | Versão                              | Arquitetura | Repositório            
    ---+---------------------------+--------+-------------------------------------+-------------+------------------------
    i+ | nvidia-computeG05         | pacote | 435.21-lp151.17.1                   | x86_64      | nVidia Graphics Drivers
        name: nvidia-computeG05
    i  | nvidia-gfxG05-kmp-default | pacote | 435.21_k4.12.14_lp151.27-lp151.17.1 | x86_64      | nVidia Graphics Drivers
        name: nvidia-gfxG05-kmp-default
    i  | nvidia-glG05              | pacote | 435.21-lp151.17.1                   | x86_64      | nVidia Graphics Drivers
        name: nvidia-glG05
    i  | x11-video-nvidiaG05       | pacote | 435.21-lp151.17.1                   | x86_64      | nVidia Graphics Drivers
        name: x11-video-nvidiaG05
    Quote Originally Posted by tannington View Post
    I'm using the same video card and the gimp (GIMP 2.8.22) starts OK.


    Only difference I immediately see is I have the G05 driver, I guess you could try that instead.

    Code:
    paul@Orion-17:~> sudo zypper se -i -v nvidia
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    
    S  | Name                      | Type    | Version                             | Arch   | Repository                         
    ---+---------------------------+---------+-------------------------------------+--------+------------------------------------
    i+ | nvidia-computeG05         | package | 435.21-lp151.17.1                   | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: nvidia-computeG05
    i+ | nvidia-gfxG05-kmp-default | package | 435.21_k4.12.14_lp151.27-lp151.17.1 | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: nvidia-gfxG05-kmp-default
    i+ | nvidia-glG05              | package | 435.21-lp151.17.1                   | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: nvidia-glG05
    i+ | x11-video-nvidiaG05       | package | 435.21-lp151.17.1                   | x86_64 | nVidia Graphics Drivers (Leap 15.1)
        name: x11-video-nvidiaG05
    paul@Orion-17:~>
    Code:
    paul@Orion-17:~> sudo hwinfo --gfxcard
    33: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.386]
      Unique ID: VCu0.ubqzgBLGrqC
      Parent ID: _Znp.mxGZ4sT7tg6
      SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia GK208B [GeForce GT 710]"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x128b "GK208B [GeForce GT 710]"
      SubVendor: pci 0x1462 "Micro-Star International Co., Ltd. [MSI]"
      SubDevice: pci 0x8c93 
      Revision: 0xa1
      Driver: "nvidia"
      Driver Modules: "nvidia"
      Memory Range: 0xfd000000-0xfdffffff (rw,non-prefetchable)
      Memory Range: 0xd0000000-0xd7ffffff (ro,non-prefetchable)
      Memory Range: 0xd8000000-0xd9ffffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 34 (21757 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v000010DEd0000128Bsv00001462sd00008C93bc03sc00i00"
      Driver Info #0:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Driver Info #1:
        Driver Status: nvidia_drm is active
        Driver Activation Cmd: "modprobe nvidia_drm"
      Driver Info #2:
        Driver Status: nvidia is active
        Driver Activation Cmd: "modprobe nvidia"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #19 (PCI bridge)
    
    Primary display adapter: #33
    paul@Orion-17:~>

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Also, gimp packages and versions are exactly the same in both installs:

    Code:
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome                     | Tipo   | Versão           | Arquitetura | Repositório          
    ---+--------------------------+--------+------------------+-------------+----------------------
    i+ | gimp                     | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp
    i  | gimp-help                | pacote | 2.8.2-lp151.2.1  | noarch      | Repositório principal
        name: gimp-help
    i+ | gimp-help-pt_BR          | pacote | 2.8.2-lp151.2.1  | noarch      | Repositório principal
        name: gimp-help-pt_BR
    i  | gimp-lang                | pacote | 2.8.22-lp151.4.6 | noarch      | Repositório principal
        name: gimp-lang
    i  | gimp-plugin-aa           | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp-plugin-aa
    i  | gimp-plugins-python      | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp-plugins-python
    i  | inkscape-extensions-gimp | pacote | 0.92.2-lp151.5.4 | x86_64      | Repositório principal
        name: inkscape-extensions-gimp
    i+ | libgimp-2_0-0            | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: libgimp-2_0-0
    i+ | libgimpui-2_0-0          | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: libgimpui-2_0-0
    Yours are the same?

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Also, would you check your libraries version?

    Code:
    /usr/lib64/gegl-0.3/exr-load.so
    /usr/lib64/libIlmImf-2_2.so.23

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: Gimp error with nvidia blob, OK with intel graphics

    Please post as root:
    Code:
    LANG=en_EN zypper se -si | grep -Ei 'systemp|system p|system'
    Code:
    zypper lr -d

  7. #7
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,219

    Default Re: AW: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by brunomcl View Post
    Also, would you check your libraries version?

    Code:
    /usr/lib64/gegl-0.3/exr-load.so
    /usr/lib64/libIlmImf-2_2.so.23
    Code:
    "gegl-0.3/exr-load.so" Ver: 0.3.34-lp151.2.5
    "libIlmImf-2_2.so.23"  Ver: 2.2.1-lp151.4.6.1
    Quote Originally Posted by Sauerland View Post
    Please post as root:
    Code:
    LANG=en_EN zypper se -si | grep -Ei 'systemp|system p|system'
    Code:
    zypper lr -d
    Just for comparison:
    Code:
    Orion-17:~ # zypper se -si | grep -Ei 'systemp|system p|system'
    i  | filesystem                           | package | 15.0-lp151.9.2                            | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | grub2-systemd-sleep-plugin           | package | 2.02-lp151.21.6.1                         | noarch | Update Repository (OSS Leap 15.1)              
    i  | kde4-filesystem                      | package | 4.14-lp151.2.1                            | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | kernel-default                       | package | 4.12.14-lp150.12.70.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default                       | package | 4.12.14-lp150.12.67.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default-devel                 | package | 4.12.14-lp150.12.70.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default-devel                 | package | 4.12.14-lp150.12.67.1                     | x86_64 | (System Packages)                              
    i+ | kernel-devel                         | package | 4.12.14-lp150.12.70.1                     | noarch | (System Packages)                              
    i+ | kernel-devel                         | package | 4.12.14-lp150.12.67.1                     | noarch | (System Packages)                              
    i  | libKF5WindowSystem5                  | package | 5.55.0-lp151.1.1                          | x86_64 | Main Repository (OSS Leap 15.1)                
    i  | libboost_filesystem1_66_0            | package | 1.66.0-lp151.4.5                          | x86_64 | Main Repository (OSS Leap 15.1)                
    i  | libboost_system1_66_0                | package | 1.66.0-lp151.4.5                          | x86_64 | Main Repository (OSS Leap 15.1)                
    il | libdvdcss2                           | package | 1.4.2-lp150.1.2                           | x86_64 | (System Packages)                              
    il | liberation2-fonts                    | package | 2.00.1-12.1                               | noarch | (System Packages)                              
    i+ | libsystemd0                          | package | 234-lp151.25.7                            | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | libsystemd0-32bit                    | package | 234-lp151.25.7                            | x86_64 | Main Repository (OSS Leap 15.1)                
    il | noto-sans-fonts                      | package | 20170919-lp150.2.1                        | noarch | (System Packages)                              
    i  | patterns-base-basesystem             | package | 20171206-lp151.29.1                       | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | python-pychm                         | package | 0.8.4.1-5.2                               | x86_64 | (System Packages)                              
    i+ | system-config-printer                | package | 1.5.7-lp151.6.3                           | x86_64 | Main Repository (OSS Leap 15.1)                
    i  | system-config-printer-applet         | package | 1.5.7-lp151.6.3                           | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-config-printer-common         | package | 1.5.7-lp151.6.3                           | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-config-printer-dbus-service   | package | 1.5.7-lp151.6.3                           | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-group-hardware                | package | 20170617-lp151.4.70                       | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-user-lp                       | package | 20170617-lp151.4.70                       | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-user-man                      | package | 20170617-lp151.4.70                       | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-user-news                     | package | 20170617-lp151.4.70                       | noarch | Main Repository (OSS Leap 15.1)                
    i  | system-user-nobody                   | package | 20170617-lp151.4.70                       | noarch | Main Repository (OSS Leap 15.1)                
    i+ | system-user-root                     | package | 20190513-lp151.3.3.1                      | noarch | Update Repository (OSS Leap 15.1)              
    i+ | systemd                              | package | 234-lp151.25.7                            | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | systemd-32bit                        | package | 234-lp151.25.7                            | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | systemd-bash-completion              | package | 234-lp151.25.7                            | noarch | Main Repository (OSS Leap 15.1)                
    i  | systemd-presets-branding-openSUSE    | package | 12.2-lp151.13.2                           | noarch | Main Repository (OSS Leap 15.1)                
    i  | systemd-presets-common-SUSE          | package | 15-lp151.7.1                              | noarch | Main Repository (OSS Leap 15.1)                
    i+ | systemd-sysvinit                     | package | 234-lp151.25.7                            | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | systemsettings5                      | package | 5.12.8-lp151.1.2                          | x86_64 | Main Repository (OSS Leap 15.1)                
    i+ | util-linux-systemd                   | package | 2.33.1-lp151.2.23                         | x86_64 | Main Repository (OSS Leap 15.1)                
    Orion-17:~ #
    Code:
    Orion-17:~ # zypper lr -d
    #  | Alias                           | Name                                            | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                             | Service
    ---+---------------------------------+-------------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------------------------+--------
     1 | KDE_Extra_(Leap_42.2)           | KDE Extra (Leap 15.1)                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_Leap_15.1                         |        
     2 | Mozilla_(Leap_42.3)_ESR         | Mozilla (Leap 15.1)                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.1/                           |        
     3 | download.nvidia.com-leap        | nVidia Graphics Drivers (Leap 15.1)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/15.1                                                   |        
     4 | download.opensuse.org-non-oss   | Main Repository (Non-OSS Leap 15.1)             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/                               |        
     5 | download.opensuse.org-non-oss_1 | Update Repository (Non-OSS Leap 15.1)           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                                          |        
     6 | download.opensuse.org-oss       | Main Repository (OSS Leap 15.1)                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                                   |        
     7 | download.opensuse.org-oss_1     | Update Repository (OSS Leap 15.1)               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                                               |        
     8 | openSUSE_Leap_15.0              | Graphics [for Darktable] (Leap 15.1)            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/graphics/openSUSE_Leap_15.1                          |        
     9 | openSUSE_Leap_15.1              | Python Development (for Recoll recommended pkg) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/devel:languages:python:backports/openSUSE_Leap_15.1/ |        
    10 | opensuse-guide.org-repo         | Libdvdcss Repository                            | No      | ----      | ----    |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                                              |        
    11 | packman.inode.at-suse           | Packman (Leap 15.1)                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.1/                              |        
    Orion-17:~ #
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,219

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Thought for a moment I only had Leap 15.0 kernels installed

    Code:
    Orion-17:~ # zypper se -si | grep -Ei 'kernel'
    i+ | kernel-default                       | package | 4.12.14-lp150.12.70.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default                       | package | 4.12.14-lp150.12.67.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default                       | package | 4.12.14-lp151.28.13.1                     | x86_64 | Update Repository (OSS Leap 15.1)              
    i+ | kernel-default-devel                 | package | 4.12.14-lp150.12.70.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default-devel                 | package | 4.12.14-lp150.12.67.1                     | x86_64 | (System Packages)                              
    i+ | kernel-default-devel                 | package | 4.12.14-lp151.28.13.1                     | x86_64 | Update Repository (OSS Leap 15.1)              
    i+ | kernel-devel                         | package | 4.12.14-lp150.12.70.1                     | noarch | (System Packages)                              
    i+ | kernel-devel                         | package | 4.12.14-lp150.12.67.1                     | noarch | (System Packages)                              
    i+ | kernel-devel                         | package | 4.12.14-lp151.28.13.1                     | noarch | Update Repository (OSS Leap 15.1)              
    i+ | kernel-firmware                      | package | 20190618-lp151.2.6.1                      | noarch | Update Repository (OSS Leap 15.1)              
    i+ | kernel-macros                        | package | 4.12.14-lp151.28.13.1                     | noarch | Update Repository (OSS Leap 15.1)              
    Orion-17:~ #
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  9. #9
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,219

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by brunomcl View Post
    Also, gimp packages and versions are exactly the same in both installs:

    Code:
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    
    S  | Nome                     | Tipo   | Versão           | Arquitetura | Repositório          
    ---+--------------------------+--------+------------------+-------------+----------------------
    i+ | gimp                     | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp
    i  | gimp-help                | pacote | 2.8.2-lp151.2.1  | noarch      | Repositório principal
        name: gimp-help
    i+ | gimp-help-pt_BR          | pacote | 2.8.2-lp151.2.1  | noarch      | Repositório principal
        name: gimp-help-pt_BR
    i  | gimp-lang                | pacote | 2.8.22-lp151.4.6 | noarch      | Repositório principal
        name: gimp-lang
    i  | gimp-plugin-aa           | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp-plugin-aa
    i  | gimp-plugins-python      | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: gimp-plugins-python
    i  | inkscape-extensions-gimp | pacote | 0.92.2-lp151.5.4 | x86_64      | Repositório principal
        name: inkscape-extensions-gimp
    i+ | libgimp-2_0-0            | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: libgimp-2_0-0
    i+ | libgimpui-2_0-0          | pacote | 2.8.22-lp151.4.6 | x86_64      | Repositório principal
        name: libgimpui-2_0-0
    Yours are the same?
    Sorry, missed that first time...

    These are the gimp packages I've installed:
    Code:
    Orion-17:~ # zypper se -si | grep -Ei 'gimp'
    i+ | gimp                                     | package | 2.8.22-lp151.4.6                           | x86_64 | Main Repository                                
    i  | gimp-help                                | package | 2.8.2-lp151.2.1                            | noarch | Main Repository                                
    i+ | gimp-help-en_GB                          | package | 2.8.2-lp151.2.1                            | noarch | Main Repository                                
    i  | libgimp-2_0-0                            | package | 2.8.22-lp151.4.6                           | x86_64 | Main Repository                                
    i  | libgimpui-2_0-0                          | package | 2.8.22-lp151.4.6                           | x86_64 | Main Repository                                
    Orion-17:~ #
    Regards, Paul

    Tumbleweed (Snapshot: 20190918) KDE Plasma 5
    Non-Tumbling Tumblweed (20150508) KDE 4 - Resurrected
    2x Leap 15.1 KDE Plasma 5

  10. #10
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: AW: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by Sauerland View Post
    Please post as root:
    Code:
    LANG=en_EN zypper se -si | grep -Ei 'systemp|system p|system'
    Code:
    zypper lr -d
    Hi, sorry for the late response, I've been away for the last couple of days.

    Requested info (part 1):
    Code:
    # LANG=en_EN zypper se -si | grep -Ei 'systemp|system p|system'
    i+ | MSGViewer                                | package | 1.9-1                                      | noarch | (System Packages)                   
    i+ | bricscadv18                              | package | 18.2.28-1                                  | x86_64 | (System Packages)                   
    i  | ffmpeg-3                                 | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i+ | filesystem                               | package | 15.0-lp151.9.2                             | x86_64 | Repositório principal               
    il | ghostscript                              | package | 9.15-10.1                                  | x86_64 | (System Packages)                   
    il | ghostscript-x11                          | package | 9.15-10.1                                  | x86_64 | (System Packages)                   
    i+ | google-earth-pro-stable                  | package | 7.3.2.5776-0                               | x86_64 | (System Packages)                   
    i+ | grub2-systemd-sleep-plugin               | package | 2.02-lp151.21.6.1                          | noarch | Repositório principal de atualização
    i+ | k3b                                      | package | 18.12.3-2.1                                | x86_64 | (System Packages)                   
    i+ | k3b-lang                                 | package | 18.12.3-2.1                                | noarch | (System Packages)                   
    i+ | kde4-filesystem                          | package | 4.14-lp151.2.1                             | x86_64 | Repositório principal               
    i+ | kernel-default                           | package | 4.4.180-102.1                              | x86_64 | (System Packages)                   
    i+ | kernel-default-devel                     | package | 4.4.180-102.1                              | x86_64 | (System Packages)                   
    i+ | kernel-devel                             | package | 4.4.180-102.1                              | noarch | (System Packages)                   
    i+ | kio_sysinfo                              | package | 42.3-18.6                                  | x86_64 | (System Packages)                   
    i+ | libHalf11                                | package | 2.1.0-7.3                                  | x86_64 | (System Packages)                   
    i+ | libHalf23                                | package | 2.2.1-4.2                                  | x86_64 | (System Packages)                   
    i+ | libIex-2_1-11                            | package | 2.1.0-7.3                                  | x86_64 | (System Packages)                   
    i+ | libIex-2_2-23                            | package | 2.2.1-4.2                                  | x86_64 | (System Packages)                   
    i+ | libIlmImf-Imf_2_1-21                     | package | 2.1.0-10.3.1                               | x86_64 | (System Packages)                   
    i+ | libIlmThread-2_1-11                      | package | 2.1.0-7.3                                  | x86_64 | (System Packages)                   
    i  | libIlmThread-2_2-23                      | package | 2.2.1-4.2                                  | x86_64 | (System Packages)                   
    i+ | libKF5WindowSystem5                      | package | 5.55.0-lp151.1.1                           | x86_64 | Repositório principal               
    i+ | libKF5WindowSystem5-lang                 | package | 5.55.0-lp151.1.1                           | noarch | Repositório principal               
    i+ | libass5                                  | package | 0.13.4-3.4                                 | x86_64 | (System Packages)                   
    i+ | libavcodec56                             | package | 2.8.15-10.2                                | x86_64 | (System Packages)                   
    i+ | libavcodec57                             | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libavcodec58                             | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libavdevice57                            | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libavdevice58                            | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libavfilter6                             | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libavfilter7                             | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libavformat56                            | package | 2.8.15-10.2                                | x86_64 | (System Packages)                   
    i+ | libavformat57                            | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libavformat58                            | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libavresample3                           | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libavresample4                           | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libavutil54                              | package | 2.8.15-10.2                                | x86_64 | (System Packages)                   
    i+ | libavutil55                              | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libavutil56                              | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i  | libboost_filesystem1_66_0                | package | 1.66.0-lp151.4.5                           | x86_64 | Repositório principal               
    i  | libboost_system1_66_0                    | package | 1.66.0-lp151.4.5                           | x86_64 | Repositório principal               
    i+ | libdvdcss2                               | package | 1.4.0-1.1                                  | x86_64 | (System Packages)                   
    i+ | libfaac0                                 | package | 1.29.9.2-2.7                               | x86_64 | (System Packages)                   
    i+ | libfaad2                                 | package | 2.8.8-1.7                                  | x86_64 | (System Packages)                   
    i+ | libfdk-aac1                              | package | 0.1.6-2.1                                  | x86_64 | (System Packages)                   
    i+ | libgnutls28                              | package | 3.3.27-2.3.1                               | x86_64 | (System Packages)                   
    i+ | libhogweed2                              | package | 2.7.1-12.1                                 | x86_64 | (System Packages)                   
    i+ | libmjpegutils-2_0-0                      | package | 2.0.0-19.15                                | x86_64 | (System Packages)                   
    i  | libmpeg2-0                               | package | 0.5.1-6.7                                  | x86_64 | (System Packages)                   
    i+ | libnettle4                               | package | 2.7.1-12.1                                 | x86_64 | (System Packages)                   
    i+ | libopencore-amrnb0                       | package | 0.1.5-1.8                                  | x86_64 | (System Packages)                   
    i+ | libopencore-amrwb0                       | package | 0.1.5-1.8                                  | x86_64 | (System Packages)                   
    i+ | libpostproc54                            | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libpostproc55                            | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libpython3_4m1_0                         | package | 3.4.6-12.10.1                              | x86_64 | (System Packages)                   
    i+ | libquicktime0                            | package | 1.2.4cvs20150223-12.16                     | x86_64 | (System Packages)                   
    i  | librtmp1                                 | package | 2.4.20151223.fa8646d-1.9                   | x86_64 | (System Packages)                   
    i+ | libsidplay1                              | package | 1.36.59-162.3                              | x86_64 | (System Packages)                   
    i+ | libsox3                                  | package | 14.4.2-5.5.7                               | x86_64 | (System Packages)                   
    i+ | libswresample1                           | package | 2.8.15-10.2                                | x86_64 | (System Packages)                   
    i+ | libswresample2                           | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libswresample3                           | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libswscale4                              | package | 3.4.4-10.2                                 | x86_64 | (System Packages)                   
    i  | libswscale5                              | package | 4.0.2-22.2                                 | x86_64 | (System Packages)                   
    i+ | libsystemd0                              | package | 234-lp151.25.7                             | x86_64 | Repositório principal

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •