Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31

Thread: Gimp error with nvidia blob, OK with intel graphics

  1. #11
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Part 2 (the full listing has more than 15000 characters):

    Code:
    i+ | libsystemd0-32bit                        | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i+ | libva-drm1                               | package | 1.7.3-1.3                                  | x86_64 | (System Packages)                   
    i+ | libva-x11-1                              | package | 1.7.3-1.3                                  | x86_64 | (System Packages)                   
    i+ | libva1                                   | package | 1.7.3-1.3                                  | x86_64 | (System Packages)                   
    i  | libvapoursynth-43                        | package | 43-11.3                                    | x86_64 | (System Packages)                   
    i  | libvapoursynth-script0                   | package | 43-11.3                                    | x86_64 | (System Packages)                   
    i+ | libvidstab1_1                            | package | 1.1.0-10.4                                 | x86_64 | (System Packages)                   
    i+ | libvpx1                                  | package | 1.3.0-8.1                                  | x86_64 | (System Packages)                   
    i+ | libwebp5                                 | package | 0.4.3-9.3                                  | x86_64 | (System Packages)                   
    i+ | libx264-148                              | package | 0.148svn20170816-1.1                       | x86_64 | (System Packages)                   
    i+ | libx264-152                              | package | 0.152svn20180305-5.3                       | x86_64 | (System Packages)                   
    i+ | libx265-130                              | package | 2.5-1.1                                    | x86_64 | (System Packages)                   
    i+ | libx265-151                              | package | 2.7-3.4                                    | x86_64 | (System Packages)                   
    i+ | libx265-165                              | package | 2.9-1.4                                    | x86_64 | (System Packages)                   
    i  | libx265-169                              | package | 3.0-1.2                                    | x86_64 | (System Packages)                   
    i  | libx265-176                              | package | 3.1.2-1.1                                  | x86_64 | (System Packages)                   
    i+ | libxvidcore4                             | package | 1.3.5-2.2                                  | x86_64 | (System Packages)                   
    i  | libzimg2                                 | package | 2.7.4-1.6                                  | x86_64 | (System Packages)                   
    i+ | mjpegtools                               | package | 2.0.0-19.15                                | x86_64 | (System Packages)                   
    i+ | openSUSE-release-dvd                     | package | 15.1-lp151.298.1                           | x86_64 | (System Packages)                   
    i  | patterns-base-basesystem                 | package | 20171206-lp151.29.1                        | x86_64 | Repositório principal               
    i  | smplayer-skins                           | package | 15.2.0-1.1                                 | noarch | (System Packages)                   
    i+ | sox                                      | package | 14.4.2-5.5.7                               | x86_64 | (System Packages)                   
    i+ | system-config-printer                    | package | 1.5.7-lp151.6.3                            | x86_64 | Repositório principal               
    i+ | system-config-printer-applet             | package | 1.5.7-lp151.6.3                            | noarch | Repositório principal               
    i+ | system-config-printer-common             | package | 1.5.7-lp151.6.3                            | noarch | Repositório principal               
    i+ | system-config-printer-common-lang        | package | 1.5.7-lp151.6.3                            | noarch | Repositório principal               
    i+ | system-config-printer-dbus-service       | package | 1.5.7-lp151.6.3                            | noarch | Repositório principal               
    i  | system-group-hardware                    | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-group-wheel                       | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-bin                          | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-daemon                       | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-lp                           | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-mail                         | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-man                          | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-nobody                       | package | 20170617-lp151.4.70                        | noarch | Repositório principal               
    i  | system-user-root                         | package | 20190513-lp151.3.3.1                       | noarch | Repositório principal de atualização
    i+ | systemd                                  | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i+ | systemd-32bit                            | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i+ | systemd-bash-completion                  | package | 234-lp151.25.7                             | noarch | Repositório principal               
    i  | systemd-container                        | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i  | systemd-coredump                         | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i+ | systemd-logger                           | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i+ | systemd-presets-branding-openSUSE        | package | 12.2-lp151.13.2                            | noarch | Repositório principal               
    i  | systemd-presets-common-SUSE              | package | 15-lp151.7.1                               | noarch | Repositório principal               
    i+ | systemd-sysvinit                         | package | 234-lp151.25.7                             | x86_64 | Repositório principal               
    i+ | systemsettings5                          | package | 5.12.8-lp151.1.2                           | x86_64 | Repositório principal               
    i+ | systemsettings5-lang                     | package | 5.12.8-lp151.1.2                           | noarch | Repositório principal               
    i+ | util-linux-systemd                       | package | 2.33.1-lp151.2.23                          | x86_64 | Repositório principal

  2. #12
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    And:

    Code:
    # zypper lr -d
    #  | Apelido                             | Nome                                 | Habilitado | Verificação GPG | Atualizar | Prioridade | Tipo   | URI                                                                           | Serviço
    ---+-------------------------------------+--------------------------------------+------------+-----------------+-----------+------------+--------+-------------------------------------------------------------------------------+--------
     1 | download.nvidia.com-leap            | nVidia Graphics Drivers              | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | https://download.nvidia.com/opensuse/leap/15.1                                |        
     2 | http-download.opensuse.org-6d99ad1d | home:Sauerland                       | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/reposit...USE_Leap_15.1/ |        
     3 | openSUSE-Leap-15.1-1                | openSUSE-Leap-15.1-1                 | Não        | ----            | ----      |   99       | rpm-md | cd:/?devices=/dev/disk/by-id/ata-ATAPI_iHAS122_3522405_358122501753           |        
     4 | packman.inode.at-suse               | Packman Repository                   | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/                              |        
     5 | repo-debug                          | Debug Repository                     | Não        | ----            | ----      |   99       | rpm-md | http://download.opensuse.org/debug/d...15.1/repo/oss/           |        
     6 | repo-debug-non-oss                  | Debug Repository (Non-OSS)           | Não        | ----            | ----      |   99       | rpm-md | http://download.opensuse.org/debug/d.../repo/non-oss/       |        
     7 | repo-debug-update                   | Update Repository (Debug)            | Não        | ----            | ----      |   99       | rpm-md | http://download.opensuse.org/debug/u...leap/15.1/oss/                      |        
     8 | repo-debug-update-non-oss           | Update Repository (Debug, Non-OSS)   | Não        | ----            | ----      |   99       | rpm-md | http://download.opensuse.org/debug/u.../15.1/non-oss/                  |        
     9 | repo-non-oss                        | Repositório Non-OSS                  | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/             |        
    10 | repo-oss                            | Repositório principal                | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/distrib...15.1/repo/oss/                 |        
    11 | repo-source                         | Source Repository                    | Não        | ----            | ----      |   99       | rpm-md | http://download.opensuse.org/source/...15.1/repo/oss/          |        
    12 | repo-source-non-oss                 | Source Repository (Non-OSS)          | Não        | ----            | ----      |   99       | rpm-md | http://download.opensuse.org/source/.../repo/non-oss/      |        
    13 | repo-update                         | Repositório principal de atualização | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                             |        
    14 | repo-update-non-oss                 | Repositório de atualização (Non-OSS) | Sim        | (r ) Sim        | Sim       |   99       | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                        |
    Thank you.

  3. #13
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: AW: Gimp error with nvidia blob, OK with intel graphics

    [QUOTE=tannington;2913544]
    Code:
    "gegl-0.3/exr-load.so" Ver: 0.3.34-lp151.2.5
    "libIlmImf-2_2.so.23"  Ver: 2.2.1-lp151.4.6.1
    How do you query the module version form the command line? I could only see the package versions in Yast.

    Anyway, the versions seem to match:

    Code:
    # Status             Pacote                         | Resumo                                   | Instalado (Disponível)    |    Tamanho
    
    [Manter]             gegl-0_3                       | Generic Graphics Library                 | 0.3.34-lp151.2.5          |    2,3 MiB
    [Manter]             gegl-0_3-lang                  | Translations for package gegl            | 0.3.34-lp151.2.5          |    2,2 MiB
    [Manter]             libgegl-0_3-0                  | Generic Graphics Library                 | 0.3.34-lp151.2.5          |  742,1 KiB
    [Manter]             openSUSE-release               | openSUSE Leap 15.1                       | 15.1-lp151.298.1          |  220,4 KiB
    [Não instalar]       gegl                           | Generic Graphics Library                 | (0.4.17-lp151.14.6)       |   63,4 KiB
    [Não instalar]       gegl-0_4                       | Generic Graphics Library                 | (0.4.17-lp151.14.6)       |    3,0 MiB
    [Não instalar]       gegl-0_4-lang                  | Translations for package gegl            | (0.4.17-lp151.14.6)       |    3,0 MiB
    [Não instalar]       gegl-0_4-orig-addon            | Generic Graphics Library                 | (0.4.17-lp151.14.6)       |   33,2 KiB
    [Não instalar]       gegl-devel                     | Generic Graphics Library                 | (0.4.17-lp151.14.6)       |  485,3 KiB
    [Não instalar]       gegl-doc                       | Documentation for the GEGL "Generic G... | (0.3.34-lp151.2.5)        |    2,6 MiB
    [Não instalar]       libgegl-0_4-0                  | Generic Graphics Library                 | (0.4.17-lp151.14.6)       |  916,9 KiB
    [Não instalar]       libmypaint-devel               | Header files for libmypaint, a brushs... | (1.3.0-lp151.14.9)        |   24,4 KiB
    [Não instalar]       libmypaint-gegl-devel          | Header files for libmypaint, a brushs... | (1.3.0-lp151.14.9)        |    1,8 KiB
    [Não instalar]       libmypaint-gegl0               | GEGL bindings for libmypaint, a brush... | (1.3.0-lp151.14.9)        |   17,8 KiB
    [Não instalar]       typelib-1_0-Gegl-0_3           | Introspection bindings for the GEGL "... | (0.3.34-lp151.2.5)        |   37,5 KiB
    libIlmImf:

    Code:
    # Status             Pacote                         | Resumo                                   | Instalado (Disponível)    |    Tamanho
    
    [Manter]             libIlmImf-2_2-23               | Library to Handle EXR Pictures in 16-... | 2.2.1-lp151.4.6.1         |    2,8 MiB
    [Manter]             libIlmImf-Imf_2_1-21           | Library to Handle EXR Pictures in 16-... | 2.1.0-10.3.1              |    1,1 MiB
    [Manter]             libIlmThread-2_1-11            | Base library for ILM software (OpenEXR)  | 2.1.0-7.3                 |   26,7 KiB
    [Manter]             libIlmThread-2_2-23            | Thread abstraction library for OpenEXR   | 2.2.1-4.2 (2.2.1-lp151.2.3) |   26,6 KiB
    [Manter]             openSUSE-release               | openSUSE Leap 15.1                       | 15.1-lp151.298.1          |  220,4 KiB
    [Não instalar]       ilmbase-devel                  | Base library for ILM software (OpenEXR)  | (2.3.0-lp151.54.1)        |  550,5 KiB
    [Não instalar]       libIlmImf-2_2-23-32bit         | Library to Handle EXR Pictures in 16-... | (2.2.1-lp151.4.6.1)       |    2,8 MiB
    [Não instalar]       libIlmImf-2_3-24               | Library to Handle EXR Pictures in 16-... | (2.3.0-lp151.35.1)        |    3,0 MiB
    [Não instalar]       libIlmImfUtil-2_2-23           | Library to simplify development of Op... | (2.2.1-lp151.4.6.1)       |  149,9 KiB
    [Não instalar]       libIlmImfUtil-2_2-23-32bit     | Library to simplify development of Op... | (2.2.1-lp151.4.6.1)       |  142,5 KiB
    [Não instalar]       libIlmImfUtil-2_3-24           | Library to simplify development of Op... | (2.3.0-lp151.35.1)        |  194,5 KiB
    [Não instalar]       libIlmThread-2_2-23-32bit      | Thread abstraction library for OpenEXR   | (2.2.1-lp151.2.3)         |   25,7 KiB
    [Não instalar]       libIlmThread-2_3-24            | Thread abstraction library for OpenEXR   | (2.3.0-lp151.54.1)        |   42,6 KiB

  4. #14
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by tannington View Post
    Sorry, missed that first time...

    These are the gimp packages I've installed:
    Code:
    Orion-17:~ # zypper se -si | grep -Ei 'gimp'
    i+ | gimp                                     | package | 2.8.22-lp151.4.6                           | x86_64 | Main Repository                                
    i  | gimp-help                                | package | 2.8.2-lp151.2.1                            | noarch | Main Repository                                
    i+ | gimp-help-en_GB                          | package | 2.8.2-lp151.2.1                            | noarch | Main Repository                                
    i  | libgimp-2_0-0                            | package | 2.8.22-lp151.4.6                           | x86_64 | Main Repository                                
    i  | libgimpui-2_0-0                          | package | 2.8.22-lp151.4.6                           | x86_64 | Main Repository                                
    Orion-17:~ #
    I removed the gimp packages you don't have installed, but it still errors out with just

    Code:
    # zypper se -si | grep -Ei 'gimp'
    i+ | gimp                                     | pacote   | 2.8.22-lp151.4.6                           | x86_64      | Repositório principal               
    i  | gimp-help                                | pacote   | 2.8.2-lp151.2.1                            | noarch      | Repositório principal               
    i+ | libgimp-2_0-0                            | pacote   | 2.8.22-lp151.4.6                           | x86_64      | Repositório principal               
    i+ | libgimpui-2_0-0                          | pacote   | 2.8.22-lp151.4.6                           | x86_64      | Repositório principal               
    #
    which are the exact same packages you have. I'm stumped!

  5. #15
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: Gimp error with nvidia blob, OK with intel graphics

    Please post:
    Code:
    zypper se -sir home:Sauerland

  6. #16
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    I don't think the problem is nvidia, as it works for you, but on the off-chance I uninstalled nvidia G05, Yast automagically reverted to nouveau. Rebooted but still get the gimp error.

    However, both nouveau and nvidia appear in the modules listing, and I don't know if this is normal:

    Code:
    :~> lsmod | grep nouveau
    nouveau              2170880  0
    mxm_wmi                16384  1 nouveau
    wmi                    28672  2 mxm_wmi,nouveau
    ttm                   126976  1 nouveau
    i2c_algo_bit           16384  1 nouveau
    video                  45056  1 nouveau
    button                 16384  1 nouveau
    drm_kms_helper        208896  2 nouveau,nvidia_drm
    drm                   491520  5 nouveau,ttm,nvidia_drm,drm_kms_helper
    :~> lsmod | grep nvidia
    nvidia_drm             49152  0
    nvidia_modeset       1122304  1 nvidia_drm
    nvidia_uvm            991232  0
    nvidia              19513344  2 nvidia_modeset,nvidia_uvm
    drm_kms_helper        208896  2 nouveau,nvidia_drm
    drm                   491520  5 nouveau,ttm,nvidia_drm,drm_kms_helper
    ipmi_msghandler        65536  2 nvidia,ipmi_devintf
    :~>
    Code:
    :~> zypper se -i -v nvidia
    Carregando dados do repositório...
    Lendo os pacotes instalados...
    Nenhum item correspondente encontrado. (<-- no corresponding item found)
    :~>

  7. #17
    Join Date
    Sep 2012
    Posts
    5,041

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by brunomcl View Post
    Code:
    :~> gimp GEGL-Message: Error loading module "/usr/lib64/gegl-0.3/exr-load.so":  /usr/lib64/libIlmImf-2_2.so.23: undefined symbol:  _ZN7Iex_2_27BaseExc6assignERNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE Segmentation fault (core image recorded*)
    Symbol _ZN7Iex_2_27BaseExc6assignERNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE is defined in shared library libIex. Do you have it installed? Which version? What is output of
    Code:
    ldd /usr/lib64/libIlmImf-2_2.so.23
    nm -D /usr/lib64/libIex-2_2.so.23 | grep Iex_2_27BaseExc6assign

  8. #18
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Ah, getting there...

    I use Sauerland repo for wallpaper switch, and it has gimp-2.10.12-lp151.2.5 and gegl-0_4-0.4.17-lp151.14.6.
    After installing these and their dependencies (26 packages in total), gimp works!

    Actually all toolbox icons were no stop signs, had to switch to legacy icons, but that is fine.

    Now on to reinstall G05 and see how it goes. If so maybe a bug report is in order.

  9. #19
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,879

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by arvidjaar View Post
    Symbol _ZN7Iex_2_27BaseExc6assignERNSt7__cxx1118basic_stringstreamIcSt11char_traitsIcESaIcEEE is defined in shared library libIex. Do you have it installed? Which version? What is output of
    Code:
    ldd /usr/lib64/libIlmImf-2_2.so.23
    nm -D /usr/lib64/libIex-2_2.so.23 | grep Iex_2_27BaseExc6assign
    Code:
    # ldd /usr/lib64/libIlmImf-2_2.so.23
            linux-vdso.so.1 (0x00007fff957c3000)
            libz.so.1 => /lib64/libz.so.1 (0x00007f0cc45c1000)
            libHalf.so.23 => /usr/lib64/libHalf.so.23 (0x00007f0cc437e000)
            libIex-2_2.so.23 => /usr/lib64/libIex-2_2.so.23 (0x00007f0cc415d000)
            libIlmThread-2_2.so.23 => /usr/lib64/libIlmThread-2_2.so.23 (0x00007f0cc3f56000)
            libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f0cc3d38000)
            libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f0cc39ae000)
            libm.so.6 => /lib64/libm.so.6 (0x00007f0cc3676000)
            libc.so.6 => /lib64/libc.so.6 (0x00007f0cc32bc000)
            libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f0cc30a4000)
            /lib64/ld-linux-x86-64.so.2 (0x00007f0cc4cab000)
    # nm -D /usr/lib64/libIex-2_2.so.23 | grep Iex_2_27BaseExc6assign
    0000000000018620 T _ZN7Iex_2_27BaseExc6assignERSt18basic_stringstreamIcSt11char_traitsIcESaIcEE
    #


    But these are after installing gimp from Sauerland repo.

    From Yast:

    Code:
    # Status             Pacote                         | Resumo                                   | Instalado (Disponível)    |    Tamanho
    
    [Manter]             libIex-2_1-11                  | Base library for ILM software (OpenEXR)  | 2.1.0-7.3                 |  130,4 KiB
    [Manter]             libIex-2_2-23                  | Exception handling library for OpenEXR   | 2.2.1-4.2 (2.2.1-lp151.2.3) |  130,4 KiB
    [Manter]             libIex-2_3-24                  | Exception handling library for OpenEXR   | 2.3.0-lp151.54.1          |  172,2 KiB
    [Não instalar]       libIex-2_2-23-32bit            | Exception handling library for OpenEXR   | (2.2.1-lp151.2.3)         |  105,6 KiB
    [Não instalar]       libIexMath-2_2-23              | Exception-based vector/matrix library... | (2.2.1-lp151.2.3)         |   18,2 KiB
    [Não instalar]       libIexMath-2_2-23-32bit        | Exception-based vector/matrix library... | (2.2.1-lp151.2.3)         |   13,5 KiB
    [Não instalar]       libIexMath-2_3-24              | Exception-based vector/matrix library... | (2.3.0-lp151.54.1)        |   23,3 KiB
    libIex-2_1-11 is from openSUSE OSS repo
    libIex-2_2-23 is from packman
    libIex-2_3-24 is from Sauerland repo.

  10. #20
    Join Date
    Sep 2012
    Posts
    5,041

    Default Re: Gimp error with nvidia blob, OK with intel graphics

    Quote Originally Posted by brunomcl View Post
    libIex-2_1-11 is from openSUSE OSS repo
    Leap 15.1 comes with libIex-2_2. If your openSUSE OSS repo has version 2.1, your OSS repo is not Leap 15.1 repository.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •