Results 1 to 4 of 4

Thread: Fehler in /usr/lib/libfontconfig.so.1.12.0

  1. #1

    Default Fehler in /usr/lib/libfontconfig.so.1.12.0

    Seit dem Update der LIB /usr/lib/libfontconfig.so.1.12.0 funktionieren einige Programme nicht mehr.
    Folgende Fehlermeldungen:
    qcad-3.5.1-pro-linux-x86_32/qcad-bin: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var
    Bei FreeCAD funktioniert der Import von svg Dateien nicht mehr.

    Mit: /usr/lib->ln -s libfontconfig.so.1.8.0 libfontconfig.so.1 kann ich zwar die Programme wieder starten, jedoch
    beim Aufruf von fonts-config werden jede Menge Fehler ausgegeben.

    Besteht die Möglichkeit die fehlende Funktion von der vorherigen Version zu übernehmen ?

    Für jede Hilfe Dankbar.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,978

    Default AW: Fehler in /usr/lib/libfontconfig.so.1.12.0

    Freecad hat ein failed seit ca 10 Tagen:
    https://build.opensuse.org/package/s...actory/FreeCAD

    Und damit benutzt du eine Version, die gegen die ältere fontconfig gebaut wurde.......
    Bugreport.
    https://lists.opensuse.org/opensuse-.../msg00209.html
    https://lists.opensuse.org/opensuse-.../msg00347.html


    Wahrscheinlich wird es bei qcad ähnlich aussehen, das gibt es aber nur im kde3 Repo oder in /home Repos.
    Bugreport.

  3. #3

    Default Re: AW: Fehler in /usr/lib/libfontconfig.so.1.12.0

    Quote Originally Posted by Sauerland View Post
    Freecad hat ein failed seit ca 10 Tagen:
    https://build.opensuse.org/package/s...actory/FreeCAD

    Und damit benutzt du eine Version, die gegen die ältere fontconfig gebaut wurde.......
    Bugreport.
    https://lists.opensuse.org/opensuse-.../msg00209.html
    https://lists.opensuse.org/opensuse-.../msg00347.html


    Wahrscheinlich wird es bei qcad ähnlich aussehen, das gibt es aber nur im kde3 Repo oder in /home Repos.
    Bugreport.
    Ich hab das Problem gelöst:
    download fontconfig-2.13.92.tar.gz -> untar -> edit config.h.in
    comment // #undef HAVE_FT_DONE_MM_VAR
    ./configure
    make
    make install

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,978

    Default AW: Fehler in /usr/lib/libfontconfig.so.1.12.0

    Ein Update wird dies wieder überschreiben........

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •