Results 1 to 10 of 10

Thread: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

  1. #1

    Default Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Hallo,

    Beim Starten der Updateinstallation mittels 'zypper dup' kam heute folgende Meldung:

    Code:
    Doppelbock:~ # zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    Problem: libgdal26-3.0.1-1.4.x86_64 requires libnetcdf.so.13()(64bit), but this requirement cannot be provided
      deleted providers: libnetcdf13-4.6.1-4.1.x86_64
     Solution 1: deinstallation of libgdal26-3.0.1-1.4.x86_64
     Solution 2: keep obsolete libnetcdf13-4.6.1-4.1.x86_64
     Solution 3: break libgdal26-3.0.1-1.4.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c/d/?] (c): d
    Problem: libgdal26-3.0.1-1.4.x86_64 requires libnetcdf.so.13()(64bit), but this requirement cannot be provided
      deleted providers: libnetcdf13-4.6.1-4.1.x86_64
    Detailed information: 
            libgdal26-3.0.1-1.4.x86_64 requires libnetcdf.so.13()(64bit), but this requirement cannot be provided
            libnetcdf13-4.6.1-4.1.x86_64 does not belong to a distupgrade repository
            nothing provides libnetcdf.so.13 needed by libgdal26-3.0.1-1.4.i586
     Solution 1: deinstallation of libgdal26-3.0.1-1.4.x86_64
     Solution 2: keep obsolete libnetcdf13-4.6.1-4.1.x86_64
     Solution 3: break libgdal26-3.0.1-1.4.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c/d/?] (c):
    Wie gehe ich da am Besten vor?
    Wie finde ich heraus, zu welchem Programm oder was auch immer die problematischen Dateien gehören?

  2. #2
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,000

    Default Re: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Quote Originally Posted by Lotosdrache View Post
    Hallo,

    Beim Starten der Updateinstallation mittels 'zypper dup' kam heute folgende Meldung:

    Code:
    Doppelbock:~ # zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    Problem: libgdal26-3.0.1-1.4.x86_64 requires libnetcdf.so.13()(64bit), but this requirement cannot be provided
      deleted providers: libnetcdf13-4.6.1-4.1.x86_64
     Solution 1: deinstallation of libgdal26-3.0.1-1.4.x86_64
     Solution 2: keep obsolete libnetcdf13-4.6.1-4.1.x86_64
     Solution 3: break libgdal26-3.0.1-1.4.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c/d/?] (c): d
    Problem: libgdal26-3.0.1-1.4.x86_64 requires libnetcdf.so.13()(64bit), but this requirement cannot be provided
      deleted providers: libnetcdf13-4.6.1-4.1.x86_64
    Detailed information: 
            libgdal26-3.0.1-1.4.x86_64 requires libnetcdf.so.13()(64bit), but this requirement cannot be provided
            libnetcdf13-4.6.1-4.1.x86_64 does not belong to a distupgrade repository
            nothing provides libnetcdf.so.13 needed by libgdal26-3.0.1-1.4.i586
     Solution 1: deinstallation of libgdal26-3.0.1-1.4.x86_64
     Solution 2: keep obsolete libnetcdf13-4.6.1-4.1.x86_64
     Solution 3: break libgdal26-3.0.1-1.4.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/c/d/?] (c):
    Wie gehe ich da am Besten vor?
    Wie finde ich heraus, zu welchem Programm oder was auch immer die problematischen Dateien gehören?
    Auswahl durch Exklusion: deinstallieren? Nein, kaputt machen? Nein. Obsolete Version behalten? Ja!.

    Code:
    erlangen:~ # zypper if libnetcdf13
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libnetcdf13:
    ------------------------------------
    Repository     : Haupt-Repository (OSS)                                
    Name           : libnetcdf13                                           
    Version        : 4.7.0-1.1                                             
    Arch           : x86_64                                                
    Vendor         : openSUSE                                              
    Installed Size : 1.5 MiB                                               
    Installed      : Yes                                                   
    Status         : out-of-date (version 4.6.1-4.1 installed)             
    Source package : netcdf-4.7.0-1.1.src                                  
    Summary        : Shared libraries for the NetCDF scientific data format
    Description    :                                                       
        NetCDF is a set of software libraries and self-describing,
        machine-independent data formats that support the creation, access,
        and sharing of array-oriented scientific data.
    
        NetCDF (network Common Data Form) is an interface for array-oriented
        data access and a collection of software libraries
        for C, Fortran, C++, and Perl that provides an implementation of the
        interface. The NetCDF library also defines a machine-independent
        format for representing scientific data. Together, the interface,
        library, and format support the creation, access, and sharing of
        scientific data.
    
        NetCDF data is:
           - Self-Describing: A NetCDF file includes information about the
             data it contains.
           - Network-transparent:  A NetCDF file is represented in a form that
             can be accessed by computers with different ways of storing
             integers, characters, and floating-point numbers.
           - Direct-access:  A small subset of a large dataset may be accessed
             efficiently, without first reading through all the preceding
             data.
           - Appendable:  Data can be appended to a NetCDF dataset along one
             dimension without copying the dataset or redefining its
             structure. The structure of a NetCDF dataset can be changed,
             though this sometimes causes the dataset to be copied.
           - Sharable:  One writer and multiple readers may simultaneously
             access the same NetCDF file.
    
    
        This package contains the NetCDF runtime libraries.
    
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  3. #3
    Join Date
    Sep 2018
    Location
    Osnabrüvk
    Posts
    7

    Default Re: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Ich hatte vorgestern das gleiche Problem und gestern bin ich kopfüber in den Abgrund gesprungen, indem ich versucht habe das Problem zu lösen
    Mein Vorgehen *** grano salis betrachten, da ich nicht weiß, inwiefern das "reproduzierbar" bzw. "nachahmenswert" ist.
    Ich habe das Problem nicht vollends verstanden, aber meine Gedanken und Taten soweit:

    Ich arbeite mit an einer Karten-Software:
    Dazu benötigen wir Postgresql (aktuell 11) und nutzen Postgis, was anscheined GDAL als abhängigkeit hat. Das wiederum scheint die Abhängigkeit auf die libnetcdf zu besitzen.
    Mein Vorgehen:
    1) den ganzen Ramsch runter von der Platte
    2) Aktuell installiert habe ich:

    Code:
    i+ | gdal2                   | GDAL/OGR - a translator library for raster and vector geospatial data formats | package   
    i+ | gdal2-devel             | GDAL library header files                                                     | package   
    i  | libgdal20               | GDAL static libraries                                                         | package   
    i  | libgdal26               | GDAL static libraries                                                         | package
    i  | libnetcdf13                                        | Shared libraries for the NetCDF scientific data format               | package
    i+ | netcdf                                             | Command-line programs for the NetCDF scientific data format          | package
    i  | netcdf-devel-data                                  | Development data files for netcdf                                    | package
    i+ | netcdf-devel-static                                | Static development files for netcdf                                  | package
    i  | postgresql                                    | Basic Clients and Utilities for PostgreSQL                                  | package   
    i  | postgresql-contrib                            | Contributed Extensions and Additions to PostgreSQL                          | package   
    i  | postgresql-server                             | The Programs Needed to Create and Run a PostgreSQL Server                   | package   
    i+ | postgresql11                                  | Basic Clients and Utilities for PostgreSQL                                  | package   
    i+ | postgresql11-contrib                          | Contributed Extensions and Additions to PostgreSQL                          | package   
    i  | postgresql11-devel                            | PostgreSQL client development header files and libraries                    | package   
    i+ | postgresql11-postgis                          | Geographic Information Systems Extensions to PostgreSQL                     | package   
    i+ | postgresql11-postgis-devel                    | Development files for postgresql11-postgis                                  | package   
    i+ | postgresql11-server                           | The Programs Needed to Create and Run a PostgreSQL Server                   | packag
    Das bescherte mir eine libnetcdf.so.15.0.1. Das Paket selbst verlinkte
    Code:
    lrwxrwxrwx 1 root root      19 Sep  2 13:58 libnetcdf.so.15 -> libnetcdf.so.15.0.1
    und ich habe einfach "just for fun" das gleiche Spiel mitgemacht:

    Code:
    ln -s libnetcdf.so.15 libnetcdf.so.13
    Das setzt einen symbolischen Link nach libnetcdf.so.15 (effektiv nach libnetcdf.so.15.0.1).
    Soweit alles okay.

    P.S.: ich war ja kurz davor, libnetcdf selbst zu bauen, habe dann beim Durchlesen der Buildschritte ersteinmal bitterlich geweint und wieder Abstand davon genommen.

  4. #4
    Join Date
    Sep 2018
    Location
    Osnabrüvk
    Posts
    7

    Default AW: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Ich weiß ja nicht, was die da gebastelt haben, aber:

    Code:
    zypper se -i --requires netcdf
    Loading repository data...
    Reading installed packages...
    
    
    S  | Name              | Summary                                                     | Type   
    ---+-------------------+-------------------------------------------------------------+--------
    i  | libgdal20         | GDAL static libraries                                       | package
    i  | libgdal26         | GDAL static libraries                                       | package
    i+ | netcdf            | Command-line programs for the NetCDF scientific data format | package
    i  | netcdf-devel-data | Development data files for netcdf                           | package
    
    
    zypper se -i --requires libnetcdf13
    Loading repository data...
    Reading installed packages...
    
    
    S  | Name   | Summary                                                     | Type   
    ---+--------+-------------------------------------------------------------+--------
    i+ | netcdf | Command-line programs for the NetCDF scientific data format | package
    Anscheinend war die .so in libnetcdf13 mit drin(?).

    Vielleicht hilft es, vor dem update netcdf zu installieren (ich hatte es komischerweise nicht) und dann das upgrade zu machen (ohne erst alles deinstallieren zu müssen).

    P.S.: was zur ... habe gerade gesehen, das Latein hier geächtet ist ... man darf nicht *** grano salis schreiben what the?!

  5. #5

    Default Re: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Danke für Eure Antworten.

    netcdf ist bei mir wohl nicht installiert:
    Code:
    Doppelbock:~ # zypper if netcdf
    Loading repository data...
    Reading installed packages...
    
    
    Information for package netcdf:
    -------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                                    
    Name           : netcdf                                                     
    Version        : 4.7.0-1.1                                                  
    Arch           : x86_64                                                     
    Vendor         : openSUSE                                                   
    Installed Size : 634.2 KiB                                                  
    Installed      : No                                                         
    Status         : not installed                                              
    Source package : netcdf-4.7.0-1.1.src                                       
    Summary        : Command-line programs for the NetCDF scientific data format
    Description    :                                                            
        NetCDF is a set of software libraries and self-describing,
        machine-independent data formats that support the creation, access,
        and sharing of array-oriented scientific data.
    
    
        This package contains utility functions for working with NetCDF files.
    
    Doppelbock:~ #
    libgdal26 und libnetcdf13 dagegen schon:
    Code:
    Doppelbock:~ # zypper if libgdal26
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libgdal26:
    ----------------------------------
    Repository     : openSUSE-Tumbleweed-Oss
    Name           : libgdal26              
    Version        : 3.0.1-1.4              
    Arch           : x86_64                 
    Vendor         : openSUSE               
    Installed Size : 19.7 MiB               
    Installed      : Yes (automatically)    
    Status         : up-to-date             
    Source package : gdal-3.0.1-1.4.src     
    Summary        : GDAL static libraries  
    Description    :                        
        GDAL and OGR are translator libraries for raster and vector geospatial data
        formats. As a library, it presents a single abstract data model to the calling
        application for all supported formats.
    
    Doppelbock:~ # zypper if libnetcdf13
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libnetcdf13:
    ------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                               
    Name           : libnetcdf13                                           
    Version        : 4.7.0-1.1                                             
    Arch           : x86_64                                                
    Vendor         : openSUSE                                              
    Installed Size : 1.5 MiB                                               
    Installed      : Yes (automatically)                                   
    Status         : out-of-date (version 4.6.1-4.1 installed)             
    Source package : netcdf-4.7.0-1.1.src                                  
    Summary        : Shared libraries for the NetCDF scientific data format
    Description    :                                                       
        NetCDF is a set of software libraries and self-describing,
        machine-independent data formats that support the creation, access,
        and sharing of array-oriented scientific data.
    
        NetCDF (network Common Data Form) is an interface for array-oriented
        data access and a collection of software libraries
        for C, Fortran, C++, and Perl that provides an implementation of the
        interface. The NetCDF library also defines a machine-independent
        format for representing scientific data. Together, the interface,
        library, and format support the creation, access, and sharing of
        scientific data.
    
        NetCDF data is:
           - Self-Describing: A NetCDF file includes information about the
             data it contains.
           - Network-transparent:  A NetCDF file is represented in a form that
             can be accessed by computers with different ways of storing
             integers, characters, and floating-point numbers.
           - Direct-access:  A small subset of a large dataset may be accessed
             efficiently, without first reading through all the preceding
             data.
           - Appendable:  Data can be appended to a NetCDF dataset along one
             dimension without copying the dataset or redefining its
             structure. The structure of a NetCDF dataset can be changed,
             though this sometimes causes the dataset to be copied.
           - Sharable:  One writer and multiple readers may simultaneously
             access the same NetCDF file.
    
    
        This package contains the NetCDF runtime libraries.
    
    Doppelbock:~ #
    Wenn ich dann die Abhängigkeiten teste, kommt auch nichts weiter raus:
    Code:
    Doppelbock:~ # zypper se -i --requires libgdal26
    Loading repository data...
    Reading installed packages...
    No matching items found.
    Doppelbock:~ # zypper se -i --requires libnetcdf13
    Loading repository data...
    Reading installed packages...
    No matching items found.
    Doppelbock:~ #
    Ich werde jetzt einfach mal das veraltete Teil behalten und schaun, was passiert.

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,000

    Default Re: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Quote Originally Posted by Lotosdrache View Post
    Danke für Eure Antworten.
    Wenn ich dann die Abhängigkeiten teste, kommt auch nichts weiter raus:
    Code:
    Doppelbock:~ # zypper se -i --requires libgdal26
    Loading repository data...
    Reading installed packages...
    No matching items found.
    Doppelbock:~ # zypper se -i --requires libnetcdf13
    Loading repository data...
    Reading installed packages...
    No matching items found.
    Doppelbock:~ #
    Ich werde jetzt einfach mal das veraltete Teil behalten und schaun, was passiert.
    Das Kommando arbeitet anders:

    Code:
    erlangen:~ # zypper if --provides libnetcdf13
    Loading repository data...
    Reading installed packages...
    
    
    Information for package libnetcdf13:
    ------------------------------------
    Repository     : Haupt-Repository (OSS)                                
    Name           : libnetcdf13                                           
    Version        : 4.7.0-1.1                                             
    Arch           : x86_64                                                
    Vendor         : openSUSE                                              
    Installed Size : 1.5 MiB                                               
    Installed      : Yes                                                   
    Status         : out-of-date (version 4.6.1-4.1 installed)             
    Source package : netcdf-4.7.0-1.1.src                                  
    Summary        : Shared libraries for the NetCDF scientific data format
    Description    :                                                       
        NetCDF is a set of software libraries and self-describing,
    ....
        This package contains the NetCDF runtime libraries.
    Provides       : [5]                                                   
        libnetcdf.so.15()(64bit)
        libnetcdf = 4.7.0
        libnetcdf-4 = 4.7.0
        libnetcdf13 = 4.7.0-1.1
        libnetcdf13(x86-64) = 4.7.0-1.1
    
    erlangen:~ #
    Eine Library "provides", ein Programm "requires":

    Code:
    erlangen:~ # zypper if --requires qmapshack
    Loading repository data...
    Reading installed packages...
    
    
    Information for package qmapshack:
    ----------------------------------
    Repository     : Application_Geo                         
    Name           : qmapshack                               
    Version        : 1.13.1-1.3                              
    Arch           : x86_64                                  
    Vendor         : obs://build.opensuse.org/Application:Geo
    Installed Size : 16.6 MiB                                
    Installed      : Yes                                     
    Status         : up-to-date                              
    Source package : qmapshack-1.13.1-1.3.src                
    Summary        : GPS data display                        
    Description    :                                         
        QMapShack is a consumer grade software to work with data
        aquired by GPS devices. The data can be displayed on a
        variety of maps and stored in a database. Additionally
        new data can be created to plan your next trip.
    Requires       : [46]                                    
        libc.so.6(GLIBC_2.14)(64bit)
        libm.so.6()(64bit)
        libm.so.6(GLIBC_2.2.5)(64bit)
        libstdc++.so.6()(64bit)
        libstdc++.so.6(GLIBCXX_3.4)(64bit)
        libgcc_s.so.1()(64bit)
        libstdc++.so.6(CXXABI_1.3)(64bit)
        libgcc_s.so.1(GCC_3.0)(64bit)
        libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
        libm.so.6(GLIBC_2.29)(64bit)
        libstdc++.so.6(CXXABI_1.3.9)(64bit)
        libgcc_s.so.1(GCC_3.3.1)(64bit)
        libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
        libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
        libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
        gdal
        proj
        libproj.so.15()(64bit)
        libgdal.so.26()(64bit)
        libQt5Core.so.5()(64bit)
        libQt5Core.so.5(Qt_5)(64bit)
        libQt5Gui.so.5()(64bit)
        libQt5Gui.so.5(Qt_5)(64bit)
        libQt5Widgets.so.5()(64bit)
        libQt5Widgets.so.5(Qt_5)(64bit)
        libQt5Core.so.5(Qt_5.13)(64bit)
        libQt5Xml.so.5()(64bit)
        libQt5Xml.so.5(Qt_5)(64bit)
        libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
        libQt5Network.so.5()(64bit)
        libQt5Network.so.5(Qt_5)(64bit)
        libQt5PrintSupport.so.5()(64bit)
        libQt5PrintSupport.so.5(Qt_5)(64bit)
        libQt5DBus.so.5()(64bit)
        libQt5DBus.so.5(Qt_5)(64bit)
        libQt5Qml.so.5()(64bit)
        libQt5Qml.so.5(Qt_5)(64bit)
        libQt5Sql.so.5()(64bit)
        libQt5Sql.so.5(Qt_5)(64bit)
        libroutino.so.0()(64bit)
        libQt5WebEngineWidgets.so.5()(64bit)
        libQt5WebEngineWidgets.so.5(Qt_5)(64bit)
        libjpeg.so.62()(64bit)
        libjpeg.so.62(LIBJPEG_6.2)(64bit)
        libquazip5.so.1()(64bit)
        routino >= 3.1.0
    
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,000

    Default Re: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Quote Originally Posted by ThomasJunk View Post
    Ich hatte vorgestern das gleiche Problem und gestern bin ich kopfüber in den Abgrund gesprungen, indem ich versucht habe das Problem zu lösen
    Mein Vorgehen *** grano salis betrachten, da ich nicht weiß, inwiefern das "reproduzierbar" bzw. "nachahmenswert" ist.
    Ich habe das Problem nicht vollends verstanden, aber meine Gedanken und Taten soweit:

    Ich arbeite mit an einer Karten-Software:
    Dazu benötigen wir Postgresql (aktuell 11) und nutzen Postgis, was anscheined GDAL als abhängigkeit hat. Das wiederum scheint die Abhängigkeit auf die libnetcdf zu besitzen.
    Mein Vorgehen:
    1) den ganzen Ramsch runter von der Platte
    2) Aktuell installiert habe ich:

    Code:
    i+ | gdal2                   | GDAL/OGR - a translator library for raster and vector geospatial data formats | package   
    i+ | gdal2-devel             | GDAL library header files                                                     | package   
    i  | libgdal20               | GDAL static libraries                                                         | package   
    i  | libgdal26               | GDAL static libraries                                                         | package
    i  | libnetcdf13                                        | Shared libraries for the NetCDF scientific data format               | package
    i+ | netcdf                                             | Command-line programs for the NetCDF scientific data format          | package
    i  | netcdf-devel-data                                  | Development data files for netcdf                                    | package
    i+ | netcdf-devel-static                                | Static development files for netcdf                                  | package
    i  | postgresql                                    | Basic Clients and Utilities for PostgreSQL                                  | package   
    i  | postgresql-contrib                            | Contributed Extensions and Additions to PostgreSQL                          | package   
    i  | postgresql-server                             | The Programs Needed to Create and Run a PostgreSQL Server                   | package   
    i+ | postgresql11                                  | Basic Clients and Utilities for PostgreSQL                                  | package   
    i+ | postgresql11-contrib                          | Contributed Extensions and Additions to PostgreSQL                          | package   
    i  | postgresql11-devel                            | PostgreSQL client development header files and libraries                    | package   
    i+ | postgresql11-postgis                          | Geographic Information Systems Extensions to PostgreSQL                     | package   
    i+ | postgresql11-postgis-devel                    | Development files for postgresql11-postgis                                  | package   
    i+ | postgresql11-server                           | The Programs Needed to Create and Run a PostgreSQL Server                   | packag
    Das bescherte mir eine libnetcdf.so.15.0.1. Das Paket selbst verlinkte
    Code:
    lrwxrwxrwx 1 root root      19 Sep  2 13:58 libnetcdf.so.15 -> libnetcdf.so.15.0.1
    und ich habe einfach "just for fun" das gleiche Spiel mitgemacht:

    Code:
    ln -s libnetcdf.so.15 libnetcdf.so.13
    Das setzt einen symbolischen Link nach libnetcdf.so.15 (effektiv nach libnetcdf.so.15.0.1).
    Soweit alles okay.

    P.S.: ich war ja kurz davor, libnetcdf selbst zu bauen, habe dann beim Durchlesen der Buildschritte ersteinmal bitterlich geweint und wieder Abstand davon genommen.
    Bei mir ist qmapshack installiert. Das benötigt libgdal26, was wiederum libnetcdf13 benötigt. Ich habe jetzt:

    Code:
    erlangen:~ # ll /usr/lib64/libnetcdf.so.15 /usr/lib64/libnetcdf.so.13
    lrwxrwxrwx 2 root root 19 Sep  2 13:58 /usr/lib64/libnetcdf.so.13 -> libnetcdf.so.15.0.1
    lrwxrwxrwx 2 root root 19 Sep  2 13:58 /usr/lib64/libnetcdf.so.15 -> libnetcdf.so.15.0.1
    erlangen:~ #
    Damit läuft qmapshack wieder. Schwindeln funktioniert in diesem Fall.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  8. #8
    Join Date
    Sep 2018
    Location
    Osnabrüvk
    Posts
    7

    Default AW: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    @karlmistelberger
    Schwindeln funktioniert in diesem Fall.
    Genau. Wir lügen ja nicht
    Aber interessantes aside. Ich habe das Verlinken erst nach dem Installieren gemacht (für mein Gewissen oder so). Von den Abhängigkeiten her, ließ sich alles auch ohne installieren.

    ¯\_(ツ)_/¯

  9. #9
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,000

    Default Re: AW: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Quote Originally Posted by ThomasJunk View Post
    Ich habe das Verlinken erst nach dem Installieren gemacht (für mein Gewissen oder so). Von den Abhängigkeiten her, ließ sich alles auch ohne installieren.
    Es kommt halt darauf an, welche Programme installiert sind. Auf meiner Mascine klemmte es. Doch heute früh kam beim Einschalten Abhilfe:

    Code:
    System updates available: erlangen
    
    Von:    root <root@localhost>
    An:    karl@localhost
    Datum:    07.09.19 06:31
    
    Transaction:    Getting updates
    Status:         Waiting in queue
    Status:         Starting
    Status:         Querying
    Percentage:     0
    Status:         Refreshing software list
    Percentage:     10
    Percentage:     100
    Percentage:     40
    Percentage:     80
    Percentage:     100
    Status:         Finished
    Results:
    Enhancement  libgdal26-3.0.1-109.1.x86_64 (Application_Geo)
    Die Welt ist wieder in Ordnung:

    Code:
    erlangen:~ # zypper verify 
    Loading repository data...
    Reading installed packages...
    
    Dependencies of all installed packages are satisfied.
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  10. #10

    Default Re: Problem beim letzten Update: libnetcdf13-4.6.1-4.1.x86_64

    Quote Originally Posted by Lotosdrache View Post
    Ich werde jetzt einfach mal das veraltete Teil behalten und schaun, was passiert.
    Tja, was passiert ist folgendes: Beim nächsten Update kommt die Meldung wieder

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •