Results 1 to 5 of 5

Thread: k3b Install Issues

  1. #1

    Default k3b Install Issues

    I read through various k3b problems on Leap 15.1--but I have not seen any reports such as mine.

    When I attempt to install k3b, it shows this in the terminal:

    ~> sudo zypper install k3b
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: k3b-19.08.0-lp151.119.1.x86_64 requires libQt5Core.so.5(Qt_5.13)(64bit), but this requirement cannot be provided
    not installable providers: libQt5Core5-5.13.0-lp151.7.1.x86_64[KDE_Qt5]
    Solution 1: Following actions will be done:
    install libQt5Core5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5DBus5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Gui5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Location5-5.13.0-lp151.2.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Multimedia5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Network5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5NetworkAuth5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5OpenGL5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Positioning5-5.13.0-lp151.2.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5PrintSupport5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5QuickControls2-5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5QuickTemplates2-5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Script5-5.13.0-lp151.1.4.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Sensors5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5SerialPort5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Sql5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Sql5-mysql-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Sql5-sqlite-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Svg5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Test5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5TextToSpeech5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WaylandClient5-5.13.0-lp151.3.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WaylandCompositor5-5.13.0-lp151.3.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WebChannel5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WebSockets5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Widgets5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Xml5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5XmlPatterns5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQtQuick5-5.13.0-lp151.2.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtquickcontrols2-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtstyleplugins-platformtheme-gtk2-5.0.0+git20170311-lp151.28.4.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtvirtualkeyboard-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtwebengine-5.13.0-lp151.6.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install python2-qt5-5.13.0-lp151.139.2.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Concurrent5-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libKF5XmlGui5-5.61.0-lp151.201.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libKF5Declarative5-5.61.0-lp151.196.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install kwin5-5.16.4-lp151.310.2.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    deinstallation of kmymoney-5.0.6-lp151.79.2.x86_64
    deinstallation of calibre-3.40.1-lp151.1.1.x86_64
    install akonadi-server-sqlite-19.08.0-lp151.198.2.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5Designer5-5.13.0-lp151.11.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install kwayland-5.61.0-lp151.183.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WebKit5-imports-5.212~alpha3-lp151.2.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WebKit5-5.212~alpha3-lp151.2.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qdbus-5.13.0-lp151.11.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtbase-platformtheme-gtk3-5.13.0-lp151.7.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtquickcontrols-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtwayland-5.13.0-lp151.3.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install plasma5-integration-plugin-5.16.4-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install xdg-desktop-portal-kde-5.16.4-lp151.109.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5WebChannel5-imports-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libqt5-qtgraphicaleffects-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libKF5XmlGui5-lang-5.61.0-lp151.201.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libKF5Declarative5-lang-5.61.0-lp151.196.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install kwin5-lang-5.16.4-lp151.310.2.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    deinstallation of kmymoney-lang-5.0.6-lp151.79.2.noarch
    install libQt5WebKitWidgets5-5.212~alpha3-lp151.2.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install plasma5-integration-plugin-lang-5.16.4-lp151.1.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install xdg-desktop-portal-kde-lang-5.16.4-lp151.109.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install python2-sip-4.19.18-lp151.36.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install breeze5-decoration-5.16.4-lp151.256.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libKF5WindowSystem5-5.61.0-lp151.200.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install plasma-framework-5.61.0-lp151.259.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install akonadi-server-19.08.0-lp151.198.2.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install python-sip-common-4.19.18-lp151.36.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libKF5WindowSystem5-lang-5.61.0-lp151.200.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install libQt5X11Extras5-5.13.0-lp151.1.1.x86_64 (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install akonadi-server-lang-19.08.0-lp151.198.2.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install plasma-framework-lang-5.61.0-lp151.259.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    install kirigami2-lang-5.61.0-lp151.92.1.noarch (with vendor change)
    openSUSE --> obs://build.opensuse.org/KDE
    Solution 2: do not install k3b-19.08.0-lp151.119.1.x86_64
    Solution 3: break k3b-19.08.0-lp151.119.1.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/3/c] (c):


    Well, I want to keep 'kmymoney', 'calibre' software installed.

    What am I missing? Really need to burn DVDs...rather not have to resort back to command line again....

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,642
    Blog Entries
    3

    Default Re: k3b Install Issues

    You are using non-standard repos somewhere. So it wants to install k3b from a non-standard repo, and then switch a bunch of other packages to that repo.

    My advice would be to revert to the standard repos. But that's for you to decide.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: k3b Install Issues

    Thanks,

    Not sure how the the non-standard library was installed...I do not remember granting out-of-normal installations.

    However, from what is states near the top: "this requirement cannot be provided not installable providers: libQt5Core5-5.13.0-lp151.7.1.x86_64[KDE_Qt5]"--so from I understand that it states there is currently no option for me at this time to install k3b anyway.

    If I had selected Option 1, it would install a broken k3b, update the library back to what it should be and it remove the 'kmymoney' and 'calibre' software.

    Guess I need to install a different cd-burning software for now.

  4. #4
    Join Date
    Aug 2008
    Location
    San Francisco
    Posts
    400

    Default Re: k3b Install Issues

    Using the standard repositories, k3b installed and functions correctly for me. Version is 18.12.3-lp151.1.2.

    Your system is trying to install k3b 19.08.0-lp151.119.1. You seem to have a repository with the latest and greatest KDE offerings. Unless you really need the latest of everything, life will be easier following nrickert's advice to stay with the standard repos. Excess repos can easily be disabled in YaST.

    Regarding calibre, their site at https://calibre-ebook.com/download_linux recommends a Binary install to keep the latest version. (As of today, Release: 3.47.1 [30 Aug, 2019]). I've used the binary install successfully for years.

    Regards,
    Howard
    ThinkPads 310ED, 600E, T23, X41, X60, T61, X201, E550

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,983

    Default AW: k3b Install Issues

    Post:
    Code:
    zypper lr -d
    Not sure how the the non-standard library was installed...I do not remember granting out-of-normal installations.
    This can not be done and will not be done without any user interaction....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •