Results 1 to 3 of 3

Thread: Wine shortcut error

  1. #1

    Default Wine shortcut error

    I have installed wine and it works from the command line, but it doesn't when I create a kde desktop shortcut. I get the error:

    Code:
    Invalid name
    but from the command line the same command (as a one line) works:

    Code:
    env WINEPREFIX="/home/froggy/.tchaos" wine C:\\windows\\command\\start.exe /Unix /home/froggy/.tchaos/dosdevices/c:/users/Public/Desktop/Time\ \&\ Chaos.lnk
    
    To make sure that I'm clear, the bash command line works, but not the KDE desktop shortcut


    Thanks

  2. #2
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    204

    Default Re: Wine shortcut error

    What if you pack that command line into a shell script…
    Code:
    #!/bin/sh
    export WINEPREFIX="/home/froggy/.tchaos" 
    exec wine C:\\windows\\command\\start.exe /Unix /home/froggy/.tchaos/dosdevices/c:/users/Public/Desktop/Time\ \&\ Chaos.lnk
    … and refer to this script in your KDE shortcut?

    Another alternative: I can imagine that »\&« getting quite fragile during any command line evaluations between the shell and KDE. Since »&« is a special character to tell a shell to process a job in the background, strange things can happen with the filename »Time & Chaos.lnk«. Maybe try making the name this Windows link file safer to parse by renaming it to »timechaos.lnk« and change your wine command-line parameter accordingly? Fingers crossed.

  3. #3

    Default Re: Wine shortcut error

    Quote Originally Posted by unix111 View Post
    What if you pack that command line into a shell script…
    Code:
    #!/bin/shexport WINEPREFIX="/home/froggy/.tchaos" exec wine C:\\windows\\command\\start.exe /Unix /home/froggy/.tchaos/dosdevices/c:/users/Public/Desktop/Time\ \&\ Chaos.lnk
    … and refer to this script in your KDE shortcut?Another alternative: I can imagine that »\&« getting quite fragile during any command line evaluations between the shell and KDE. Since »&« is a special character to tell a shell to process a job in the background, strange things can happen with the filename »Time & Chaos.lnk«. Maybe try making the name this Windows link file safer to parse by renaming it to »timechaos.lnk« and change your wine command-line parameter accordingly? Fingers crossed.
    Thanks that go *** working. What I don't understand is that the same shortcut as described works on an other (older laptop) opensuse leap 15.0.But thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •