Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Hibernate doesn't work.

  1. #11
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: Hibernate doesn't work.

    Just a note.

    Since my posts above, I have tried hibernating my laptop.

    Running 15.1, I selected "hibernate" from the menu (in Plasma/KDE). It seemed to hibernate fine.

    I then powered it back on and rebooted. It appeared to successfully resume from hibernation. However, I did get a kernel message about an unexpected NMI interrupt. As best I recall, the kernel said "dazed and confused but continuing". Apart from that, everything looked okay.

    Later, I hibernated Tumbleweed on the same machine. And then I rebooted with a successful resume from hibernation. With Tumbleweed, there was no "dazed and confused" message.

    I should add that both of those are using an encrypted LVM (the same encrypted LVM, but different root volumes within that LVM). And they use the same swap, so they use the same location for saving the hibernation image. I do wonder what would happen if I hibernated 15.1, and then rebooted to Tumbleweed -- would it resume from the 15.1 hibernation image? But I'm not about to try that. I prefer to avoid hibernating.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  2. #12
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    145

    Default Re: Hibernate doesn't work.

    Hi Guys

    This is not only on 15.1 on 15.0 with new kernel 4.12.14-lp150.12.70-default kernel on my AMD machine it does not work anymore.
    Seems to go to suspend mode but fan is still running of CPU and case and consuming the same as up...
    After restore display is mangeld, not usable...
    This worked fine with kernel 4.12.14-lp150.12.61-default
    Hibernating does not work anymore long time ago. All newer kernels does not work. At the other end on my HP intel laptop it works with new kernel.
    The whole suspend/hibernate stuff is really a pain on linux. Every kernel update you have to test always on all machines....

  3. #13
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: Hibernate doesn't work.

    Quote Originally Posted by tkmbe View Post
    All newer kernels does not work.
    Have you tried the latest kernel from the kernel repo at
    Code:
    http://download.opensuse.org/repositories/Kernel:/stable/standard/
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #14
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    145

    Default Re: Hibernate doesn't work.

    No I haven't but I think released kernel should work right...
    Other day I will to a test..

    Thanks

  5. #15
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: Hibernate doesn't work.

    Quote Originally Posted by tkmbe View Post
    No I haven't but I think released kernel should work right...
    Other day I will to a test..

    Thanks
    It is worth trying.

    The released kernel has some feature backported from the latest kernel. But there could be some bugs in the backporting.

    If hibernate does not work on the latest kernel (from the kernels repo), then there is a kernel problem.
    If it does work there, but not on the released kernel, then it's an openSUSE kernel problem.

    Either way, it might be worth reporting as a bug.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #16

    Default Re: Hibernate doesn't work.

    Quote Originally Posted by nicomunet123 View Post
    Here are my disks.
    Hi
    First of all, you get the same information that is in your above screenshot by a "parted -l" at the command line as root. To post that output here using code tags (you obviously know how to do that) - instead of posting the link to some image on some server in the "cloud" - that output would then be preserved even if you would ever decide to delete that screenshot in the "cloud". Or you could perhaps use susepaste, and there select: Delete After > Never.

    From your above screenshot it can be seen that you installed Leap 15.1 on a separate hard disk with the system files along with your user data in one single BtrFS partition (I usually prefer to have / and /home in separate partitions, which is easier to deal with when you should ever decide to make a fresh installation of any future version of openSUSE).

    Searching the internet for "grub resume hibernate swap" I found a piece of well written documentation which gives you some background about hibernate etc.,
    https://wiki.archlinux.org/index.php..._and_hibernate

    On that page, under Hibernation > Required kernel parameters, you'll find the advice
    Generally, the naming method used for the resume parameter should be the same as used for the root parameter.
    after an example of how this may look like, which there is
    resume=UUID=4209c845-f495-4c43-8a03-5363dd433153
    For your installation this has been set up differently, see the parameters 'root=' and 'resume=' in your reply to
    Quote Originally Posted by nrickert View Post
    What's the output from:
    Code:
    cat /proc/cmdline
    Quote Originally Posted by nicomunet123 View Post
    Code:
    BOOT_IMAGE=/boot/vmlinuz-4.12.14-lp151.28.13-default root=UUID=2a87c183-fd18-4aa8-92d1-0
    8a42d8ec4cc splash=silent resume=/dev/disk/by-id/ata-WDC_WDS480G2G0B-00EPW0_19154F464706
    -part3 quiet mitigations=off
    You further wrote
    Quote Originally Posted by nicomunet123 View Post
    It I force shut down it, it will not resume, and sometimes will not boot (so couple reboots might be required).
    I myself just had some strange problems after installing Leap 15.1 if in the partitioner during the installation I selected to mount partitions by "Device ID" instead of by "UUID", c.f. thread
    https://forums.opensuse.org/showthre...to-init-daemon

    In /etc/fstab this results in entries of the type '/dev/disk/by-id/ata-WDC_WDS480G2G0B-00EPW0_19154F464706-part3' like you have it in your output from "cat /proc/cmdline" that I quoted above.

    You can quickly check what you have in fstab with (works without sudo or su)
    Code:
    cat /etc/fstab
    If you have entries of the type "/dev/disk/by-id/..." instead of "UUID=..." or "/dev/disk/by-uuid/..." there, and if you didn't edit /etc/fstab after installation, then you could just give it a try and in YaST > Partitioner in the "Fstab Options" of the "Mounting Options" for the partitions of openSUSE on your second hard disk change from mounting by "Device ID" to mounting by "UUID".
    After closing the partitioner (saving the changes) you would then as well be able to copy and paste the UUID of your swap from the output of another "cat /etc/fstab" to the argument of the parameter resume= in YaST > Boot Loader > Kernel Parameters.
    In one of my installations of 15.1 I now have there
    Code:
    resume=/dev/disk/by-uuid/76cca290-a1ef-43e8-b295-a3a704857f9e
    (with an additional space at the end).
    This differs from the "syntax" given on the web page cited above (which would be resume=UUID=76cca290-a1ef-43e8-b295-a3a704857f9e ), but it as well refers to the UUID (unlike /dev/disk/by-id/...) and it works well for my installation of Leap 15.1.

    A final remark with respect to this thread as such:
    If swap is needed to hibernate (which can not be a swap file for BtrFS and a Kernel 4.x, see web page cited above), then it will be useful to create a swap partition of sufficient size, which should in general be the case if
    Quote Originally Posted by nicomunet123 View Post
    I have 8 GB of RAM, and 16 GB swap partition.
    and to check during a typical situation of use, that swap isn't used heavily already, which is quickly done by a "free" on the command line (no sudo or su necessary).

    And
    Quote Originally Posted by nrickert View Post
    Running 15.1, I selected "hibernate" from the menu (in Plasma/KDE). It seemed to hibernate fine.

    I then powered it back on and rebooted. It appeared to successfully resume from hibernation. However, I did get a kernel message about an unexpected NMI interrupt. As best I recall, the kernel said "dazed and confused but continuing". Apart from that, everything looked okay.

    Later, I hibernated Tumbleweed on the same machine. And then I rebooted with a successful resume from hibernation. With Tumbleweed, there was no "dazed and confused" message.

    I should add that both of those are using an encrypted LVM (the same encrypted LVM, but different root volumes within that LVM). And they use the same swap, so they use the same location for saving the hibernation image. I do wonder what would happen if I hibernated 15.1, and then rebooted to Tumbleweed -- would it resume from the 15.1 hibernation image? But I'm not about to try that.
    well, I'm convinced that it very likely is a very good idea to not to try that ..... ;-)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •