Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

  1. #11

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Earlier in my work I had to program in graphic mode 1024x768 without GPU acceleration for 7 hours. It was not pleasant
    I installed this .rpm - the system started to turn on correctly. But this is only a temporary solution.

    Then I decided to go deeper into the subject, why doesn't the amdgpu firmware load in the newest kernel.
    What I did, it really worked.
    After many hours of trying, I managed to fix the problem.
    The problem most likely occurs ONLY in OpenSUSE (bug?).
    I noticed that the files in the folder /lib/firmware/5.2.9-1/amdgpu/ are from June 6, 2019. Most interestingly, the files in the folder /lib/firmware/5.2.10-1/amdgpu/ have the same modification date and content.
    The same applies to all files in the folder /lib/firmware/amdgpu/
    Zypper doesn't update them at all.
    The only time they are installed is during the first installation of the system.
    I flashed LiveUSB on a flash drive with kernel version 5.2.11-1 (currently it is the newest one)
    Then I removed ABSOLUTELY ALL files from /lib/firmware/<xxx>/amdgpu and /lib/firmware/amdgpu and then replaced them with LiveUSB files.
    I also copied Linux image with 5.2.11 kernel to /boot.
    Then I booted the computer normally (still with nomodeset), made a grub2-mkconfig (to detect the latest kernel), restarted the computer with normal kernel parameters and..... It works!
    I can safely say that the problem lies in opensuse, that it is not able to update the firmware for some reason, leaving it untouched from the beginning of the system installation.

    P.S. Touchpad doesn't work again, but it's a different topic

    (image of a working updated kernel with glxinfo, glxgears and inxi on KDE Plasma)
    https://imgur.com/a/aWclQUU

    Flashing .iso and copying files is also a some kind of solution, but I doubt that someone would like it
    I wonder where exactly the problem is.

    Thank you very much for your help!

  2. #12
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Quote Originally Posted by olekolek View Post
    Because of the update, the working version 5.2.9 was automatically removed from /boot.
    My advice and practice, with Tumbleweed is to edit "/etc/zypp/zypp.conf" to add "oldest" to this line
    Code:
    multiversion.kernels = oldest,latest,latest-1,running
    The idea is to keep a known working kernel around.

    Every now and then I will manually delete the oldest kernel, so that a more recent kernel becomes the new "oldest". But I only do that when that is known to be a good working kernel.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,680
    Blog Entries
    15

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Hi
    @OP, how do you update your system?

    I've seen no issues here with same generation GPU (GFX8) and Tumbleweed.

    Code:
     pinxi -GxxSaz
    System:    Host: bert Kernel: 5.2.11-1-default x86_64 bits: 64 compiler: gcc v: 9.2.1 
               parameters: BOOT_IMAGE=/boot/vmlinuz-5.2.11-1-default root=UUID=2cbadd0b-fccd-4aab-b6e1-1264fcc20bbb splash=silent 
               scsi_mod.use_blk_mq=1 amdgpu.ppfeaturemask=0xffffffff quiet 
               Desktop: Gnome 3.32.2 wm: gnome-shell dm: GDM Distro: openSUSE Tumbleweed 20190904 
    Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics] vendor: Hewlett-Packard driver: amdgpu 
               v: kernel bus ID: 00:01.0 chip ID: 1002:9874 
               Device-2: AMD Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445] vendor: Hewlett-Packard driver: amdgpu 
               v: kernel bus ID: 04:00.0 chip ID: 1002:6900 
               Display: x11 server: X.Org 1.20.5 driver: amdgpu compositor: gnome-shell resolution: 1366x768~60Hz 
               OpenGL: renderer: AMD CARRIZO (DRM 3.32.0 5.2.11-1-default LLVM 8.0.1) v: 4.5 Mesa 19.1.5 direct render: Yes
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    zypper update or zypper dup, nothing else.
    The kernel is from official OpenSUSE repository.

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,680
    Blog Entries
    15

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Quote Originally Posted by olekolek View Post
    zypper update or zypper dup, nothing else.
    The kernel is from official OpenSUSE repository.
    Hi
    For Tumbleweed it's only zypper dup, nothing else, a zypper update may have introduced an issue with the likes of firmware?

    I prefer zypper -vvv dup as it shows additional information.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16
    Join Date
    Mar 2019
    Location
    mtl.qc.ca
    Posts
    127

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Quote Originally Posted by olekolek View Post
    I just want to announce that in the recently released version of kernel 5.2.11-1 the problem still exists. Because of the update, the working version 5.2.9 was automatically removed from /boot. Now I can't turn on the system at all without nomodeset.
    It looks like the GPU driver works **only** on version 5.2.9 only (neither older nor newer kernels work).
    I would also like to say that this is the same version of Linux I had after installing the system a few weeks ago.
    5.2.9 is still available in the boot menu, the last option. For Lenovo, we have the same system, must use iommu=soft to boot in Linux, if not the laptop won't boot = black screen.

    Code:
    inxi -Gxx
    Graphics:
      Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
      vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0 chip ID: 1002:15dd 
      Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati 
      unloaded: fbdev,modesetting,vesa compositor: kwin_x11 resolution: 1920x1080~60Hz 
      OpenGL: renderer: AMD RAVEN (DRM 3.33.0 5.3.0-050300rc7-generic LLVM 8.0.1) 
      v: 4.5 Mesa 19.1.6 direct render: Yes
    Boot Line:

    Code:
    cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-5.3.0-050300rc7-generic root=UUID=1a5c3b32-7c5b-494a-8600-d15582f3a40e ro iommu=soft quiet splash vt.handoff=7
    The machine boots and runs normally in every distros that support secure boot. Try iommu=soft to see if the system works normally after.
    Ryzen 2700U FHD Lenovo ThinkPad E585

  7. #17
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,680
    Blog Entries
    15

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Quote Originally Posted by mike_g View Post
    5.2.9 is still available in the boot menu, the last option. For Lenovo, we have the same system, must use iommu=soft to boot in Linux, if not the laptop won't boot = black screen.

    Code:
    inxi -Gxx
    Graphics:
      Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] 
      vendor: Lenovo driver: amdgpu v: kernel bus ID: 05:00.0 chip ID: 1002:15dd 
      Display: x11 server: X.Org 1.20.5 driver: amdgpu FAILED: ati 
      unloaded: fbdev,modesetting,vesa compositor: kwin_x11 resolution: 1920x1080~60Hz 
      OpenGL: renderer: AMD RAVEN (DRM 3.33.0 5.3.0-050300rc7-generic LLVM 8.0.1) 
      v: 4.5 Mesa 19.1.6 direct render: Yes
    Boot Line:

    Code:
    cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-5.3.0-050300rc7-generic root=UUID=1a5c3b32-7c5b-494a-8600-d15582f3a40e ro iommu=soft quiet splash vt.handoff=7
    The machine boots and runs normally in every distros that support secure boot. Try iommu=soft to see if the system works normally after.
    Hi
    In the case of your card it's next generation, so there is the amdgpu.ngg=1 kernel boot option to enable.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #18
    Join Date
    Sep 2012
    Posts
    5,041

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Quote Originally Posted by olekolek View Post
    I just want to announce that in the recently released version of kernel 5.2.11-1 the problem still exists.
    You should open bug report on https://bugzilla.opensuse.org/

  9. #19
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,645

    Default Re: Newest Linux 5.2.10-1 - cannot switch to EFI VGA (Radeon)

    Quote Originally Posted by arvidjaar View Post
    You should open bug report on https://bugzilla.opensuse.org/
    Bug report HOWTO. When you create your report, please include a link to this thread.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •