Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: New updates include 3D rivers but if declined all updates fail

  1. #1

    Default New updates include 3D rivers but if declined all updates fail

    Just started to install 232 new updates but these include some Nvidia proprietary 3D software which I do not need and is reported to be a possible problem with KDE desktop. When I entered 'n' to drop the Nvidia driver the whole update process stopped.

    Does this mean that all the 232 new updates are associated with Nvidia or are other updates included which I should have? How do I sort this out?

    Otherwise very pleased with Tumbleweed so far. No more problems than with 15.1 in my experience. (Typo in title, should be drivers!!!)

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,208

    Default AW: New updates include 3D rivers but if declined all updates fail

    So please post as root:
    Code:
    zypper dup
    and
    Code:
    zypper lr -d

  3. #3

    Default Re: New updates include 3D rivers but if declined all updates fail

    As root I have run zypper dup and selected 'y' which gave me the following message;

    Code:
    (Use the Enter or Space key to scroll the text by lines or pages.)
    
    In order to install 'Mesa-dri-nouveau', you must agree to terms of the following license agreement:
    
    WARNING: Nouveau DRI/3D driver selected.
    
    This driver is considered experimental and is known to have issues with
    applications that use certain 3D acceleration features of modern
    NVIDIA hardware.
    
    Symptoms include application crashes or lockups & crashes of your system's
    graphical environment. Older Hardware and less demanding applications may work
    just fine and do benefit from the Hardware acceleration features this driver
    offers over software emulation.
    
    Use of this driver is especially not recommended for use with the KDE Desktop
    Environment or Qt-based Applications.
    
    The hardware vendor potentially offers alternative drivers.
    
    Please click "Accept" if you accept the risks that may come with the
    installation of this driver. Choose "Cancel"  to prevent installation
    of the driver and use software emulation instead.
    
    
    (Press 'q' to exit the pager.)
    ~
    /var/tmp/TmpFile.2sDmpS lines 1-26/26 (END)
    If I then quit the pager I get the following:-

    Code:
    AJBR-W530:~ # zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    The following 4 NEW packages are going to be installed:
      kernel-default-5.2.10-1.2 libgsl25 libnftables1 libprotobuf-lite20
    
    The following 4 packages are going to be REMOVED:
      hardlink libgsl23 libnftables0 libprotobuf-lite19
    
    The following 231 packages are going to be upgraded:
      Mesa Mesa-dri Mesa-dri-nouveau Mesa-gallium Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0
      Mesa-libva MozillaFirefox MozillaFirefox-translations-common PackageKit
      PackageKit-backend-zypp PackageKit-gstreamer-plugin PackageKit-gtk3-module
      PackageKit-lang akonadi-notes-lang cifs-utils cpp9 curl e2fsprogs elfutils
      elfutils-lang enblend-enfuse ffmpeg-4 gawk gstreamer-plugins-bad
      gstreamer-plugins-bad-lang gstreamer-plugins-base gstreamer-plugins-base-lang
      gstreamer-plugins-good gstreamer-plugins-good-gtk gstreamer-plugins-good-lang ipset
      iputils libGraphicsMagick-Q16-3 libGraphicsMagick3-config libIlmImf-2_3-24
      libKF5AkonadiNotes5 libKF5CalendarCore5 libQt5WebKit5 libQt5WebKit5-imports
      libQt5WebKitWidgets5 libSDL_image-1_2-0 libabw-0_1-1 libasm1 libavcodec57 libavcodec58
      libavdevice57 libavdevice58 libavfilter6 libavfilter7 libavformat57 libavformat58
      libavresample3 libavresample4 libavutil55 libavutil56 libbabl-0_1-0 libblkid1
      libcdrdeflt1_0 libcom_err2 libcurl4 libdeflt1_0 libdw1 libebl-plugins libelf1
      libext2fs2 libfaad2 libfdisk1 libfile1_0 libfind3_0 libgbm1 libgcc_s1 libgdata-lang
      libgdata22 libgfortran5 libgnutls30 libgomp1 libgpg-error0 libgslcblas0
      libgstadaptivedemux-1_0-0 libgstallocators-1_0-0 libgstapp-1_0-0 libgstaudio-1_0-0
      libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0
      libgstfft-1_0-0 libgstgl-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0
      libgstpbutils-1_0-0 libgstphotography-1_0-0 libgstriff-1_0-0 libgstrtp-1_0-0
      libgstrtsp-1_0-0 libgstsctp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0
      libgsturidownloader-1_0-0 libgstvideo-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0
      libinput-udev libinput10 libipset13 libkpathsea6 libmfx libmfx1 libmount1 libmpcdec6
      libmpg123-0 libneon27 libnftnl11 libnghttp2-14 libobjc4 libopencv4_1 liborcus-0_15-0
      libpackagekit-glib2-18 libpgm-5_2-0 libpostproc54 libpostproc55 libprotobuf-c1
      libpython2_7-1_0 libquadmath0 librmt1_0 librscg1_0 librtmp1 libscg1_0 libscgcmd1_0
      libschily2_0 libsmartcols1 libstdc++6 libstdc++6-pp-gcc9 libstorage-ng-lang
      libstorage-ng-ruby libstorage-ng1 libswresample2 libswresample3 libswscale4
      libswscale5 libteamdctl0 libuuid1 libva-drm2 libva-glx2 libva-wayland2 libva-x11-2
      libva2 libvdpau_nouveau libvisio-0_1-1 libvlc5 libvlccore9 libx264-155 libx265-176
      libxvidcore4 libzimg2 mkisofs mpg123-openal mpg123-pulse mugshot nano nano-lang
      nftables openSUSE-release openSUSE-release-ftp openssh openssh-askpass-gnome
      openssh-helpers opensuse-welcome opensuse-welcome-lang pam-config python python-base
      python-gtk python3-packaging python3-pyOpenSSL python3-rpm python3-setuptools remmina
      remmina-lang remmina-plugin-rdp remmina-plugin-secret remmina-plugin-vnc
      remmina-plugin-xdmcp rpm rpm-config-SUSE spax star sudo suse-module-tools susepaste
      susepaste-screenshot texlive-lm-fonts typelib-1_0-PackageKitGlib-1_0 util-linux
      util-linux-lang util-linux-systemd viewres vlc vlc-codec-gstreamer vlc-codecs vlc-lang
      vlc-noX vlc-qt vlc-vdpau xdm xfce4-screenshooter xfce4-screenshooter-lang
      xfce4-whiskermenu-plugin xfce4-whiskermenu-plugin-lang yast2-alternatives
      yast2-auth-client yast2-auth-server yast2-installation yast2-iscsi-client
      yast2-journal yast2-online-update yast2-online-update-frontend yast2-pam yast2-proxy
      yast2-ruby-bindings yast2-security yast2-services-manager yast2-storage-ng yast2-theme
      yast2-theme-breeze yast2-theme-oxygen yast2-trans-en yast2-trans-en_GB yast2-update
      yast2-vpn
    
    The following product is going to be upgraded:
      openSUSE Tumbleweed  20190824-0 -> 20190829-0
    
    The following package requires a system reboot:
      kernel-default-5.2.10-1.2
    
    231 packages to upgrade, 4 new, 4 to remove.
    Overall download size: 266.2 MiB. Already cached: 0 B. After the operation, additional
    359.7 MiB will be used.
    
        Note: System reboot required.
    Continue? [y/n/v/...? shows all options] (y): y
    Do you agree with the terms of the license? [yes/no] (no): ^CAJBR-W530:~ #
    I cannot see the option 'cancel' and do not know what 'v' does so will wait your next advice on this.

    Here is the result from your next command;-

    Code:
    AJBR-W530:~ # zypper lr -d
    # | Alias              | Name               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                          | Service
    --+--------------------+--------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------+--------
    1 | packman-essentials | packman-essentials | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/Essentials/ |        
    2 | repo-non-oss       | repo-non-oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss         |        
    3 | repo-oss           | repo-oss           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss             |        
    4 | repo-update        | repo-update        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/              |        
    AJBR-W530:~ #
    Hope this helps.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,208

    Default AW: New updates include 3D rivers but if declined all updates fail

    First:
    There is no update of
    Nvidia proprietary 3D software
    , its nouveau.
    So update your System or post:
    Code:
    zypper se -s mesa

  5. #5

    Default Re: New updates include 3D rivers but if declined all updates fail

    Sorry I meant nouveau but the warnings about using this update with KDE desktop are real and as I do not want or need 3D how do I get around the problem. You have not made clear but here is the result of your last instruction;-

    Code:
    AJBR-W530:~ # zypper se -s mesa
    Loading repository data...
    Reading installed packages...
    
    S | Name                      | Type    | Version      | Arch   | Repository       
    --+---------------------------+---------+--------------+--------+------------------
    i | Mesa                      | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa                      | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa                      | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-32bit                | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-KHR-devel            | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-KHR-devel            | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-demo                 | package | 8.4.0-1.7    | x86_64 | repo-oss         
      | Mesa-demo                 | package | 8.4.0-1.7    | i586   | repo-oss         
    i | Mesa-demo-x               | package | 8.4.0-1.7    | x86_64 | repo-oss         
    v | Mesa-demo-x               | package | 8.4.0-1.7    | i586   | repo-oss         
      | Mesa-devel                | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-devel                | package | 19.1.5-227.1 | i586   | repo-oss         
    i | Mesa-dri                  | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-dri                  | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-dri                  | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-dri-32bit            | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-dri-devel            | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-dri-devel            | package | 19.1.5-227.1 | i586   | repo-oss         
    i | Mesa-dri-nouveau          | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-dri-nouveau          | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-dri-nouveau          | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-dri-nouveau-32bit    | package | 19.1.5-227.1 | x86_64 | repo-oss         
    i | Mesa-gallium              | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-gallium              | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-gallium              | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-gallium-32bit        | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libEGL-devel         | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libEGL-devel         | package | 19.1.5-227.1 | i586   | repo-oss         
    i | Mesa-libEGL1              | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-libEGL1              | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-libEGL1              | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libEGL1-32bit        | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGL-devel          | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGL-devel          | package | 19.1.5-227.1 | i586   | repo-oss         
    i | Mesa-libGL1               | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-libGL1               | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-libGL1               | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libGL1-32bit         | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGLESv1_CM-devel   | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGLESv1_CM-devel   | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libGLESv1_CM1        | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGLESv1_CM1        | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libGLESv2-2          | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGLESv2-2          | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libGLESv2-devel      | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGLESv2-devel      | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libGLESv3-devel      | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libGLESv3-devel      | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libOpenCL            | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libOpenCL            | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libVulkan-devel      | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libVulkan-devel      | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libd3d               | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libd3d               | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libd3d-32bit         | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libd3d-devel         | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libd3d-devel         | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libd3d-devel-32bit   | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libglapi-devel       | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | Mesa-libglapi-devel       | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libglapi-devel-32bit | package | 19.1.5-227.1 | x86_64 | repo-oss         
    i | Mesa-libglapi0            | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-libglapi0            | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-libglapi0            | package | 19.1.5-227.1 | i586   | repo-oss         
      | Mesa-libglapi0-32bit      | package | 19.1.5-227.1 | x86_64 | repo-oss         
    i | Mesa-libva                | package | 19.1.3-226.1 | x86_64 | (System Packages)
    v | Mesa-libva                | package | 19.1.5-227.1 | x86_64 | repo-oss         
    v | Mesa-libva                | package | 19.1.5-227.1 | i586   | repo-oss         
      | libOSMesa-devel           | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | libOSMesa-devel           | package | 19.1.5-227.1 | i586   | repo-oss         
      | libOSMesa-devel-32bit     | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | libOSMesa8                | package | 19.1.5-227.1 | x86_64 | repo-oss         
      | libOSMesa8                | package | 19.1.5-227.1 | i586   | repo-oss         
      | libOSMesa8-32bit          | package | 19.1.5-227.1 | x86_64 | repo-oss         
    AJBR-W530:~ #
    I am certainly no wiser but if you can explain I am interested.
    Many thanks,
    Budge

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,208

    Default AW: New updates include 3D rivers but if declined all updates fail

    The Mesa-dri-nouveau needs to accept the license, so do :
    Code:
    zypper dup --auto-agree-with-licenses
    Code:
    231 packages to upgrade, 4 new, 4 to remove.
    Overall download size: 266.2 MiB. Already cached: 0 B. After the operation, additional
    359.7 MiB will be used.
    
        Note: System reboot required.
    Continue? [y/n/v/...? shows all options] (y): y
    Do you agree with the terms of the license? [yes/no] (no): ^CAJBR-W530:~ #
    You have said yes to the Update (see the line before the last one) and now you have to accept the license of Mesa-dri-nouveau (the last line).......

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,814

    Default Re: New updates include 3D rivers but if declined all updates fail

    If you have a NVIDIA GPU then you need either Nouveau or the NVIDA driver If you really really don't want 3D accel then you must drop back to the fall back drivers which have poor resolution also.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,307
    Blog Entries
    3

    Default Re: New updates include 3D rivers but if declined all updates fail

    Quote Originally Posted by Budgie2 View Post
    Just started to install 232 new updates but these include some Nvidia proprietary 3D software which I do not need and is reported to be a possible problem with KDE desktop. When I entered 'n' to drop the Nvidia driver the whole update process stopped.
    We now know (from later posts in this thread), that you are referring to "Mesa-dri-nouveau".

    Step 1: Uninstall that, if it is currently installed. I suggest Yast Software Management for that.
    Step 2: Lock that package so it will never be installed. I would usually do that with Yast software management.

    After that, you should not again be bothered by prompts for this package.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9

    Default Re: New updates include 3D rivers but if declined all updates fail

    I still do not understand what I am doing here. My original question was because I did not understand what to do about the serious warning concerning the potential problems I might have:-

    Code:
    WARNING: Nouveau DRI/3D driver selected
    
    This driver is considered experimental and is known to have issues with
    applications that use certain 3D acceleration features of modern
    NVIDIA hardware.
    It appears from the advice given later in this thread that I neither need nor want this driver.

    Is this because I have an Nvidia GPU and am using the proprietary drivers?

    If this is true and I just go ahead and install the Mesa-dri-nouveau will it be ignored because it is not required?

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,814

    Default Re: New updates include 3D rivers but if declined all updates fail

    Easy ignore it it is there just as a warning. The statement is a bit more scary than it needs to be

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •