Results 1 to 9 of 9

Thread: Issue with "zypper install stunnel"

  1. #1

    Question Issue with "zypper install stunnel"

    When I try to install the stunnel into the SUSE linux, I got the below response information:

    bash-4.4# zypper install -l -y stunnel
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides group(nogroup) needed by stunnel-5.49-37.14.x86_64
    Solution 1: do not install stunnel-5.49-37.14.x86_64
    Solution 2: break stunnel-5.49-37.14.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c] (c): c



    anyone can tell me the problem "nothing provides group(nogroup)" means exactly what? how to fix?
    I have tried to add nogroup by command "groupadd nogroup", seems not help.

    thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Issue with "zypper install stunnel"

    I see that group(nogroup) is indeed a dependancy. To me that is a strange notation for a dependency. I assume there is something wrong here.

    Maybe first wait a bit until others chime in here, else file a bug report at https://en.opensuse.org/openSUSE:Submitting_bug_reports
    Henk van Velden

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,875
    Blog Entries
    3

    Default Re: Issue with "zypper install stunnel"

    I just installed "stunnel" without problems.

    It does have a dependency on "group(nogroup)" so I must have something installed that meets that requirement.

    I did a search for "group" in Yast. It lists the package "system-user-nobody" as installed. When I click on the "Dependencies" tab, it shows as providing "group(nogroup)" in addition to "group(nobody)".

    Maybe try installing "system-user-nobody" and see if that helps.

    Hmm, that comes from the main repo. Maybe check your repos, and make sure that the main repo is enabled. It shows here as having name "Main repository", alias "repo-oss" and url "http://download.opensuse.org/distribution/leap/15.1/repo/oss/". It is almost certain that you have that repo configured, but you might have inadvertently disabled it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Issue with "zypper install stunnel"

    I looked a bit further. The OSS repo of 15.1 has stunnel 5.44-lp150.3.3 and that is not what you try to install.

    Thus maybe should explain more elaborate what you are doing. We can not look over your shoulder!
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,462
    Blog Entries
    2

    Default Re: Issue with "zypper install stunnel"

    Quote Originally Posted by hcvv View Post
    I looked a bit further. The OSS repo of 15.1 has stunnel 5.44-lp150.3.3 and that is not what you try to install.

    Thus maybe should explain more elaborate what you are doing. We can not look over your shoulder!
    There is a 5.49 in the 15.1 security repo...

    https://software.opensuse.org/package/stunnel

    The User should just verify that is where this package is from, and not installing from a bad choice like a TW repo.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: Issue with "zypper install stunnel"

    Quote Originally Posted by tsu2 View Post
    There is a 5.49 in the 15.1 security repo...

    https://software.opensuse.org/package/stunnel

    The User should just verify that is where this package is from, and not installing from a bad choice like a TW repo.

    TSU

    hi,

    Thanks for all of your help.
    Maybe I need make more clear about what I am doing.

    Actually I try to install the stunnel in one docker image which based on SUSE sles:15 OS.
    From the website
    https://software.opensuse.org/downlo...ackage=stunnel , I found

    For SLE-15 run the following as root:

    Code:
    zypper addrepo https://download.opensuse.org/repositories/security:Stunnel/SLE-15/security:Stunnel.repo
    zypper refresh
    zypper install stunnel

    but when run this "zypper install stunnel", I got the issue


    bash-4.4# zypper install -l -y stunnel
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides group(nogroup) needed by stunnel-5.49-37.14.x86_64
    Solution 1: do not install stunnel-5.49-37.14.x86_64
    Solution 2: break stunnel-5.49-37.14.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c] (c): c



    I wonder how to fix this "nothing provides group(nogroup)" problem, I have tried "groupadd nogroup", seems no help.

    maybe the https://download.opensuse.org/reposi...y:Stunnel.repo is not right choice for the sles:15 ?

    but can somehow fix this nogroup issue manually before run "zypper install stunnel"?

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Issue with "zypper install stunnel"

    Quote Originally Posted by eleyzhu View Post
    Maybe I need make more clear about what I am doing.
    That is of course the most important thing to do when you want adequate help.
    Quote Originally Posted by eleyzhu View Post
    Actually I try to install the stunnel in one docker image which based on SUSE sles:15 OS.
    Then why do you say your thread is about LEAP15.1?

    You are spoiling our time!

    For SLES/SLED please go to https://forums.suse.com/forum.php
    Henk van Velden

  8. #8

    Default Re: Issue with "zypper install stunnel"

    Quote Originally Posted by hcvv View Post
    That is of course the most important thing to do when you want adequate help.

    Then why do you say your thread is about LEAP15.1?

    You are spoiling our time!

    For SLES/SLED please go to https://forums.suse.com/forum.php

    Hi,

    Sorry for your time on this question.
    I was not sure how big the difference is beween the LEAP and SLED..., not know this is not the right place to ask, I jsut find this forum and try to see if can get some help.
    Everyone's knowledge is not enough for all the domain, this is why I ask for help here.

    Br,
    Leyu

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Issue with "zypper install stunnel"

    Quote Originally Posted by eleyzhu View Post
    Hi,

    Sorry for your time on this question.
    I was not sure how big the difference is beween the LEAP and SLED..., not know this is not the right place to ask, I jsut find this forum and try to see if can get some help.
    Everyone's knowledge is not enough for all the domain, this is why I ask for help here.

    Br,
    Leyu
    It is not so much about the fact that you try here, but that you then make us think that you use LEAP 15.1 and do not explain anything about what you have, try and do.

    It is like calling up a car repair shop and saying, I have a Dodge and .....,where you in fact have a Ford.

    We are happy to point everyone that comes here by incident in the right direction, like in this case point to the SLES forums, but we are not clairvoyant.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •