Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35

Thread: Failed to connect to bus, failed to talk to init daemon

  1. #31

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by tsu2 View Post
    IMO might be a hard to find corruption.
    Try doing a DVD repair, followed by a system update.

    Of course, fully backup everything first.
    Depending on the speed of your Internet connection and disks, this could take a half day to complete but it ought to address any embedded system anomalies.

    Hi again!
    Usually, recommendations of that kind aren't the ones that one likes to read ...

    But after gogalthorp's comment that nothing I would describe would be normal, and after it became clear more and more that in my installation of 15.1, Network Manager causes the whole system to lock up or crash whenever I disconnect WLAN or even if I disconnect the cable connection, I was starting to ask myself whether there in fact had something been corrupted in my installation of Leap 15.1, or if - even unlikely in this case - a hardware error had occurred.

    But to make clear what the reason will be (or will not be), I did choose a different approach than a repair and a subsequent system update.
    Anyway I had made all updates, the 15.1 I ran was up to date.

    Instead I decided to install 15.1 on a new quality USB stick that I recently bought in a shop and that I hardly used since then.
    So hardware problems with respect to mass storage should then not play any role.

    First I checked the DVD installer on the USB stick to which I "burned" it to
    # dd if=/dev/sdb of="openSUSE-Leap-15.1-DVD-x86_64-read-from-USB.iso" bs=4M iflag=count_bytes count=4056940544 && sync
    967+1 records in
    967+1 records out
    4056940544 bytes (4,1 GB, 3,8 GiB) copied, 127,368 s, 31,9 MB/s
    # sha256sum openSUSE-Leap-15.1-DVD-x86_64-read-from-USB.iso
    c6d3ed19fe5cc25c4667bf0b46cc86aebcfbca3b0073aed0a288834600cb8b97  openSUSE-Leap-15.1-DVD-x86_64-read-from-USB.iso
    In this /dev/sdb is the USB stick with the installer on it. The file size of the iso and the sha256 checksum are available from
    That looked good!

    Then using the DVD installer on this USB stick, I installed 15.1 on the new USB stick mentioned above.
    The laptop on which this took place is configured such that it directly boots from an USB stick plugged (if that USB stick is bootable).

    Adjacent to this installation, using GParted, I deleted all partitions on that USB stick (it has an MBR, of course).

    During installation I did use the partitioner of the openSUSE DVD installer (instead of e.g. GParted)) to create swap, root, and home partition.

    I didn't remove anything of the software suggested for installation, like Java (which I usually don't install), or LibreOffice (which I wouldn't have needed in this case), I just left things how they were, and only added a few packages: urfkill, kwrite, kfind, zip, meld, gparted.

    So, this was a fresh and very clean install of Leap 15.1 with KDE.
    No additional repos.
    Pure Leap 15.1.
    Without Mesa-dri-nouveau.
    As before.

    Next steps:
    1) This new 15.1 installation boots without problems.
    2) I click on the icon of the Network Manager Applet.
    3) I select my WLAN and enter the password.
    4) The connection is established.
    5) Reboot.
    6) The WLAN connection is established again, as well as the cable connection that is still there (unrequested but sometimes useful messages after startup).
    7) I open a Konsole window and become root there using su.
    8) I use Network Manager Applet to disconnect the WLAN connection (which seems to in fact take place).
    9) I click on the Konsole window, where I have become root before.
    10) In that Konsole window where I had become root
    # shutdown -h now
    Failed to connect to bus: No such file or directory
    Failed to talk to init daemon.
    To state it clearly: this a new fresh install on intact hardware, of pure Leap 15.1.

    I whish everybody here a good weekend!

  2. #32
    Join Date
    Feb 2010

    Lightbulb Re: Failed to connect to bus, failed to talk to init daemon


    It's getting worse …
    On this Desktop – AMD CPU; AMD Oland PRO [Radeon R7 240/340] Oland OpenGL – following sequence:
    1. Login “normally” – SDDM, KDE Plasma session.
    2. <Ctrl-Alt-F1> and login as root on TTY1.
    3. Either, <Alt-Left> through TTY1-6 and then TTY7, <Alt-Right> to TTY7 or, <Ctrl-Alt-F7> to switch back to the KDE Plasma session.
    4. The KDE Plasma session hangs.
    5. <Ctrl-Alt-F1> back to the root user.
    6. <Alt-Right> and login as the “dead” user on TTY2.
    7. Inspect ‘~/.local/share/sddm/xorg-session.log’.
    8. The XOrg session has suffered the following errors:

    klauncher: Exiting on signal 1
    Unexpected response from KInit (response = 0).
    startkde: Could not start ksmserver. Check your installation.
    XIO:  fatal IO error 0 (Erfolg) on X server ":0"
          after 471849 requests (471849 known processed) with 0 events remaining.
    Error: Can't open display: :0
    startkde: Shutting down...
    kdeinit5_wrapper: Warning: connect(/run/user/1000/kdeinit5__0) failed: : No such file or directory
    Error: Can not contact kdeinit5!
    xprop:  unable to open display ':0'
    xprop:  unable to open display ':0'
    startkde: Done.
    KCrash: Attempting to start /usr/bin/plasmashell from kdeinit
    Warning: connect() failed: : Datei oder Verzeichnis nicht gefunden
    KCrash: Attempting to start /usr/bin/plasmashell directly
    KCrash: Application 'plasmashell' crashing...
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi from kdeinit
    Warning: connect() failed: : Datei oder Verzeichnis nicht gefunden
    KCrash: Attempting to start /usr/lib64/libexec/drkonqi directly
    Warning: bind() for communication with DrKonqi failed: Keine Berechtigung
    Unable to start Dr. Konqi
    Re-raising signal for core dump handling.
    If on the other hand, I login to TTY1-7 with systemd isolated to the Multi-User target – also “chvt 63”, “chvt 62”, “deallocvt” – switching between VT sessions works as expected.
    If I then execute from the “root” user session “systemd default”, the user session of TTY7 gets killed and the SDDM Greeter starts – login as a KDE Plasma user.

    • I can then switch to the existing VT user sessions from the KDE Plasma session and, switch back and forth between CLI VT sessions and the KDE Plasma session as often as I want.
    • If I create additional KDE Plasma sessions (TTY8 and TTY9 – just the same – switch back and forth between any of the user sessions until tired of the game …
    • Logout of the additional KDE Plasma sessions – just the same.
    • Logout of the user sessions on TTY2-6, just the same.
    • Switching between the remaining KDE Plasma session and the user session on TTY1 also continues to function as expected.
    • I need to finish this post before I logout of the user session on TTY1 …

    Just a thought:
    • It's possible that, the “Simple Desktop Display Manager” doesn't initialise the TTY7 VT session properly, and subsequent additional KDE Plasma sessions as well, unless, a CLI VT session was initially started on TTY7 …

  3. #33
    Join Date
    Feb 2010

    Exclamation Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by dcurtisfra View Post
    • I need to finish this post before I logout of the user session on TTY1 …
    Logging out from the “root” session on TTY1 caused the KDE Plasma session on TTY7 to freeze …

    Recovered by:
    1. Logging as “root” to TTY1 and isolate to the Multi-User target.
    2. Kill all the user process of the user who was logged in to the KDE Plasma session.
    3. “systemd default”.
    4. Logout of the TTY1 “root” session.
    5. Login at the SDDM Greeter.

  4. #34

    Default Re: Failed to connect to bus, failed to talk to init daemon

    The problems with NetworkManager that I described in this thread seem to be related to

  5. #35

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Good news first: I found out more about the conditions under which NetworkManager crashes Leap 15.1 - as well as a quick fix.

    Performing several installations of Leap 15.1 on different hardware (see list at the end of this posting) I could confirm the problems with NetworkManager, and that the lock ups do not occur if network is set up as "wicked service", which differs from comment 6 of

    The problems while using NetworkManager occured for every installation of Leap 15.1 on every hardware I used - but as well, during each installation, in the partitioner in "Fstab Options" I always made the setting that partitions should be mounted by "Device ID", instead of by UUID (the latter being the default).

    The quick fix:
    if swap and / (or root) and /home are mounted by UUID instead of by ID, then NetworkManager doesn't crash Leap 15.1 anymore. In my tests/attempts this was 100 percent reproducible.
    It makes no difference if this is achieved by a fresh install, or by modifying fstab accordingly using a text editor, and changing the parameter "resume=..." in YaST > Boot Loader.
    I used GParted installed in and started from openSUSE to get the UUIDs needed for that, which I found to be comfortable.
    A template/copy of fstab and grub.cfg from a Leap 15.1 installed without changing the default of mounting by UUID was useful.

    Usually I absolutely dislike having only a heap of UUIDs in fstab, not seeing from them to which partition on which hardware these entries belong.

    I discovered this after installing Leap 15.1 on a USB stick of a certain manufacturer/reseller who doesn't produce memory chips himself (I once had problems using smartctl for an external HDD of the same brand).
    Booting from that USB stick a boot error occurred like that reported in
    After modifying fstab on that USB stick (plugged after booting another installation of openSUSE and using a text editor) 15.1 finally booted from that stick, although I had to wait 1.5 minutes for a start job that didn't complete, probably because in grub.cfg there still was resume=/dev/disk/by-id/... instead of resume=/dev/disk/by-uuid/...
    Now, with partitions in fstab mounted by UUID, NetworkManager worked well without the problems encountered before.

    Hardware used to test, according to hwinfo:

    (1) Desktop
    Pentium Dual-Core E5200 @ 2.50GHz
    graphics card:
    Intel 4 Series Chipset Integrated Graphics Controller
    D-Link DWA-140 RangeBooster N Adapter(rev.B3) [Ralink RT5372]
    Broadcom NetLink BCM5784M Gigabit Ethernet PCIe

    (2) Desktop
    Core i5-2500 @ 3.30GHz
    graphics card:
    Intel 2nd Generation Core Processor Family Integrated Graphics Controller
    Qualcomm Atheros AR9227 Wireless Network Adapter
    Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet

    (3) Laptop
    Core2 Duo P8700 @ 2.53GHz
    graphics card:
    nVidia G96CM [GeForce 9600M GS]
    Intel Ultimate N WiFi Link 5300
    Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

    (4) Laptop
    Core i3 M350 @ 2.27GHz
    graphics card:
    Intel Core Processor Integrated Graphics Controller
    nVidia GT218M [GeForce 310M]
    Realtek RTL8191SEvB Wireless LAN Controller
    Qualcomm Atheros AR8131 Gigabit Ethernet

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts