Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Failed to connect to bus, failed to talk to init daemon

  1. #1

    Default Failed to connect to bus, failed to talk to init daemon

    Hello everyone!

    This is a quite recent install of Leap 15.1 from the 4 openSUSE repos only (i.e. oss, oss updates, non-oss, non-oss updates).
    All pending updates made today.
    I use KDE.
    The laptop is of generic brand, some years old with windoze 7, intel core i3, nvidia geforce 310M.

    1) I boot. KDE is running.
    2) I hit Ctrl-Alt-F1 to get a terminal.
    3) Using 'su' I log in as root.
    4) Using Ctrl-Alt-F7 I return to KDE desktop.
    5) I open a Dolphin window, and I close it again. At his point, that still works.
    6) I click on the Network Manager Applet in the task bar at the lower boundary of the screen.
    7) I disable WiFi / WLAN (the laptop is connected by cable).
    8) I close the Network Manager popup window that opened from there.
    9) I try to start Dolphin again. I get (translated):
    Code:
    The command can't be executed.
    The file or directory
    '/home/mydefaultuser/.local/share/plasma_icons/org.kde.dolphin.desktop'
    doesn't exist.
    10) I hit Ctrl-Alt-F1, and I get to the terminal where I logged in as root before (root prompt).
    11) I enter
    Code:
    shutdown -h now
    12) I get (not translated, but typed by hand):
    Code:
    Failed to connect to bus: No such file or directory
    Failed to talk to init daemon.
    I shut down the hard way by pressing the power button for several seconds.

    This is repeatable.

    Any idea?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,515

    Talking Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by ratzi View Post
    2) I hit Ctrl-Alt-F1 to get a terminal.
    3) Using 'su' I log in as root.
    4) Using Ctrl-Alt-F7 I return to KDE desktop.
    5) I open a Dolphin window, and I close it again. At his point, that still works.
    .
    .
    10) I hit Ctrl-Alt-F1, and I get to the terminal where I logged in as root before (root prompt).
    Yes, I've noticed this as well:
    • Active SDDM session – KDE Plasma – on VT7.
    • Active user session – could be “root” or, another user – on VT1 through VT6.

    When jumping between CLI Virtual Terminals and the SDDM Virtual Terminal (VT1 .. VT6 ←→ VT7), the system freezes …
    • I was pointing a finger at my AMD Chip-Set and Graphic card but, it seems that the Intel/NVIDIA world is also suffering from this issue …

    I'm simply waiting for Wayland and some SDDM changes – in the mean time I only begin «and end» VT1 .. VT6 sessions when only the SDDM Greeter is running on VT7 …
    • Or, I “isolate” to the systemd multi-user.target, do what ever and then, return the system to the default systemd target …

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Using wayland????

    Not seeing this using X

  4. #4

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by dcurtisfra View Post
    When jumping between CLI Virtual Terminals and the SDDM Virtual Terminal (VT1 .. VT6 ←→ VT7), the system freezes …
    • I was pointing a finger at my AMD Chip-Set and Graphic card but, it seems that the Intel/NVIDIA world is also suffering from this issue …
    Interesting: already under Leap 15.0, on the very same laptop, I had even worse problems with KDE lock ups and freezes of the system. I then blamed that on NVIDIA, because I never have experienced problems of that kind on intel PCs using processor graphics only (i.e. PCs with no additional video/graphics card), of which I have two.

    That may have been wrong, see
    https://forums.opensuse.org/showthre...26#post2891926
    However, arvidjaar didn't elaborate on that then, and I didn't ask.

    Anyway, after an update not much time after that, the behaviour of Leap 15.0 improved much on that same laptop. I was a bit sceptical and kept on using Leap 42.3 on that laptop.
    Now after the end of support for Leap 42.3 I tried a clean install of 15.1, because it will be supported much longer than 15.0.

    And the freeze: Yes, yesterday I finally got a freeze of 15.1 when trying to switch back to KDE (VT7) after the shutdown command in VT1 didn't work anymore.

    Quote Originally Posted by dcurtisfra View Post
    Yes, I've noticed this as well:
    • Active SDDM session – KDE Plasma – on VT7.
    • Active user session – could be “root” or, another user – on VT1 through VT6.
    Usually I don't jump between the virtual terminals using Ctrl-Alt-F1 / Ctrl-Alt-F7 etc - except that I have a reason.
    The reason here was that KDE got locked after using the Network Manager Applet. That finally made it necessary to shut down the laptop the hard way, and that took place already the first time I tried to use the Network Manager Applet.

    It was the second try when I first went to VT1 (Ctrl-Alt-F1) and logged in as root before anything else. The reason was that after the lock ups of KDE under Leap 15.0 I never had the chance anymore to log in as root, in order to shut down in a more usual way, because (i) KDE didn't open Konsole anymore (just like any other application), and (ii) on VT1 trying to log in as root ended up in timeouts.
    I didn't want to end up like that again.
    Actually I finally had tried the same under Leap 15.0 already, with similar results, see
    https://forums.opensuse.org/showthre...82#post2891682

    So if I hadn't logged in on VT1 first, then I would not even have seen the error message
    Quote Originally Posted by ratzi View Post
    Code:
    Failed to connect to bus: No such file or directory
    Failed to talk to init daemon.
    The error message of KDE that I obtained before that is striking as well, but it gives less details.

    Quote Originally Posted by dcurtisfra View Post
    I'm simply waiting for Wayland and some SDDM changes – in the mean time I only begin «and end» VT1 .. VT6 sessions when only the SDDM Greeter is running on VT7 …
    • Or, I “isolate” to the systemd multi-user.target, do what ever and then, return the system to the default systemd target …
    As long as I don't use the Network Manager Applet on that laptop, things work quite well: usually I boot the system, start firefox, and access the internet. That works. And the shutdown after that works too.
    So for me personally it isn't that urgent to have this fixed - although it's a bit nasty.
    For others, this may look different.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Instead of using keyboard keystrokes, try using the "systemctl isolate" command as described in the following article...

    https://www.tecmint.com/change-runle...ts-in-systemd/

    Somewhere a long time ago I remember reading a Poettering blog article (I'm sure it can be found) that described how unlike in SysVinit, in some scenarios systemd runlevels don't match up exactly with what you'd expect... in other words, there isn't a fixed relationship. There is an attempt to preserve the associations because it's what Users expect, but systemd removed the fixed relationship to make more options available and provide some extra flexibility in utilizing resources.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by tsu2 View Post
    Instead of using keyboard keystrokes, try using the "systemctl isolate" command as described in the following article...

    https://www.tecmint.com/change-runle...ts-in-systemd/
    Hi
    Reading through this I currently do not see how that could be used to turn off WiFi / WLAN while in KDE.
    And when KDE is locked up after trying to turn off WiFi / WLAN using the Network Manager Applet there doesn't seem to be any possibility to get a working command line where a command like
    Code:
    # systemctl isolate multi-user.target
    could be entered.

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: Failed to connect to bus, failed to talk to init daemon

    OK,
    I didn't understand the point of your switching runlevels so got side-tracked. And, I still don't know why you did what you did.
    But, if you actually were trying to do something in a text terminal, and had problems connecting to a bus, my recommendation is still there.

    Two things you should check...
    Whenever you see an error about a missing file, the first thing you should check is if that file actually exists.

    Also,
    A common cause of "unable to connect to dbus" errors is trying to access something without proper permissions.
    I'm not sure why you're attempting to run NM with root permission, it's set up to run as the logged in normal User... I haven't tested running as root but the error is typical of that kind of incorrect use.

    As far as turning off your Wifi...
    I don't know that NM can do that, it's a configuration manager and AFAIK doesn't manage device on/off(but can configure a start configuration).
    For that, you might use a software solution like rfkill or a hardware switch on your laptop.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by tsu2 View Post
    OK,
    I didn't understand the point of your switching runlevels so got side-tracked. And, I still don't know why you did what you did.
    But, if you actually were trying to do something in a text terminal, and had problems connecting to a bus, my recommendation is still there.
    Hi again!
    The problem was (and is) that KDE or the whole system got "locked up" after I disabled WiFi / WLAN using the Network Manager Applet.
    I then could not shutdown anymore, because KDE wouldn't launch anything anymore. I reported the (strange) error message that I get trying to launch Dolphin as a standard user (not root!). Shutdown didn't work either - for the same (whichever) reasons, I assume.
    So the last thing to try for me was to try to get to a working command line. That was the reason to try Ctrl-Alt-F1 in that situation.

    Logging in as root at virtual console 1 BEFORE running Network Manager Applet was the only means to do so which I am aware of. Without success at the end of the day, because I got the error messages given in the title of this thread. So a conclusion would be, that not only KDE got bust by using the Network Manager Applet, but the whole system.

    Quote Originally Posted by tsu2 View Post
    Two things you should check...
    Whenever you see an error about a missing file, the first thing you should check is if that file actually exists.
    Yes, it does!
    After a fresh boot, I can open a Dolphin window as default user without any problem, and the file '/home/mydefaultuser/.local/share/plasma_icons/org.kde.dolphin.desktop' is there, I can navigate to it in that Dolphin window.
    The error message that this file can't be found is displayed only after the use of the Network Manager Applet.

    Quote Originally Posted by tsu2 View Post
    Also,
    A common cause of "unable to connect to dbus" errors is trying to access something without proper permissions.
    I'm not sure why you're attempting to run NM with root permission, it's set up to run as the logged in normal User... I haven't tested running as root but the error is typical of that kind of incorrect use.
    I did NOT try to run the Network Manager Applet as root. After boot I'm logged in as standard user by default, without giving a password.
    From there on I clicked on the icon of the Network Manager Applet in the task bar.
    In older versions of openSUSE up to 42.3 this never caused problems.
    However, changing network setup may usually require root privileges at some point that I don't know, but if, this then is made transparent to the standard user, as a tribute to usability.
    All I can say is that it worked for me for years, i.e. on from earlier versions of openSUSE (probably openSUSE 11 or 12) up to Leap 42.

    Quote Originally Posted by tsu2 View Post
    As far as turning off your Wifi...
    I don't know that NM can do that, it's a configuration manager and AFAIK doesn't manage device on/off(but can configure a start configuration).
    For that, you might use a software solution like rfkill or a hardware switch on your laptop.

    TSU
    'rfkill' would be a good idea, but it can not be installed anymore from the repos for Leap 15!

    And I don't even expect that the Network Manager Applet would switch off the WiFi device.
    It would be sufficient to me if the connection by WiFi is disabled in certain situations - which worked for versions of openSUSE older than 15.

    Thanks for taking your time
    Mike

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,117
    Blog Entries
    2

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Apparently,
    rfkill is now packaged with a new management daemon...
    And the package installing the whole thing is now
    Code:
    zypper in urfkill
    I see by your explanation what you are trying to do,
    Hopefully using rfkill will avoid your problems.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  10. #10

    Default Re: Failed to connect to bus, failed to talk to init daemon

    Quote Originally Posted by tsu2 View Post
    Apparently,
    rfkill is now packaged with a new management daemon...
    And the package installing the whole thing is now
    Code:
    zypper in urfkill
    Good to know that!
    I once stumbled over rfkill working with another laptop that has a physical switch to disable/enable WiFi/WLAN.
    After switching off WiFi/WLAN, in openSUSE WLAN remained disabled even if that switch was used to turn WLAN on again.
    rfkill then was the solution.

    Installation of urfkill went smoothly.

    Quote Originally Posted by tsu2 View Post
    I see by your explanation what you are trying to do,
    Hopefully using rfkill will avoid your problems.
    The bad news is that rfkill doesn't solve the issue.

    I boot the same way as before: KDE, Network Manager.
    Using 'su' I become root in a terminal.
    I enter rfkill to output the current state, result:

    Code:
    # rfkill
    ID TYPE DEVICE      SOFT      HARD
     0 wlan phy0   unblocked unblocked
    #
    Fine, now trying to disable WLAN:

    Code:
    # rfkill block wlan
    #
    ... and check that state, ooooops:

    Code:
    # rfkill
    rfkill: cannot open /dev/rfkill: No such file or directory
    rfkill: cannot read /dev/rfkill: Bad file descriptor
    #
    I immediately try to shut down from the command line. Result:

    Code:
    # shutdown -h now
    Failed to connect to bus: No such file or directory
    Failed to talk to init daemon.
    #

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •