Results 1 to 8 of 8

Thread: Gmic dependancy: libopencv_core.so.3.4

  1. #1

    Default Gmic dependancy: libopencv_core.so.3.4

    Hi all

    Trying to install g'mic on opensuse 15.0 i get this dependancy error:
    nothing provides libopencv_core.so.3.4 (64bit) needed by gmic-2.5.3-lp.150.2.1.x86
    It is a fresh install of opensuse 15.0. I tried to install gmic on 15.1 before, resulting in the same error.

    a check on zypper gave me the following result:
    S | Name | Summary | Type
    --+------------------------+--------------------------------------------+--------
    i | libopencv3_3 | Libraries to use OpenCV computer vision | package
    | libopencv4_1 | Libraries to use OpenCV computer vision | package
    | libopencv4_1-debuginfo | Debug information for package libopencv4_1 | package
    So obviously, I need to ugrade libopencv tot 3.4, but I dont have a clue how to fix this..

    Any help appreciated!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,145

    Default AW: Gmic dependancy: libopencv_core.so.3.4

    Trying to install g'mic on opensuse 15.0 i get this dependancy error:
    Where do you get that package?

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,145

    Default AW: Gmic dependancy: libopencv_core.so.3.4

    It does not build anymore, so I think, you have installed the "old" one which is build against opencv 3.4 and now opencv 4.1 is in that Repo.

    https://build.opensuse.org/package/show/graphics/gmic

  4. #4

    Default Re: AW: Gmic dependancy: libopencv_core.so.3.4

    Quote Originally Posted by Sauerland View Post
    Where do you get that package?
    From repo
    http://download.opensuse.org/reposit...USE_Leap_15.0/

  5. #5

    Default Re: Gmic dependancy: libopencv_core.so.3.4

    so, from the build page, it turns out gmic doesnt build on any version of opensuse.

    Apart from using the gmic webservice, are there any solutions?

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,145

    Default AW: Gmic dependancy: libopencv_core.so.3.4


  7. #7

    Default Re: Gmic dependancy: libopencv_core.so.3.4

    installing from /home repo left me with a massive amount of dependancy errors.
    Tried the different options, but none of them resulted in a working gimic.

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,145

    Default AW: Gmic dependancy: libopencv_core.so.3.4

    I have build opencv in my /home Repo and installed gmic by enabling the graphics Repo and:
    Code:
    zypper in gmic
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 4 NEW packages are going to be installed:
      gmic libGraphicsMagick++-Q16-12 libgmic1 libopencv3_4
    
    4 new packages to install.
    Overall download size: 10.1 MiB. Already cached: 0 B. After the operation, additional 34.3 MiB will be
    used.
    Continue? [y/n/v/...? shows all options] (y): 
    Retrieving package libopencv3_4-3.4.5-lp150.3.1.x86_64             (1/4),   6.7 MiB ( 24.3 MiB unpacked)
    Retrieving: libopencv3_4-3.4.5-lp150.3.1.x86_64.rpm ................................[done (487.1 KiB/s)]
    Retrieving package libGraphicsMagick++-Q16-12-1.3.32-lp150.130.1.x86_64
                                                                       (2/4), 140.7 KiB (468.9 KiB unpacked)
    Retrieving: libGraphicsMagick++-Q16-12-1.3.32-lp150.130.1.x86_64.rpm ...............[done (437.2 KiB/s)]
    Retrieving package libgmic1-2.5.3-lp150.2.1.x86_64                 (3/4),   2.1 MiB (  6.3 MiB unpacked)
    Retrieving: libgmic1-2.5.3-lp150.2.1.x86_64.rpm ....................................[done (559.1 KiB/s)]
    Retrieving package gmic-2.5.3-lp150.2.1.x86_64                     (4/4),   1.1 MiB (  3.2 MiB unpacked)
    Retrieving: gmic-2.5.3-lp150.2.1.x86_64.rpm ........................................[done (538.6 KiB/s)]
    Checking for file conflicts: .....................................................................[done]
    (1/4) Installing: libopencv3_4-3.4.5-lp150.3.1.x86_64 ............................................[done]
    (2/4) Installing: libGraphicsMagick++-Q16-12-1.3.32-lp150.130.1.x86_64 ...........................[done]
    (3/4) Installing: libgmic1-2.5.3-lp150.2.1.x86_64 ................................................[done]
    (4/4) Installing: gmic-2.5.3-lp150.2.1.x86_64 ....................................................[done]
    gmic_qt is starting.

    libopencv:

    https://download.opensuse.org/reposi...3.1.x86_64.rpm
    or Repo:
    https://download.opensuse.org/reposi...USE_Leap_15.0/
    Last edited by Sauerland; 14-Sep-2019 at 08:49.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •