Results 1 to 10 of 10

Thread: Updates coming daily - Have setting at 1 month - some I don't want

  1. #1
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Updates coming daily - Have setting at 1 month - some I don't want

    Updates coming daily - Have setting at 1 month - some I don't want but keep nagging me to install.
    The daily thing is the tray update checker. It won't recognize the 1 month setting. WHY?

    I get a security update for libreoffice. I removed Libreoffice.
    Possible some arcane place in the system I can't find that still has references to Libreoffice?
    If so, how would I find it?
    Using YaST and searching for 'libreoffice' the only thing in the list that is installed is
    Code:
    libhyphen0                     | A simple thesaurus for Libreoffice
    and if I try to delete it, it also removes hplip(which I need.

    And I have marked Opera as 'Protected'. yet that thing in the tray still want to update it.
    I don't want it updated. the new version has some changes that are not very user friendly IMO,
    and the incognito colors(which I can't change) are terrible! Purple! Really Opera?
    Is there a way to stop that tray thing from nagging me to update?

    I hate to remove the widget, because it does indicate when there are updates, and I'm not sure it wouldn't nag me if I did remove the widget!

    EDIT>>> I went ahead and uninstalled the 'libhypnen0' and chose the last option in the dependency list, and it only removed 'libhyphen0'.
    I guess I will see if the security update for Libreoffice still want to install.
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  2. #2
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    204

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Had similar problems here with the KDE/Plasma Software Updates widget. It never respected my »weekly« setting. Last year, I deactivated it.
    I now use mostly YaST’s excellent »Online Update« and »Software Management« for keeping my Leap 15.0 main rig up to date and check for any package dependencies.
    Since I work within xterm+bash a lot every day, I manually use the zypper command near weekends in order to look for any updates:
    Code:
    rig:~ ▶ zypper lifecycle
    
    Product end of support                                  
    Codestream: openSUSE Leap 15                            2021-11-30
        openSUSE Leap 15.0                                  2019-11-30
    
    Package end of support if different from product:
    libIlmImf-2_2-23                         Now, installed 2.2.1-lp150.2.6.1, update available 2.2.1-lp150.2.9.1 
    libapparmor1                             Now, installed 2.12.2-lp150.6.14.1, update available 2.12.3-lp150.6.17.1 
    libopenssl1_0_0                          Now, installed 1.0.2p-lp150.2.13.1, update available 1.0.2p-lp150.2.16.1 
    libopenssl1_0_0-steam                    Now, installed 1.0.2p-lp150.2.9.1, update available 1.0.2p-lp150.2.16.1 
    libopenssl1_0_0-steam-32bit              Now, installed 1.0.2p-lp150.2.9.1, update available 1.0.2p-lp150.2.16.1 
    libsolv-tools                            Now, installed 0.6.35-lp150.2.3.1, update available 0.7.5-lp150.7.1 
    libwps-0_4-4                             Now, installed 0.4.9-lp150.2.3.1, update available 0.4.10-lp150.7.1 
    libxml2-2                                Now, installed 2.9.7-lp150.2.6.1, update available 2.9.7-lp150.2.10.1 
    libxml2-2-32bit                          Now, installed 2.9.7-lp150.2.6.1, update available 2.9.7-lp150.2.10.1 
    libxml2-devel                            Now, installed 2.9.7-lp150.2.6.1, update available 2.9.7-lp150.2.10.1 
    libxml2-tools                            Now, installed 2.9.7-lp150.2.6.1, update available 2.9.7-lp150.2.10.1 
    libyui-ncurses-pkg8                      Now, installed 2.48.5.2-lp150.2.3.1, update available 2.48.5.2-lp150.7.1 
    libyui-qt-pkg8                           Now, installed 2.45.15.2-lp150.2.3.1, update available 2.45.15.2-lp150.7.1 
    libzstd1                                 Now, installed 1.3.4-lp150.1.2, update available 1.4.2-lp150.2.3.1 2019-11-30
    libzypp                                  Now, installed 17.7.2-lp150.2.9.1, update available 17.12.0-lp150.2.13.1 
    nvidia-computeG04                        Now, installed 390.116-lp150.7.1, update available 390.129-lp150.6.1 
    nvidia-gfxG04-kmp-default                Now, installed 390.116_k4.12.14_lp150.11-lp150.7.1, update available 390.129_k4.12.14_lp150.11-lp150.6.1 
    nvidia-glG04                             Now, installed 390.116-lp150.7.1, update available 390.129-lp150.6.1 
    polkit-default-privs                     Now, installed 13.2-lp150.8.22.1, update available 13.2-lp150.8.25.1 
    python-solv                              Now, installed 0.6.35-lp150.2.3.1, update available 0.7.5-lp150.7.1 
    x11-video-nvidiaG04                      Now, installed 390.116-lp150.7.1, update available 390.129-lp150.6.1 
    yast2-pkg-bindings                       Now, installed 4.0.13-lp150.2.10.1, update available 4.0.13-lp150.2.13.1 
    zypper                                   Now, installed 1.14.12-lp150.2.9.2, update available 1.14.28-lp150.2.13.1 
    zypper-aptitude                          Now, installed 1.14.12-lp150.2.9.2, update available 1.14.28-lp150.2.13.1 
    zypper-log                               Now, installed 1.14.12-lp150.2.9.2, update available 1.14.28-lp150.2.13.1 
    
    rig:~ ▶ _
    Oh, time to update some packages.

    Sorry, all I can offer is this workaround, not a solution. Oh well.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Quote Originally Posted by unix111 View Post
    Code:
    rig:~ ▶ zypper lifecycle
    Interesting. I'll note that "zypper lifecycle" is not documented in the man page for "zypper".

    I normally use "zypper lu" if I just want to see what's available. Or "zypper lp" to list only the available patches.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Sep 2012
    Posts
    5,230

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Quote Originally Posted by Bill_L View Post
    Have setting at 1 month
    "Having setting" it where exactly?

  5. #5
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Quote Originally Posted by arvidjaar View Post
    "Having setting" it where exactly?
    Right click on the software update widget, and selected 'Configure Software Updates'. There are daily, weekly and monthly choices.
    But I found that it reverts back to daily with each re-boot. DO NOT KNOW WHY!
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  6. #6
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    601

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    I Have since found that the seccurity update for Libreoffice, was actually updates to a spell checker that is used for several things in Firefox as well.
    I removed Firefox and then got rid of those spell checkers.
    I'll see what happens when I boot up next time.

    I don't mind using zypper for finding and installing updates. But I really don't want my wife having 'root privileges' on her laptop.
    So, i would still like to find a way to discourage that widget from nagging on things set to 'protected' mode in YaST.

    @nrickert this is a link to SUSE about the zypper lifestyle command https://www.suse.com/documentation/s...lifecycle.html
    And here for Leap15.1 (in Chapter 3 - Packaging Changes) https://doc.opensuse.org/release-not...USE/Leap/15.1/
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,215
    Blog Entries
    15

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Quote Originally Posted by Bill_L View Post
    Right click on the software update widget, and selected 'Configure Software Updates'. There are daily, weekly and monthly choices.
    But I found that it reverts back to daily with each re-boot. DO NOT KNOW WHY!
    Hi
    That would be a bug and worth reporting? I just kill off packagekit....

    Code:
    zypper rm PackageKit PackageKit-backend-zypp PackageKit-lang PackageKit-branding-openSUSE
    zypper al PackageKit PackageKit-backend-zypp PackageKit-lang PackageKit-branding-openSUSE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Quote Originally Posted by Bill_L View Post
    @nrickert this is a link to SUSE about the zypper lifestyle command https://www.suse.com/documentation/s...lifecycle.html
    And here for Leap15.1 (in Chapter 3 - Packaging Changes) https://doc.opensuse.org/release-not...USE/Leap/15.1/
    Thanks for that reference.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  9. #9
    Join Date
    Jan 2017
    Location
    Nürnberg, Germany
    Posts
    204

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    There is also an unfortunately named manpage:
    Code:
    man zypper-lifecycle

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: Updates coming daily - Have setting at 1 month - some I don't want

    Quote Originally Posted by unix111 View Post
    There is also an unfortunately named manpage:
    Code:
    man zypper-lifecycle
    Thanks. I would not have thought to look for that.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •