Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Keyboard layout setting not maintained after logout

  1. #11
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    966

    Default Re: Keyboard layout setting not maintained after logout

    Quote Originally Posted by deano_ferrari View Post
    ??? But how do they relate to incorrect keyboard layouts in a DE? Can you clarify more meaningfully?
    • Several of them refer to keyboard settings, although they try to change their settings only.
    • Software installed increases the number of options which may confuse users.
    • The installation may remember earlier software installs even when removed.

    On a pristine installation of Arch Linux/KDE keyboard configuration for is straight forward because it does not have a GUI for doing so. You need to add manually:

    Code:
    erlangen:~ # cat /ArchLinux/etc/X11/xorg.conf.d/20-keyboard.conf 
    Section "InputClass"
            Identifier "keyboard"
            MatchIsKeyboard "yes"
            Option "XkbLayout" "de"
            Option "XkbVariant" "nodeadkeys"
    EndSection
    erlangen:~ #
    openSUSE has:
    Code:
    erlangen:~ # cat /etc/X11/xorg.conf.d/00-keyboard.conf
    # Read and parsed by systemd-localed. It's probably wise not to edit this file
    # manually too freely.
    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "de"
            Option "XkbModel" "microsoftpro"
            Option "XkbVariant" "nodeadkeys"
            Option "XkbOptions" "terminate:ctrl_alt_bksp"
    EndSection
    erlangen:~ #
    That works reliably too, unless somebody else tinkers with settings, such as YaST or a Linux user.

    The Live version of Leap has:

    Code:
    erlangen:~ # cat /run/media/karl/cow/rw/etc/X11/xorg.conf.d/00-keyboard.conf
    # Written by systemd-localed(8), read by systemd-localed and Xorg. It's
    # probably wise not to edit this file manually. Use localectl(1) to
    # instruct systemd-localed to update it.
    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "us"
            Option "XkbModel" "pc105+inet"
            Option "XkbOptions" "terminate:ctrl_alt_bksp"
    EndSection
    erlangen:~ #
    I desperately tried to switch to "de" and finally succeeded by copying the Arch Linux configuration to Leap: /etc/vconsole.conf and /etc/X11/xorg.conf.d/20-keyboard.conf
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  2. #12
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,294
    Blog Entries
    1

    Default Re: Keyboard layout setting not maintained after logout

    Yes, but the user-specific keyboard settings within KDE should determine the keyboard layout within the DE environment when configured to do so.
    openSUSE Leap 15.0; KDE Plasma 5

  3. #13
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    966

    Default Re: Keyboard layout setting not maintained after logout

    Quote Originally Posted by deano_ferrari View Post
    Yes, but the user-specific keyboard settings within KDE should determine the keyboard layout within the DE environment when configured to do so.
    Yes it should, but actually it didn't. I tried hard with KDE System Settings, but failed. So I changed system wide settings as described above and succeeded at the first try.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  4. #14

    Default Re: Keyboard layout setting not maintained after logout

    For the avoidance of doubt I do not have two keyboard options set, only one for UK and in set in two places. In Yast I have Hardware>System Keyboard>English UK
    In System Settings I have Hardware>Input Devices>Keyboard>Layout>English (UK) mapped and labled as gb.

    I had a look where suggested and have:-

    Code:
    alastair@AJBR-W530:~> cat /etc/X11/xorg.conf.d/00-keyboard.conf
    # Written by systemd-localed(8), read by systemd-localed and Xorg. It's
    # probably wise not to edit this file manually. Use localectl(1) to
    # instruct systemd-localed to update it.
    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "gb"
            Option "XkbModel" "microsoftpro"
            Option "XkbOptions" "terminate:ctrl_alt_bksp"
    EndSection
    alastair@AJBR-W530:~>
    The point about Gnome is interesting but I have never installed Gnome desktop here. It is possible some Gnome stuff is installed because of dependencies being dragged in by an application but not the whole desktop.



    What more can I say.

  5. #15
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    966

    Default Re: Keyboard layout setting not maintained after logout

    Quote Originally Posted by Budgie2 View Post
    For the avoidance of doubt I do not have two keyboard options set, only one for UK and in set in two places. In Yast I have Hardware>System Keyboard>English UK
    In System Settings I have Hardware>Input Devices>Keyboard>Layout>English (UK) mapped and labled as gb.

    I had a look where suggested and have:-

    Code:
    alastair@AJBR-W530:~> cat /etc/X11/xorg.conf.d/00-keyboard.conf
    # Written by systemd-localed(8), read by systemd-localed and Xorg. It's
    # probably wise not to edit this file manually. Use localectl(1) to
    # instruct systemd-localed to update it.
    Section "InputClass"
            Identifier "system-keyboard"
            MatchIsKeyboard "on"
            Option "XkbLayout" "gb"
            Option "XkbModel" "microsoftpro"
            Option "XkbOptions" "terminate:ctrl_alt_bksp"
    EndSection
    alastair@AJBR-W530:~>
    The point about Gnome is interesting but I have never installed Gnome desktop here. It is possible some Gnome stuff is installed because of dependencies being dragged in by an application but not the whole desktop.



    What more can I say.
    What about:

    Code:
    erlangen:~ # localectl
       System Locale: LC_CTYPE=de_DE.UTF-8
           VC Keymap: de-nodeadkeys
          X11 Layout: de
           X11 Model: microsoftpro
         X11 Variant: nodeadkeys
         X11 Options: terminate:ctrl_alt_bksp
    erlangen:~ # journalctl -b | grep -i kbd
    Aug 21 16:48:58 erlangen display-manager[1397]: I: Using systemd /usr/share/systemd/kbd-model-map mapping
    Aug 21 17:30:58 erlangen org_kde_powerdevil[2001]: powerdevil: Kbd backlight brightness value:  0
    Aug 21 18:56:58 erlangen org_kde_powerdevil[2001]: powerdevil: Kbd backlight brightness value:  0
    erlangen:~ # journalctl -b | grep -i keyboard
    Aug 21 16:48:53 erlangen kernel: hid-generic 0003:046A:0011.0002: input,hidraw1: USB HID v1.11 Keyboard [HID 046a:0011] on usb-0000:00:14.0-2/input0
    Aug 21 16:48:53 erlangen systemd[1]: Starting Apply settings from /etc/sysconfig/keyboard...
    Aug 21 16:48:53 erlangen systemd[1]: Started Apply settings from /etc/sysconfig/keyboard.
    erlangen:~ #
    Ever tried a pristine user?
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  6. #16
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,294
    Blog Entries
    1

    Default Re: Keyboard layout setting not maintained after logout

    Quote Originally Posted by hcvv View Post
    Just to increase confusion.

    This EN and US in the panel reminds me of a configuration (in KDE) where more then one keyboard layout are defined. Note: NOT languages, but keyboard layouts. This to allow the user to switch between them, either because he switches two keyboards, or because he uses the existing keyboard in two ways (in at least one way ignoring what is engraved on the keys, maybe having a paper overlay of some kind to help him in hitting the correct key combinations).
    I don't usually have two (or more) keyboard layouts configured, but I now have 'gb English (UK)' and 'us English (US)' configured with the UK keyboard layout at the top ie active within my KDE environment. It displays in the panel as you describe Henk. I also had the IBus icon displaying, but I have removed IBus now. Anyway, as you say two or more keyboards do cause the current active keyboard layout to be displayed and can also be changed from there. It all works as expected for me with Leap 15.1.
    openSUSE Leap 15.0; KDE Plasma 5

  7. #17

    Default Re: Keyboard layout setting not maintained after logout

    My problem with the keyboard layout switching to US layout has been thT in spite of both System Settings>Hardware>Input Devices>Keyboard layout being mapped as gb, English (UK) and Yast Control Centre>Hardware>System Keyboard Layout>English UK and no other layouts selected I still get a US layout.

    The uncalled for change is tolerable but on occasions a nuisance and once it has switched to US layout it tends to stay that way.

    In playing around with System Setting I added the option Show flag to the previous settings of Show layout indicator and Show for single layout. Since then the layout has remained working as English UK!!!

    Just thought I would share this and show the flag to a wider audience.

    Budgie2

  8. #18

    Default Re: Keyboard layout setting not maintained after logout

    Quote Originally Posted by Budgie2 View Post
    My problem with the keyboard layout switching to US layout has been thT in spite of both System Settings>Hardware>Input Devices>Keyboard layout being mapped as gb, English (UK) and Yast Control Centre>Hardware>System Keyboard Layout>English UK and no other layouts selected I still get a US layout.

    The uncalled for change is tolerable but on occasions a nuisance and once it has switched to US layout it tends to stay that way.

    In playing around with System Setting I added the option Show flag to the previous settings of Show layout indicator and Show for single layout. Since then the layout has remained working as English UK!!!

    Just thought I would share this and show the flag to a wider audience.

    Budgie2
    As usual, wrote too soon. US layout back again. The only benefit now is it is easier to notice the wrong flag and switch back using the flag.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •