Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

  1. #1

    Default How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    KDE5 update widget "plasma5-pk-updates" has good tuning in Leap 15.0.
    It is searching for updates at a boot time only once, then I can run it manually when I need it.
    I set it searching for updates every week (once a week).
    But in Leap 15.1 update widget is seeking for updates every time I plug in network cable.

    How can I configure its behaviour?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,616
    Blog Entries
    3

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    I prefer to disable that update applet (in System Tray Settings), and then use "zypper" or "Yast" to check for updates.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Some developers loves to make life worser: https://reposcope.com/package/plasma5-pk-updates

    OpenSUSE Leap 15.1 oss: Updated from 0.3.2-lp151.1.1 to 0.3.2-lp151.2.1
    Mar 30

    Add patches already approved by upstream to delay any check for updates until the network is online if the network is offline . The patches also fix some visibility issues of widgets that don't make sense if the network is offline. This is part of the fix for boo#1103678.
    0001-Hide-updates-and-checkbox-when-system-is-offline.patch
    0002-Add-its-own-messageChanged-NOTIFY-signal-to-message.patch
    0003-Delay-PkUpdates-checkUpdates-calls-if-the-network-is-offline.patch
    Rebase patch:
    0001-Hide-option-to-install-updates-on-Tumbleweed.patch
    https://bugzilla.opensuse.org/show_bug.cgi?id=1103678

    https://build.opensuse.org/request/show/687416

    https://kompsekret.ru/q/how-can-i-di...plasma-105942/


    Last edited by malcolmlewis; 18-Aug-2019 at 16:01.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Then remove the updater and use zypper up

    The updater is going to update that is what it is designed to do. If you want to only manually update then use zypper

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,822
    Blog Entries
    15

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Quote Originally Posted by Svyatko View Post
    Some developers loves to make life worser: https://reposcope.com/package/plasma5-pk-updates
    Hi
    A friendly reminder about our Forum T&C's, language and attacks will not be tolerated.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    980

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Quote Originally Posted by Svyatko View Post
    KDE5 update widget "plasma5-pk-updates" has good tuning in Leap 15.0.
    It is searching for updates at a boot time only once, then I can run it manually when I need it.
    I set it searching for updates every week (once a week).
    But in Leap 15.1 update widget is seeking for updates every time I plug in network cable.

    How can I configure its behaviour?
    I unchecked Software Updates in the system Tray and changed settings to run /usr/bin/true which has no side effects when invoked inadvertently.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  7. #7

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    reading something in the web I masked and stopped the service and seems to work :-)
    Code:
      pla4-TW:~ # systemctl stop packagekit 
    pla4-TW:~ # systemctl mask packagekit
    ...there is tiny a problem, the packagekit icon in the system tray isn't shown

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,133

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Quote Originally Posted by pier_andreit View Post
    reading something in the web I masked and stopped the service and seems to work :-)
    Code:
      pla4-TW:~ # systemctl stop packagekit 
    pla4-TW:~ # systemctl mask packagekit
    ...there is tiny a problem, the packagekit icon in the system tray isn't shown
    I do not understand the problem. You (as system administrator) stop the service and as a result the service connected applet vanishes from the end-users desktop. That is what I would expect.
    Henk van Velden

  9. #9

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Quote Originally Posted by hcvv View Post
    I do not understand the problem. You (as system administrator) stop the service and as a result the service connected applet vanishes from the end-users desktop. That is what I would expect.
    yes, the icon is not present but only the icon, the space of packagekit is present, the click on the space produce the popup window of "software updates" with "network is offline", I expected that or the icon disappear and also the space, or the icon should have a sort of inactive icon that should appear :-)

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,133

    Default Re: How to configure KDE5 widget for getting updates only with my request? (plasma5-pk-updates)

    Well, that is a better description of what you see then.

    I haven't Packagekit installed at all (and tabood it), thus my situation is not the same as yours.

    I am not good at playing with KDE settings, but can you not remove the (empty) icon from the panel?
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •