Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 37

Thread: Samaba headache again

  1. #21
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,286
    Blog Entries
    1

    Default Re: Samaba headache again

    Quote Originally Posted by gogalthorp View Post
    No mdns was not in default. I added it but no go. note that default is public right??? I set public up as I thought it should be with my past experience. But maybe that is wrong. Exactly which zones should be used and what are the new settings in general for samba simple pier to pier on local net only. Things were simpler when there were only 3 zones defined
    The firewall settings are ok now, but you may need to restart avahi-daemon
    Code:
    sudo systemctl restart avahi-daemon
    then check
    Code:
    avahi-browse -art
    BTW, any machine providing samba shares is acting as a samba server, and may also be a client. From a firewalld perspective, 'samba' service opens ports 445(tcp), 137(udp),138(udp), and 139(tcp), while 'samba-client' service opens ports 137(udp) and 138(udp).
    openSUSE Leap 15.0; KDE Plasma 5

  2. #22
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Samaba headache again

    Still nothing
    Note I'm restartin Samba after every iteration

    Code:
    linux1:/home/gogalthorp # systemctl restart avahi-daemon     
    linux1:/home/gogalthorp # systemctl status avahi-daemon 
    ● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
       Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: enabled)
       Active: active (running) since Mon 2019-08-12 14:41:55 EDT; 12s ago
     Main PID: 25754 (avahi-daemon)
       Status: "Server startup complete. Host name is linux1.local. Local service cookie is 69670634."
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/avahi-daemon.service
               └─25754 avahi-daemon: running [linux1.local]
    
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::f2a3>
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: New relevant interface eth0.IPv6 for mDNS.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.1.>
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: New relevant interface eth0.IPv4 for mDNS.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Network interface enumeration completed.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Registering new address record for fe80::f2a3:9cf7:561a:4aba on eth0.*.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Registering new address record for 192.168.1.3 on eth0.IPv4.
    Aug 12 14:41:56 linux1.localdomain avahi-daemon[25754]: Server startup complete. Host name is linux1.local. Local service cookie is>
    Aug 12 14:41:57 linux1.localdomain avahi-daemon[25754]: Service "linux1" (/etc/avahi/services/ssh.service) successfully established.
    Aug 12 14:41:57 linux1.localdomain avahi-daemon[25754]: Service "linux1" (/etc/avahi/services/sftp-ssh.service) successfully establ>
    ...skipping...
    ● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
       Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: enabled)
       Active: active (running) since Mon 2019-08-12 14:41:55 EDT; 12s ago
     Main PID: 25754 (avahi-daemon)
       Status: "Server startup complete. Host name is linux1.local. Local service cookie is 69670634."
        Tasks: 1 (limit: 4915)
       CGroup: /system.slice/avahi-daemon.service
               └─25754 avahi-daemon: running [linux1.local]
    
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::f2a3>
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: New relevant interface eth0.IPv6 for mDNS.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.1.>
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: New relevant interface eth0.IPv4 for mDNS.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Network interface enumeration completed.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Registering new address record for fe80::f2a3:9cf7:561a:4aba on eth0.*.
    Aug 12 14:41:55 linux1.localdomain avahi-daemon[25754]: Registering new address record for 192.168.1.3 on eth0.IPv4.
    Aug 12 14:41:56 linux1.localdomain avahi-daemon[25754]: Server startup complete. Host name is linux1.local. Local service cookie is>
    Aug 12 14:41:57 linux1.localdomain avahi-daemon[25754]: Service "linux1" (/etc/avahi/services/ssh.service) successfully established.
    Aug 12 14:41:57 linux1.localdomain avahi-daemon[25754]: Service "linux1" (/etc/avahi/services/sftp-ssh.service) successfully establ>
    Code:
    linux1:/home/gogalthorp # avahi-browse -art
    +   eth0 IPv6 LINUX1                                        _device-info._tcp    local
    +   eth0 IPv4 LINUX1                                        _device-info._tcp    local
    +   eth0 IPv6 LINUX1                                        Microsoft Windows Network local
    +   eth0 IPv4 LINUX1                                        Microsoft Windows Network local
    +   eth0 IPv6 linux1                                        SSH Remote Terminal  local
    +   eth0 IPv4 linux1                                        SSH Remote Terminal  local
    +   eth0 IPv6 linux1                                        SFTP File Transfer   local
    +   eth0 IPv4 linux1                                        SFTP File Transfer   local
    =   eth0 IPv6 LINUX1                                        _device-info._tcp    local
       hostname = [linux1.local]
       address = [fe80::f2a3:9cf7:561a:4aba]
       port = [0]
       txt = ["model=MacSamba"]
    =   eth0 IPv4 LINUX1                                        _device-info._tcp    local
       hostname = [linux1.local]
       address = [192.168.1.3]
       port = [0]
       txt = ["model=MacSamba"]
    =   eth0 IPv6 LINUX1                                        Microsoft Windows Network local
       hostname = [linux1.local]
       address = [fe80::f2a3:9cf7:561a:4aba]
       port = [445]
       txt = []
    =   eth0 IPv4 LINUX1                                        Microsoft Windows Network local
       hostname = [linux1.local]
       address = [192.168.1.3]
       port = [445]
       txt = []
    =   eth0 IPv6 linux1                                        SSH Remote Terminal  local
       hostname = [linux1.local]
       address = [fe80::f2a3:9cf7:561a:4aba]
       port = [22]
       txt = []
    =   eth0 IPv4 linux1                                        SSH Remote Terminal  local
       hostname = [linux1.local]
       address = [192.168.1.3]
       port = [22]
       txt = []
    =   eth0 IPv6 linux1                                        SFTP File Transfer   local
       hostname = [linux1.local]
       address = [fe80::f2a3:9cf7:561a:4aba]
       port = [22]
       txt = []
    =   eth0 IPv4 linux1                                        SFTP File Transfer   local
       hostname = [linux1.local]
       address = [192.168.1.3]
       port = [22]
       txt = []

  3. #23
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,286
    Blog Entries
    1

    Default Re: Samaba headache again

    Now your avahi-browse output shows active services so that is progress.
    openSUSE Leap 15.0; KDE Plasma 5

  4. #24
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,286
    Blog Entries
    1

    Default Re: Samaba headache again

    You will likely need to restart your desktop session, and you should then find that Dolphin will display these services graphically.

    Network > Network (you may need to refresh/redisplay with F5 first)

    or type 'network:/' in the location bar. You should see a folder icon representing the host(s) concerned. Click on a host and all the services (represented as icons) should show for the respective host.
    Last edited by deano_ferrari; 12-Aug-2019 at 12:39.
    openSUSE Leap 15.0; KDE Plasma 5

  5. #25
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Samaba headache again

    Tried reboot. I agree it looks better but something is staill missing

  6. #26
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,286
    Blog Entries
    1

    Default Re: Samaba headache again

    Quote Originally Posted by gogalthorp View Post
    Tried reboot. I agree it looks better but something is staill missing
    Do you start KDE with a new session, or stay with existing session?
    openSUSE Leap 15.0; KDE Plasma 5

  7. #27
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,286
    Blog Entries
    1

    Default Re: Samaba headache again

    The 'network:/' KIO shows nothing when entered in to the location bar?
    openSUSE Leap 15.0; KDE Plasma 5

  8. #28
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Samaba headache again

    Quote Originally Posted by deano_ferrari View Post
    The 'network:/' KIO shows nothing when entered in to the location bar?
    It does show linux1 under that there are 4 instances of linux1
    unknown, SFTP, SMB, SSH servers The unknown and SMB show the local shared directory. No sign of the other two OS but they both see all others.

    Never looked in the network entry which translates to remote: I have always used the shared folders(SMB)

    I'm not seeing the network MSHOME which should have all the OS under it.

  9. #29
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,286
    Blog Entries
    1

    Default Re: Samaba headache again

    Quote Originally Posted by gogalthorp View Post
    It does show linux1 under that there are 4 instances of linux1
    unknown, SFTP, SMB, SSH servers The unknown and SMB show the local shared directory.
    Great! They all represent services that 'linux'1 host provides.

    No sign of the other two OS but they both see all others.
    No, they won't show up here - only Bonjour/Avahi aware (eg Linux/Mac) hosts would show up here. It would be nice if Windows 10 machines would use DNS-SD to the same. That's why I mentioned way back in post #9...
    For samba running on Linux hosts only, avahi can be employed for similar discovery...
    Never looked in the network entry which translates to remote: I have always used the shared folders(SMB)
    Yes, it's for Avahi aware hosts. It relies on DNS service discovery (DNS-SD), which is what we've been exploring here.

    I'm not seeing the network MSHOME which should have all the OS under it.
    The NetBIOS-based discovery is no longer unless you explicitly enable it and have hosts still using SMBv1. For my Windows 10 shares, I can reach it by name using
    Code:
    smb://<hostname>.local
    but as I already mentioned I generally just save the required URLs to my 'Remote' places in Dolphin for future access.
    Last edited by deano_ferrari; 12-Aug-2019 at 20:42.
    openSUSE Leap 15.0; KDE Plasma 5

  10. #30
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Samaba headache again

    smb://linux1.local shows local shares

    But I still don't see the Window shares can you give me an example URL?

Page 3 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •