Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Plasma error on update

  1. #1

    Default Plasma error on update

    I have just updated to LEAP 15.1 from 42.3 and upon booting it is saying plasma is unable to start as it could not correctly use OpenGL 2. Please check that your graphic drivers are set up correctly.

    From what I remember I used the G04 Nvidia drivers on 42.3. Please can someone help in letting me know how to get around this I can't actually do anything at the moment. It is set to automatic log in (it's a PC at home, not a laptop) so can't even get to the log in screen.

    Any help is greatly appreciated.

  2. #2

    Default Re: Plasma error on update

    Forgot to add, once I close the windows I am left with a totally black screen with a very large cursor/arrow. Thanks.

  3. #3

    Default Re: Plasma error on update

    I managed to get to a text log in, I used zypper to install the nvidia repo, uninstall then reinstall my drivers using the newer repo but still no luck. When I close the first window I am left with ksplashgml closed unexpectedly....

    Thanks

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,645

    Default Re: Plasma error on update

    NVIDA driver may not update depending on the update method and NVIDIA repo availability.

    Log into a terminal at boot as root and add the NVIDIA repo if needed and add the drivers then reboot.

    Note also if this is a notebook then you would need to deal with Optimus hardware and use either suse-prime or bumblebee to deal with the hybrid graphics.

    If you need more detail ask

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,645

    Default Re: Plasma error on update

    hmmm should have worked. This is why I always do a fresh install and just keep my home. I keep two root partitions that I rotate for each new version I install that why I can drop back to the previous if the new version has problems.

    Can you boot with nomodeset??

  6. #6

    Default Re: Plasma error on update

    Quote Originally Posted by gogalthorp View Post
    hmmm should have worked. This is why I always do a fresh install and just keep my home. I keep two root partitions that I rotate for each new version I install that why I can drop back to the previous if the new version has problems.

    Can you boot with nomodeset??
    Thanks,

    I had a look at the repos using zypper and found that opensuse 15.1 update was not enabled. I enabled it, refreshed the repos, then forced an update. It asked to update nvidia drivers which I'm now doing, let's see what happens with another reboot....

  7. #7

    Default Re: Plasma error on update

    AHA, I'm in!! Woo

    Thanks

  8. #8
    Join Date
    Dec 2008
    Location
    Corrientes, Argentina
    Posts
    3

    Unhappy Re: Plasma error on update

    I have the same problem, but in a new installation of Leap 15.1. And I don't know where to report.

  9. #9

    Default Re: Plasma error on update

    Have same issue after recent update in Tumbleweed.

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,645

    Default Re: Plasma error on update

    Quote Originally Posted by emtorres View Post
    I have the same problem, but in a new installation of Leap 15.1. And I don't know where to report.
    First off tell us the GPU hardware and if this is a notebook.

    Can you boot with nomodeset?

    At boot screen press e
    Find line startin linux or linuxefi
    go to the end of that line (note it wraps)
    add a space and nomodeset
    F10 to continue boot

    this will load fall back drivers that shold work with any hardware but with reduced proformance. but it will allow you to install needed drivers

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •