Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: WLAN mit Router verbunden aber kein Internet Zugang

  1. #1

    Question WLAN mit Router verbunden aber kein Internet Zugang

    Hallo
    Nach der Installation von Leap 15.1 kann ich mit dem Network Manager eine Internet Verbindung über ein LAN Kabel und den Router aufbauen oder auch über eine mobile Breitbandverbindung mittels eines Huawei Sticks. Die Verbindung funktioniert aber nicht über den WiFi Anschluß mit demselben Router. Der Network Manager sagt, er ist verbunden mit der WiFi Adresse des Routers, aber schon das Ping Kommando an den Router wird nicht beantwortet. Firefox meldet, daß keine Internet Verbindung besteht. Auf dem Notebook ist auch Windows 10 installiert und da funktioniert die WiFi Verbindung. Es handelt sich um das Medion Notebook P7652. Der Flugzeug Modus ist ausgeschaltet und WiFi aktiviert.

    Ein anderes Medion Notebook mit Leap 15.0 baut die WiFi Verbindung über denselben Router mit der gleichen Adresse auf und Firefox zeigt die aufgerufene Seite an.

    Weil ich mich mit den Kommandos zum Zustand der Internet Verbindungen nicht so gut auskenne, möchte ich hier erstmal nichts veröffentlichen, sondern bitte die Fachleute um die Angabe der erforderlichen Abfragen. Die Ausgaben trage ich dann hier ein.

    Für jeden Ratschlag bin ich dankbar.

    kl

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Poste (Ausgabe bitte in Code-Tags):
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    Code:
    rfkill list all

  3. #3

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Hallo Sauerland

    Hier sind die Ergebnisse
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    02:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
            Subsystem: Intel Corporation Device [8086:1010]
            Kernel driver in use: iwlwifi
            Kernel modules: iwlwifi
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
            Subsystem: Pegatron Device [1b0a:20d9]
            Kernel driver in use: r8169
            Kernel modules: r8169
    Code:
    sudo rfkill list all
    [sudo] Passwort für root: 
    0: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: no
    1: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no
    Einmal habe ich den Hinweis gefunden, daß der Treiber r8169 zu instabilem Verhalten führen könnte.
    Vielen Dank für die schnelle Reaktion.

    kl

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Einmal habe ich den Hinweis gefunden, daß der Treiber r8169 zu instabilem Verhalten führen könnte.
    Das ist aber kein Wlan sondern Kabel.....

    Poste:
    Code:
    journalctl -b | grep -Ei 'firm|iwlwifi'

  5. #5

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Hallo Sauerland

    Code:
    journalctl -b | grep -Ei 'firm|iwlwifi'
    Aug 10 20:15:01 linux-gmaw kernel: Spectre V2 : Enabling Restricted Speculation for firmware calls
    Aug 10 20:15:01 linux-gmaw kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    Aug 10 20:15:04 linux-gmaw kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.9f0a2d68.0 op_mode iwlmvm
    Aug 10 20:15:04 linux-gmaw kernel: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
    Aug 10 20:15:04 linux-gmaw kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8265, REV=0x230
    Aug 10 20:15:04 linux-gmaw kernel: iwlwifi 0000:02:00.0: base HW address: 9c:da:3e:6e:ab:7c
    Aug 10 20:15:04 linux-gmaw kernel: [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS
    Aug 10 20:15:05 linux-gmaw kernel: Bluetooth: hci0: Minimum firmware build 1 week 10 2014
    Aug 10 20:15:05 linux-gmaw kernel: Bluetooth: hci0: Found device firmware: intel/ibt-12-16.sfi
    Aug 10 20:15:06 linux-gmaw kernel: Bluetooth: hci0: Waiting for firmware download to complete
    Aug 10 20:15:06 linux-gmaw kernel: Bluetooth: hci0: Firmware loaded in 1423690 usecs
    Aug 10 20:15:06 linux-gmaw NetworkManager[1353]: <info>  [1565460906.7184] manager[0x557513007070]: monitoring kernel firmware directory '/lib/firmware'.
    Aug 10 20:15:06 linux-gmaw NetworkManager[1353]: <info>  [1565460906.7208] rfkill0: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.4/0000:02:00.0/ieee80211/phy0/rfkill0) (driver iwlwifi)
    kl

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Poste:
    Code:
    nmcli c
    Code:
    nmcli g

  7. #7

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Hallo Sauerland

    Code:
    nmcli c
    NAME                         UUID                                  TYPE      DEVICE 
    Kabelgebundene Verbindung 1  b2cc6a58-79aa-3b10-bd19-1cd833d4f456  ethernet  eth0   
    AldiTalk/MedionMobile        83a7268a-6c9b-476d-aaf5-88d30e6c881c  gsm       --     
    hier                         d4f02586-d2a8-4b9a-9d0f-cd0afbe1aba8  wifi      --
    Code:
    nmcli g
    STATE      CONNECTIVITY  WIFI-HW    WIFI       WWAN-HW    WWAN      
    verbunden  vollständig   aktiviert  aktiviert  aktiviert  aktiviert
    kl

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Da gibt es anscheinend kein Wlan-Device.

  9. #9

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    Hallo Sauerland
    Doch, den WLAN Device gibt es schon, denn das Notebook hat sich in der Anfangsphase über Wlan mit dem Router verbunden. Und auch das KDE Infozentrum sagt unter PCI
    2:00.0 Intel Corporation Wireless 8265 / 8275

    Der Router ist so eingestellt, daß er sich mit dem Namen "hier" meldet, damit nicht jeder sehen kann, welches Gerät es ist.

    Durch die Ergebnisse Deiner Kommandos bin ich misstrauisch geworden und habe das Notebook direkt neben den Router gestellt. Da hat sich dann die über WLAN aufgerufene Seite langsam aufgebaut und Firefox hat sich nicht mehr über eine unterbrochene Datenverbindung beschwert - aber eben sehr langsam.

    Vermutlich liegt kein Software Problem vor, sondern die Hardware hat eine Macke. Gibt es eine Möglichkeit, den WLAN Device in Opensuse nach seinen Betriebsdaten (Spannung, Signalstärke usw) zu fragen?

    kl

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,952

    Default AW: WLAN mit Router verbunden aber kein Internet Zugang

    1. Router neu starten.
    2. Alle Konfigurationen im Netzwerkmanager löschen und neu hinzufügen.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •