Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Epson iscan scanner software doens't compile anymore

  1. #11

    Default Re: Epson iscan scanner software doens't compile anymore

    Okay then, thanks. Found the download page with the 15.1 packages too.

    I am assuming that this package works fine in "Leap 15.1" but in "Tumbleweed" it gives me the following error:

    Code:
     sh install.sh 
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Paketabhängigkeiten werden aufgelöst...
    4 Probleme:
    Problem: libboost_filesystem.so.1.66.0()(64bit) benötigt von imagescan-3.57.0-1epson4opensuse15.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: libboost_filesystem.so.1.66.0()(64bit) benötigt von imagescan-3.57.0-1epson4opensuse15.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: libboost_filesystem.so.1.66.0()(64bit) benötigt von imagescan-3.57.0-1epson4opensuse15.1.x86_64 wird nirgends zur Verfügung gestellt
    Problem: libboost_filesystem.so.1.66.0()(64bit) benötigt von imagescan-3.57.0-1epson4opensuse15.1.x86_64 wird nirgends zur Verfügung gestellt
    
    Problem: libboost_filesystem.so.1.66.0()(64bit) benötigt von imagescan-3.57.0-1epson4opensuse15.1.x86_64 wird nirgends zur Verfügung gestellt
     Lösung 1: imagescan-3.57.0-1epson4opensuse15.1.x86_64 nicht installieren
     Lösung 2: imagescan-3.57.0-1epson4opensuse15.1.x86_64 durch Ignorieren einiger Abhängigkeiten brechen
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a/d/?] (a): a
    Apparently there is a library missing or libboost has already gone beyond 1.66.0.

    Edit: In case it is hosted at boost.org - they are at 1.70.0

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,381

    Default AW: Epson iscan scanner software doens't compile anymore

    Code:
    zypper se -si boost

  3. #13

    Default Re: Epson iscan scanner software doens't compile anymore

    Code:
    zypper se -si boost
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                           | Typ   | Version    | Arch   | Repository             
    ---+--------------------------------+-------+------------+--------+------------------------
    i+ | boost-license1_62_0            | Paket | 1.62.0-2.1 | noarch | (Systempakete)         
    i+ | boost-license1_63_0            | Paket | 1.63.0-3.2 | noarch | (Systempakete)         
    i+ | boost-license1_67_0            | Paket | 1.67.0-2.3 | noarch | (Systempakete)         
    i  | boost-license1_69_0            | Paket | 1.69.0-1.6 | noarch | openSUSE:Tumbleweed    
    i  | boost-license1_69_0            | Paket | 1.69.0-1.6 | noarch | openSUSE-Tumbleweed-Oss
    i+ | libboost_date_time1_67_0       | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i  | libboost_date_time1_69_0       | Paket | 1.69.0-1.6 | x86_64 | openSUSE:Tumbleweed    
    i  | libboost_date_time1_69_0       | Paket | 1.69.0-1.6 | x86_64 | openSUSE-Tumbleweed-Oss
    i+ | libboost_filesystem1_67_0      | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i  | libboost_filesystem1_69_0      | Paket | 1.69.0-1.6 | x86_64 | openSUSE:Tumbleweed    
    i  | libboost_filesystem1_69_0      | Paket | 1.69.0-1.6 | x86_64 | openSUSE-Tumbleweed-Oss
    i+ | libboost_iostreams1_62_0       | Paket | 1.62.0-2.1 | x86_64 | (Systempakete)         
    i+ | libboost_iostreams1_63_0       | Paket | 1.63.0-3.2 | x86_64 | (Systempakete)         
    i+ | libboost_iostreams1_67_0       | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i  | libboost_iostreams1_69_0       | Paket | 1.69.0-1.6 | x86_64 | openSUSE:Tumbleweed    
    i  | libboost_iostreams1_69_0       | Paket | 1.69.0-1.6 | x86_64 | openSUSE-Tumbleweed-Oss
    i+ | libboost_locale1_67_0          | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i  | libboost_locale1_69_0          | Paket | 1.69.0-1.6 | x86_64 | openSUSE:Tumbleweed    
    i  | libboost_locale1_69_0          | Paket | 1.69.0-1.6 | x86_64 | openSUSE-Tumbleweed-Oss
    i+ | libboost_program_options1_67_0 | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i  | libboost_program_options1_69_0 | Paket | 1.69.0-1.6 | x86_64 | openSUSE:Tumbleweed    
    i  | libboost_program_options1_69_0 | Paket | 1.69.0-1.6 | x86_64 | openSUSE-Tumbleweed-Oss
    i+ | libboost_system1_62_0          | Paket | 1.62.0-2.1 | x86_64 | (Systempakete)         
    i+ | libboost_system1_63_0          | Paket | 1.63.0-3.2 | x86_64 | (Systempakete)         
    i+ | libboost_system1_67_0          | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i+ | libboost_thread1_62_0          | Paket | 1.62.0-2.1 | x86_64 | (Systempakete)         
    i+ | libboost_thread1_63_0          | Paket | 1.63.0-3.2 | x86_64 | (Systempakete)         
    i+ | libboost_thread1_67_0          | Paket | 1.67.0-2.3 | x86_64 | (Systempakete)         
    i  | libboost_thread1_69_0          | Paket | 1.69.0-1.6 | x86_64 | openSUSE:Tumbleweed    
    i  | libboost_thread1_69_0          | Paket | 1.69.0-1.6 | x86_64 | openSUSE-Tumbleweed-Oss

  4. #14
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    5,381

    Default AW: Epson iscan scanner software doens't compile anymore

    66 is missing.....

    you can install them from obs.
    Last edited by Sauerland; 09-Aug-2019 at 07:59.

  5. #15

    Default Re: AW: Epson iscan scanner software doens't compile anymore

    Quote Originally Posted by Sauerland View Post
    66 is missing.....
    I noticed that as well. I thought filing a build request for this version might be a better idea. (Link)

  6. #16
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,314
    Blog Entries
    1

    Default no compilation needed

    Added repo:

    Code:
    erlangen:~ # zypper lr -uEP
    #  | Alias               | Name                        | Enabled | GPG Check | Refresh | Priority | URI                                                                            
    ---+---------------------+-----------------------------+---------+-----------+---------+----------+--------------------------------------------------------------------------------
     2 | Packman             | Packman                     | Yes     | (r ) Yes  | Yes     |   90     | http://ftp.fau.de/packman/suse/openSUSE_Tumbleweed/                            
     5 | openSUSE-20191106-0 | openSUSE-20191106-0         | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/oss/                              
     8 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/tumbleweed/repo/non-oss/                          
    10 | repo-update         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | http://download.opensuse.org/update/tumbleweed/                                
     1 | Application_Geo     | Application_Geo             | Yes     | (r ) Yes  | Yes     |  100     | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_Tumbleweed/
     3 | jalbum              | jalbum                      | Yes     | (  ) No   | Yes     |  100     | http://jalbum.net/download/software/yumrepo/                                   
     4 | myrepo              | myrepo                      | Yes     | (  ) No   | Yes     |  100     | dir:/home/karl/Downloads/myrepo                                                
     6 | opensuse-guide.org  | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |  100     | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                            
    11 | tmp                 | tmp                         | Yes     | (r ) Yes  | Yes     |  100     | http://download.opensuse.org/distribution/leap/15.1/repo/oss/                  
    erlangen:~ #
    Installed:

    Code:
    erlangen:~ # zypper in libboost_filesystem1_66_0
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 3 NEW packages are going to be installed:
      boost-license1_66_0 libboost_filesystem1_66_0 libboost_system1_66_0
    
    3 new packages to install.
    Overall download size: 95.9 KiB. Already cached: 0 B. After the operation, additional 110.9 KiB will be used.
    Continue? [y/n/v/...? shows all options] (y): 
    Retrieving package boost-license1_66_0-1.66.0-lp151.4.5.noarch                                                                                                                                          (1/3),  20.5 KiB (  1.3 KiB unpacked)
    Retrieving: boost-license1_66_0-1.66.0-lp151.4.5.noarch.rpm ...........................................................................................................................................................................[done]
    Retrieving package libboost_system1_66_0-1.66.0-lp151.4.5.x86_64                                                                                                                                        (2/3),  25.1 KiB ( 18.3 KiB unpacked)
    Retrieving: libboost_system1_66_0-1.66.0-lp151.4.5.x86_64.rpm .........................................................................................................................................................................[done]
    Retrieving package libboost_filesystem1_66_0-1.66.0-lp151.4.5.x86_64                                                                                                                                    (3/3),  50.3 KiB ( 91.3 KiB unpacked)
    Retrieving: libboost_filesystem1_66_0-1.66.0-lp151.4.5.x86_64.rpm .....................................................................................................................................................................[done]
    
    Checking for file conflicts: ..........................................................................................................................................................................................................[done]
    (1/3) Installing: boost-license1_66_0-1.66.0-lp151.4.5.noarch .........................................................................................................................................................................[done]
    (2/3) Installing: libboost_system1_66_0-1.66.0-lp151.4.5.x86_64 .......................................................................................................................................................................[done]
    (3/3) Installing: libboost_filesystem1_66_0-1.66.0-lp151.4.5.x86_64 ...................................................................................................................................................................[done]
    erlangen:~ #
    Installed from script:

    Code:
    erlangen:/home/karl/Downloads/imagescan-bundle-opensuse-15.1-3.61.0.x64.rpm # ./install.sh 
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Paketabhängigkeiten werden aufgelöst...
    
    Die folgenden 5 NEUEN Pakete werden installiert:
      imagescan imagescan-plugin-gt-s650 imagescan-plugin-networkscan imagescan-plugin-ocr-engine libboost_program_options1_66_0
    
    5 neue Pakete zu installieren.
    Gesamtgröße des Downloads: 10,0 MiB. Bereits im Cache gespeichert: 0 B. Nach der Operation werden zusätzlich 22,3 MiB belegt.
    Fortfahren? [j/n/v/...? zeigt alle Optionen] (j): j
    Paket libboost_program_options1_66_0-1.66.0-lp151.4.5.x86_64 abrufen                                                                                                                                    (1/5), 139,3 KiB (500,6 KiB entpackt)
    Abrufen: libboost_program_options1_66_0-1.66.0-lp151.4.5.x86_64.rpm .................................................................................................................................................................[fertig]
    Paket imagescan-3.61.0-1epson4opensuse15.1.x86_64 abrufen                                                                                                                                               (2/5),   1,5 MiB (  8,6 MiB entpackt)
    imagescan-3.61.0-1epson4opensuse15.1.x86_64.rpm:
        Paket ist nicht signiert!
    imagescan-3.61.0-1epson4opensuse15.1.x86_64 (Einfacher Cache für RPM-Dateien): Fehler beim Überprüfen der Signatur [6-Datei ist unsigniert]
    Das Paket trotz des Fehlers akzeptieren. (--no-gpg-checks)
    
    Paket imagescan-plugin-gt-s650-1.0.2-1epson4opensuse15.1.x86_64 abrufen                                                                                                                                 (3/5),  99,0 KiB (269,0 KiB entpackt)
    imagescan-plugin-gt-s650-1.0.2-1epson4opensuse15.1.x86_64.rpm:
        Paket ist nicht signiert!
    imagescan-plugin-gt-s650-1.0.2-1epson4opensuse15.1.x86_64 (Einfacher Cache für RPM-Dateien): Fehler beim Überprüfen der Signatur [6-Datei ist unsigniert]
    Das Paket trotz des Fehlers akzeptieren. (--no-gpg-checks)
    
    Paket imagescan-plugin-ocr-engine-1.0.2-1epson4opensuse15.1.x86_64 abrufen                                                                                                                              (4/5),   8,2 MiB ( 12,9 MiB entpackt)
    imagescan-plugin-ocr-engine-1.0.2-1epson4opensuse15.1.x86_64.rpm:
        Paket ist nicht signiert!
    imagescan-plugin-ocr-engine-1.0.2-1epson4opensuse15.1.x86_64 (Einfacher Cache für RPM-Dateien): Fehler beim Überprüfen der Signatur [6-Datei ist unsigniert]
    Das Paket trotz des Fehlers akzeptieren. (--no-gpg-checks)
    
    Paket imagescan-plugin-networkscan-1.1.3-1epson4opensuse15.1.x86_64 abrufen                                                                                                                             (5/5),  48,5 KiB (125,6 KiB entpackt)
    imagescan-plugin-networkscan-1.1.3-1epson4opensuse15.1.x86_64.rpm:
        Paket ist nicht signiert!
    imagescan-plugin-networkscan-1.1.3-1epson4opensuse15.1.x86_64 (Einfacher Cache für RPM-Dateien): Fehler beim Überprüfen der Signatur [6-Datei ist unsigniert]
    Das Paket trotz des Fehlers akzeptieren. (--no-gpg-checks)
    
    
    Überprüfung auf Dateikonflikte läuft: ...............................................................................................................................................................................................[fertig]
    (1/5) Installieren: libboost_program_options1_66_0-1.66.0-lp151.4.5.x86_64 ..........................................................................................................................................................[fertig]
    (2/5) Installieren: imagescan-3.61.0-1epson4opensuse15.1.x86_64 .....................................................................................................................................................................[fertig]
    (3/5) Installieren: imagescan-plugin-gt-s650-1.0.2-1epson4opensuse15.1.x86_64 .......................................................................................................................................................[fertig]
    (4/5) Installieren: imagescan-plugin-ocr-engine-1.0.2-1epson4opensuse15.1.x86_64 ....................................................................................................................................................[fertig]
    (5/5) Installieren: imagescan-plugin-networkscan-1.1.3-1epson4opensuse15.1.x86_64 ...................................................................................................................................................[fertig]
    erlangen:/home/karl/Downloads/imagescan-bundle-opensuse-15.1-3.61.0.x64.rpm # exit
    karl@erlangen:~/Downloads/imagescan-bundle-opensuse-15.1-3.57.0.x64.rpm> 
    karl@erlangen:~/Downloads/imagescan-bundle-opensuse-15.1-3.57.0.x64.rpm>
    Last edited by karlmistelberger; 09-Nov-2019 at 01:26. Reason: fixed headline
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •