Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: reached target shutdown for 2minutes when shutdown

Hybrid View

  1. #1

    Default reached target shutdown for 2minutes when shutdown

    Hi, how can I avoid, when I restart my computer, to have the reached target shutdown message for 2 minutes?

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: reached target shutdown for 2minutes when shutdown

    Hi, if that is due to https://bugzilla.opensuse.org/show_bug.cgi?id=1129476 and if you are not using logical volume management, you may disable lvm-related services or uninstall those packages (see comments 4 and 5 on the bug report).
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,608
    Blog Entries
    3

    Default Re: reached target shutdown for 2minutes when shutdown

    Just a note:

    I am using LVM. And I am not having this problem.

    Maybe something LVM related is going into a deep sleep if not actually used. Or maybe the shutdown sequence is in the wrong order if LVM is not actually used.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,686

    Default Re: reached target shutdown for 2minutes when shutdown

    A stop job unable to stop must be identified, then corrected. Typically a stop job that fails is due to a start job that never started.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  5. #5

    Default Re: reached target shutdown for 2minutes when shutdown

    Quote Originally Posted by OrsoBruno View Post
    Hi, if that is due to https://bugzilla.opensuse.org/show_bug.cgi?id=1129476 and if you are not using logical volume management, you may disable lvm-related services or uninstall those packages (see comments 4 and 5 on the bug report).
    manythanks orsobruno, I don't use lvm, the packages mentioned in the bugzilla:
    liblvm2app2_2
    liblvm2cmd2_02
    lvm2
    are not installed in my system
    the only similar name is
    libLLVM5 - Libraries for LLVM
    in the bugzilla the system hangs at:
    Code:
    [ 77.019608] systemd-journald[473]: systemd-journald stopped as pid 473
    [ 167.020886] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [ 167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad).
    my system hang at
    Code:
    reached target shutdown
    ...it seems not related my issue to bugzilla bug :-)
    ciao :-)

  6. #6
    Join Date
    Jul 2008
    Location
    Sweden
    Posts
    174

    Default Re: reached target shutdown for 2minutes when shutdown

    My took long time too. Even to boot. Some thread here on forum said to change
    Code:
    WAIT_FOR_INTERFACES="30"
    in "/etc/sysconfig/network/config" to a low value. That was for boot, but my system shut down faster also.
    ASUS G46VW running openSUSE LEAP 42.1, Windows 8
    Samsung NP300V3A running openSUSE LEAP 42.1 Windows 7
    Some EEEPC running openSUSE LEAP 42.1, "Server" running sshfs, (mini)DLNA, NFS
    Raspberry Pi, Weezy, openSUSE 13.1 (two different SD-cards)

  7. #7

    Default Re: reached target shutdown for 2minutes when shutdown

    here my system hangs:
    http://paste.opensuse.org/31364367
    I don't know how to report what is written there in text

  8. #8
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: reached target shutdown for 2minutes when shutdown


  9. #9

    Default Re: reached target shutdown for 2minutes when shutdown

    maaanythanks ravas, I tried to follow the instructions of your link and the result is this:
    https://susepaste.org/72721206

    if the first numbers are time and starting from the last
    Code:
    Reached target Shutdown
    I can see this that could maybe is the culprit:
    from here
    Code:
    [   36.115687] systemd[1]: shutdown.target: Job shutdown.target/start finished, result=done
    [   36.115689] systemd[1]: Reached target Shutdown.
    [   36.115708] systemd[1]: final.target changed dead -> active
    [   36.115709] systemd[1]: final.target: Job final.target/start finished, result=done
    [   36.115711] systemd[1]: Reached target Final Step.
    [   36.115854] systemd[1]: systemd-reboot.service: Passing 0 fds to service
    [   36.115859] systemd[1]: systemd-reboot.service: About to execute: /usr/bin/systemctl --force reboot
    [   36.115956] systemd[1]: systemd-reboot.service: Forked /usr/bin/systemctl as 2788
    [   36.116026] systemd[1]: systemd-reboot.service: Changed dead -> start
    [   36.116030] systemd[1]: Starting Reboot...
    to here wher 36.11xxxxx became 126.14xxx
    Code:
    [   36.150316] systemd-journald[435]: Received SIGTERM from PID 1 (systemd-shutdow).
    [   36.150323] systemd-journald[435]: systemd-journald stopped as pid 435
    [  126.149022] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [  126.154494] systemd-shutdown[1]: Sending SIGKILL to PID 437 (lvmetad).
    [  126.155632] systemd-shutdown[1]: Unmounting file systems.
    [  126.155809] systemd-shutdown[1]: Remounting '/' read-only with options 'data=ordered'.
    hoping that this could be useful... ciao :-)

  10. #10
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: reached target shutdown for 2minutes when shutdown

    https://forums.opensuse.org/showthre...-of-90-seconds

    Among many lines, the shutdown log showed these:

    [ 77.019608] systemd-journald[473]: systemd-journald stopped as pid 473
    [ 167.020886] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [ 167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad).

    As I do not need the LVM, I deleted the following packages:

    liblvm2app2_2
    liblvm2cmd2_02
    lvm2

    The service has vanished and shutdown is no longer delayed now.

    ~ Ed Vaessen
    https://bugzilla.opensuse.org/show_bug.cgi?id=1129476

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •