Page 4 of 4 FirstFirst ... 234
Results 31 to 34 of 34

Thread: reached target shutdown for 2minutes when shutdown

  1. #31
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: reached target shutdown for 2minutes when shutdown

    https://forums.opensuse.org/showthre...-of-90-seconds

    Among many lines, the shutdown log showed these:

    [ 77.019608] systemd-journald[473]: systemd-journald stopped as pid 473
    [ 167.020886] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [ 167.027376] systemd-shutdown[1]: Sending SIGKILL to PID 484 (lvmetad).

    As I do not need the LVM, I deleted the following packages:

    liblvm2app2_2
    liblvm2cmd2_02
    lvm2

    The service has vanished and shutdown is no longer delayed now.

    ~ Ed Vaessen
    https://bugzilla.opensuse.org/show_bug.cgi?id=1129476

  2. #32
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: reached target shutdown for 2minutes when shutdown

    Or see the post after that...

    Apparently setting the lvm2-monitor service to start "manually" and possibly stopping the lvm2-lvmtad and lvm2-lvmpolld services seems to be enough to solve the problem.

    ~ Bruno Pesavento
    https://bugzilla.opensuse.org/show_bug.cgi?id=1129476

  3. #33

    Default Re: reached target shutdown for 2minutes when shutdown

    Quote Originally Posted by ravas View Post
    manythanks ravas, the problem on the laptop seems solved, the one on the desktop not.
    I also answered on the thread you indicated me that resolved the problem on the laptop:
    https://forums.opensuse.org/showthre...98#post2911998

    Removing the three lvm2 packages the problem seems solved on the laptop (a tuxedo infinity pro processor= Intel Core i7-8565U, RAM=32Gb, 2TB SSD disk) but not solved on the desktop computer, if it can be useful I attach the two shutdown log (obtained following the instructions here https://freedesktop.org/wiki/Softwar...emd/Debugging/ ) of the laptop where the problem seems solved:

    the log before removing the three lvm2 packages and where the shutdown was slow
    https://susepaste.org/72721206

    the log after removed the three lvm2 packages and where the shutdown was fast
    https://susepaste.org/68442920

    and also I attach the log of the desktop where I removed the three lvm2 packages but the shutdown remain slow
    https://susepaste.org/93130715

    the interesting rows seems these
    Code:
     322.929047] systemd-journald[502]: systemd-journald stopped as pid 502
    [  322.936530] systemd-coredump[2574]: Failed to connect to coredump service: Connection refused
    [  412.928467] systemd-shutdown[1]: Sending SIGKILL to remaining processes...
    [  412.933397] systemd-shutdown[1]: Sending SIGKILL to PID 1716 (rsync).
    [  412.933931] systemd-shutdown[1]: Hardware watchdog 'iTCO_wdt', version 0
    [  412.934401] systemd-shutdown[1]: Unmounting file systems.
    [  412.934505] systemd-shutdown[1]: Remounting '/home' read-only with options 'data=ordered'.

  4. #34
    Join Date
    Apr 2016
    Location
    North America
    Posts
    537

    Default Re: reached target shutdown for 2minutes when shutdown

    I had too many tabs open, and posted in the other thread.
    Check out https://bbs.archlinux.org/viewtopic.php?id=163768

Page 4 of 4 FirstFirst ... 234

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •