Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Audacity fails to load since upgrading to Leap 15.1

  1. #1

    Default Audacity fails to load since upgrading to Leap 15.1

    When I try to run Audacity from the command-line, I get the message:
    audacity: relocation error: audacity: symbol _ZThn696_N14wxTextCtrlBase8overflowEi, version WXU_3.0 not defined in file libwx_gtk2u_core-suse-nostl.so.3 with link time reference
    I have tried removing Audacity and the packages it depends on:
    libwx_gtk2u_adv-suse-nostl3 libwx_gtk2u_html-suse-nostl3 libwx_gtk2u_qa-suse-nostl3
    and reinstalling audacity but the problem remains.

    I have just upgraded from Leap 14.2 to Leap 15.1. The hardware is x86_64

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,606

    Question Re: Audacity fails to load since upgrading to Leap 15.1

    Are you installing Audacity from the main Leap 15.1 repository? – <http://download.opensuse.org/distrib...15.1/repo/oss/>.

    Please check your repositories list – ‘zypper repos --uri’.

    Please check all the libraries required by Audacity and, the repositories which are loading those libraries: ‘zypper info --requires audacity’.

    With the user “root”, please check all the package dependencies: ‘zypper verify’.

    With the user “root” and rpm, please verify each file against the package meta-data: ‘rpm --verify --all’.
    • I suggest that, you redirect the «large amount of» output to a file and then, inspect the contents of that file …
    • You may have to rebuild the rpm database before you begin: ‘rpm --rebuilddb’.


    After you've done all that, you should also consider checking the system's configuration (with the user “root”): ‘rpmconfigcheck’.

  3. #3

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    I have done a fresh install from DVD using only the repositories that it accesses:
    # zypper repos --uri
    Repository priorities are without effect. All enabled repositories share the same priority.

    # | Alias | Name | Enabled | GPG Check | Refresh | URI
    ---+---------------------------+------------------------------------+---------+-----------+---------+-------------------------------------------------------------------------
    1 | openSUSE-Leap-15.1-1 | openSUSE-Leap-15.1-1 | Yes | (r ) Yes | No | cd:/?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8G2_W091_054714
    2 | repo-debug | Debug Repository | No | ---- | ---- | http://download.opensuse.org/debug/d...15.1/repo/oss/
    3 | repo-debug-non-oss | Debug Repository (Non-OSS) | No | ---- | ---- | http://download.opensuse.org/debug/d.../repo/non-oss/
    4 | repo-debug-update | Update Repository (Debug) | No | ---- | ---- | http://download.opensuse.org/debug/u...leap/15.1/oss/
    5 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No | ---- | ---- | http://download.opensuse.org/debug/u.../15.1/non-oss/
    6 | repo-non-oss | Non-OSS Repository | Yes | (r ) Yes | Yes | http://download.opensuse.org/distrib.../repo/non-oss/
    7 | repo-oss | Main Repository | Yes | (r ) Yes | Yes | http://download.opensuse.org/distrib...15.1/repo/oss/
    8 | repo-source | Source Repository | No | ---- | ---- | http://download.opensuse.org/source/...15.1/repo/oss/
    9 | repo-source-non-oss | Source Repository (Non-OSS) | No | ---- | ---- | http://download.opensuse.org/source/.../repo/non-oss/
    10 | repo-update | Main Update Repository | Yes | (r ) Yes | Yes | http://download.opensuse.org/update/leap/15.1/oss/
    11 | repo-update-non-oss | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes | http://download.opensuse.org/update/leap/15.1/non-oss/
    Checking the libraries that audacity requires:
    # zypper info --requires audacity
    The libraries that audacity requires are:
    Loading repository data...
    Reading installed packages...


    Information for package audacity:
    ---------------------------------
    Repository : @System
    Name : audacity
    Version : 2.3.1-lp151.138.2
    Arch : x86_64
    Vendor : obs://build.opensuse.org/multimedia
    Installed Size : 15.6 MiB
    Installed : Yes
    Status : up-to-date
    Source package : audacity-2.3.1-lp151.138.2.src
    Summary : A Multi Track Digital Audio Editor
    Description :
    Audacity is a program that manipulates digital audio wave forms.
    In addition to multitrack recording capabilities with effects, it
    imports and exports many sound file formats, including WAV, AIFF,
    AU, IRCAM, MP, and Ogg Vorbis. Wave data larger than the available
    physical memory size can be edited.
    Requires : [83]
    libc.so.6()(64bit)
    libc.so.6(GLIBC_2.2.5)(64bit)
    libc.so.6(GLIBC_2.4)(64bit)
    libc.so.6(GLIBC_2.14)(64bit)
    libc.so.6(GLIBC_2.3.4)(64bit)
    libpthread.so.0()(64bit)
    libc.so.6(GLIBC_2.3)(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(GLIBCXX_3.4)(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libpthread.so.0(GLIBC_2.2.5)(64bit)
    libm.so.6()(64bit)
    libm.so.6(GLIBC_2.2.5)(64bit)
    libc.so.6(GLIBC_2.7)(64bit)
    libglib-2.0.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libc.so.6(GLIBC_2.15)(64bit)
    libdl.so.2()(64bit)
    libdl.so.2(GLIBC_2.2.5)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.21)(64bit)
    libc.so.6(GLIBC_2.11)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)
    libpthread.so.0(GLIBC_2.3.2)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.20)(64bit)
    libstdc++.so.6(CXXABI_1.3.8)(64bit)
    librt.so.1()(64bit)
    librt.so.1(GLIBC_2.2.5)(64bit)
    libgtk-x11-2.0.so.0()(64bit)
    libgdk-x11-2.0.so.0()(64bit)
    libstdc++.so.6(GLIBCXX_3.4.18)(64bit)
    libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
    libpthread.so.0(GLIBC_2.3.3)(64bit)
    libasound.so.2()(64bit)
    libasound.so.2(ALSA_0.9)(64bit)
    libm.so.6(GLIBC_2.15)(64bit)
    libexpat.so.1()(64bit)
    libasound.so.2(ALSA_0.9.0rc4)(64bit)
    libogg.so.0()(64bit)
    libstdc++.so.6(CXXABI_1.3.5)(64bit)
    libvorbis.so.0()(64bit)
    libFLAC.so.8()(64bit)
    libstdc++.so.6(GLIBCXX_3.4.19)(64bit)
    libvorbisenc.so.2()(64bit)
    libjack.so.0()(64bit)
    libsndfile.so.1()(64bit)
    libsndfile.so.1(libsndfile.so.1.0)(64bit)
    libvorbisfile.so.3()(64bit)
    libstdc++.so.6(CXXABI_1.3.3)(64bit)
    libmad.so.0()(64bit)
    libtwolame.so.0()(64bit)
    libwx_baseu-suse-nostl.so.3()(64bit)
    libwx_baseu-suse-nostl.so.3(WXU_3.0)(64bit)
    libsoxr.so.0()(64bit)
    libwx_gtk2u_core-suse-nostl.so.3()(64bit)
    libwx_gtk2u_core-suse-nostl.so.3(WXU_3.0)(64bit)
    ffmpeg
    libFLAC++.so.6()(64bit)
    libid3tag.so.0()(64bit)
    liblilv-0.so.0()(64bit)
    libSoundTouch.so.1()(64bit)
    libsuil-0.so.0()(64bit)
    libvamp-hostsdk.so.3()(64bit)
    libwx_baseu_net-suse-nostl.so.3()(64bit)
    libwx_baseu_net-suse-nostl.so.3(WXU_3.0)(64bit)
    libwx_gtk2u_adv-suse-nostl.so.3()(64bit)
    libwx_gtk2u_adv-suse-nostl.so.3(WXU_3.0)(64bit)
    libwx_gtk2u_html-suse-nostl.so.3()(64bit)
    libwx_gtk2u_html-suse-nostl.so.3(WXU_3.0)(64bit)
    libwx_gtk2u_qa-suse-nostl.so.3()(64bit)
    libwx_gtk2u_qa-suse-nostl.so.3(WXU_3.0)(64bit)
    rpmlib(CompressedFileNames) <= 3.0.4-1
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(FileDigests) <= 4.6.0-1
    rpmlib(PayloadIsXz) <= 5.2-1
    libFLAC++6 >= 1.3.1
    libFLAC8 >= 1.3.1
    /bin/sh
    /bin/sh
    Package dependencies are all file:
    # zypper verify
    Loading repository data...
    Reading installed packages...

    Dependencies of all installed packages are satisfied.
    Checking all meta-data gives:
    # rpm --verify --all
    .M....G.. g /var/log/lastlog
    S.5....T. c /etc/unixODBC/odbcinst.ini
    .M....... g /etc/iscsi/initiatorname.iscsi
    .M....... c /etc/iscsi/iscsid.conf
    ......... /usr/bin/erb (replaced)
    ......... /usr/bin/gem (replaced)
    ......... /usr/bin/irb (replaced)
    ......... /usr/bin/ruby (replaced)
    ......... d /usr/share/man/man1/erb.1.gz (replaced)
    ......... d /usr/share/man/man1/irb.1.gz (replaced)
    ......... d /usr/share/man/man1/ri.1.gz (replaced)
    ......... d /usr/share/man/man1/ruby.1.gz (replaced)
    ....L.... d /usr/share/man/man1/ftp.1.gz
    S.5....T. c /etc/sysconfig/SuSEfirewall2
    .M....... c /etc/X11/xorg.conf.d/00-keyboard.conf
    .M....... c /etc/locale.conf
    .M....... c /etc/machine-id
    .M....... c /etc/vconsole.conf
    .M....... g /var/lib/systemd/random-seed
    .M....... g /etc/xml/catalog-d.xml
    S.5....T. c /etc/fonts/conf.d/10-rendering-options.conf
    S.5....T. c /etc/fonts/conf.d/58-family-prefer-local.conf
    .M....... g /var/lib/ca-certificates/ca-bundle.pem
    .M....... g /var/lib/ca-certificates/java-cacerts
    .......T. /usr/lib64/gconv/gconv-modules.cache
    .M....... g /usr/share/fonts/75dpi/encodings.dir
    .M....... g /usr/share/fonts/75dpi/fonts.scale
    .M....... g /usr/share/fonts/misc/encodings.dir
    .M....... g /usr/share/fonts/misc/fonts.scale
    S.5....T. c /etc/plymouth/plymouthd.conf
    .M...U... /var/cache/cups
    ....L.... /etc/ImageMagick-7
    .M....... g /boot/grub2/grub.cfg
    S.5....T. c /etc/default/grub
    .M....... g /usr/share/fonts/100dpi/encodings.dir
    .M....... g /usr/share/fonts/100dpi/fonts.scale
    .M....... g /usr/share/fonts/Type1/encodings.dir
    .M....... g /usr/share/fonts/cyrillic/encodings.dir
    .M....... g /usr/share/fonts/cyrillic/fonts.scale
    .M....... g /usr/share/fonts/truetype/encodings.dir
    ....L.... /etc/ImageMagick
    missing /usr/bin/aviocat (replaced)
    missing /usr/bin/cws2fws (replaced)
    missing /usr/bin/ffescape (replaced)
    missing /usr/bin/ffeval (replaced)
    missing /usr/bin/ffhash (replaced)
    missing /usr/bin/ffmpeg (replaced)
    missing /usr/bin/ffplay (replaced)
    missing /usr/bin/ffprobe (replaced)
    missing /usr/bin/ffserver (replaced)
    missing /usr/bin/fourcc2pixfmt (replaced)
    missing /usr/bin/graph2dot (replaced)
    missing /usr/bin/ismindex (replaced)
    missing /usr/bin/pktdumper (replaced)
    missing /usr/bin/probetest (replaced)
    missing /usr/bin/qt-faststart (replaced)
    missing /usr/bin/seek_print (replaced)
    missing /usr/bin/trasher (replaced)
    missing /usr/share/ffmpeg/ffprobe.xsd (replaced)
    .......T. /usr/share/ffmpeg/libvpx-1080p.ffpreset
    .......T. /usr/share/ffmpeg/libvpx-1080p50_60.ffpreset
    .......T. /usr/share/ffmpeg/libvpx-360p.ffpreset
    .......T. /usr/share/ffmpeg/libvpx-720p.ffpreset
    .......T. /usr/share/ffmpeg/libvpx-720p50_60.ffpreset
    missing d /usr/share/man/man1/ffmpeg-all.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-bitstream-filters.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-codecs.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-devices.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-filters.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-formats.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-protocols.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-resampler.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-scaler.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg-utils.1.gz (replaced)
    missing d /usr/share/man/man1/ffmpeg.1.gz (replaced)
    missing d /usr/share/man/man1/ffplay-all.1.gz (replaced)
    missing d /usr/share/man/man1/ffplay.1.gz (replaced)
    missing d /usr/share/man/man1/ffprobe-all.1.gz (replaced)
    missing d /usr/share/man/man1/ffprobe.1.gz (replaced)
    missing d /usr/share/man/man1/ffserver-all.1.gz (replaced)
    missing d /usr/share/man/man1/ffserver.1.gz (replaced)
    S.5....T. c /etc/postfix/main.cf
    S.5....T. c /etc/postfix/master.cf
    .M....... c /var/log/NetworkManager
    .......T. c /etc/YaST2/control.xml
    missing /usr/bin/apt
    .M....... g /run/mcelog
    ....L.... /usr/share/java/xml-commons-apis.jar
    S.5....T. c /etc/sane.d/dll.conf
    S.5....T. c /etc/sane.d/epson2.conf
    S.5....T. c /etc/sane.d/net.conf
    .M....... c /var/log/audit/audit.log
    .M....... g /etc/mpv/scripts
    S.5....T. c /etc/ntp.conf
    ....L.... c /etc/pam.d/common-account
    ....L.... c /etc/pam.d/common-auth
    ....L.... c /etc/pam.d/common-password
    ....L.... c /etc/pam.d/common-session
    S.5....T. c /etc/pulse/client.conf
    S.5....T. c /etc/sddm.conf
    .....UG.. g /run/sddm
    .M....... g /var/log/alternatives.log
    .M....... g /run/avahi-daemon
    .M....... g /etc/udev/hwdb.bin
    S.5....T. c /etc/cups/cupsd.conf
    .......T. c /etc/login.defs
    .M....... g /etc/mpv/scripts
    S.5....T. c /etc/sane.d/epkowa.conf
    .M....... g /run/cryptsetup
    SM5....T. c /etc/fonts/conf.d/30-metric-aliases.conf
    missing /usr/bin/nosetests
    missing d /usr/share/man/man1/nosetests.1.gz
    Rebuilding the RPM-db gives unchanged meta-data, and then checking the RPM configuration files gives:
    # rpm --rebuilddb
    # rpmconfigcheck
    Searching for unresolved configuration files
    Please check the following files (see /var/adm/rpmconfigcheck):
    /etc/cups/cupsd.conf.rpmnew
    /etc/default/grub.rpmnew
    /etc/fonts/conf.d/10-rendering-options.conf.rpmsave
    /etc/fonts/conf.d/58-family-prefer-local.conf.rpmsave
    /etc/freshwrapper.conf.rpmsave
    /etc/hostname.rpmnew
    /etc/hosts.rpmnew
    /etc/nsswitch.conf.rpmnew
    /etc/pam.d/common-account.rpmnew
    /etc/pam.d/common-auth.rpmnew
    /etc/pam.d/common-password.rpmnew
    /etc/pam.d/common-session.rpmnew
    /etc/plymouth/plymouthd.conf.rpmnew
    /etc/postfix/main.cf.rpmnew
    /etc/postfix/master.cf.rpmnew
    /etc/pulse/client.conf.rpmnew
    /etc/sane.d/dll.conf.rpmnew
    /etc/sane.d/epson2.conf.rpmnew
    /etc/sane.d/net.conf.rpmnew
    /etc/sddm.conf.rpmnew
    /etc/sysconfig/SuSEfirewall2.rpmnew
    /usr/share/info/dir.rpmnew

  4. #4

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Remove audacity and its traces if you can. Reboot.

    Try installing from different sources: Packman, older audacity versions, Tumbleweed, Audacity's web site. If not successful, uninstall, remove traces and reboot before a new attempt. Versions 2.2.* may be incompatible with upgraded opensuse 15.1.

  5. #5

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Thanks for that advice. I did not have success with installing the audacity release from Leap 14.2 because there were too many old dependencies that I found hard to cope with.

    I went to the Audacity site and they don't have a binary for OpenSuse, only source. I tried to compile, but after installing numerous "-devel" packages, I had to give up with a compilation error when I could not figure out what else I had to install.

    I have found another audio editor, ocenaudio, which is provided as an RPM for OpenSuse by the developers and which has a lot of the audacity functionality, so I will make do with it until audacity solves the UI problems with the WX library.

    Many thanks for the help.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,606

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    @tgf:

    Strange, Audacity runs on this Leap 15.1 system without too many errors (I haven't bothered to setup Jack properly … ) and, it edits MP3:
    Code:
     > audacity 
    ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
    ALSA lib pcm.c:2552:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
    ALSA lib pcm.c:2552:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
    ALSA lib pcm.c:2552:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
    ALSA lib pcm_route.c:867:(find_matching_chmap) Found no matching channel map
    ALSA lib pcm_dmix.c:1099:(snd_pcm_dmix_open) unable to open slave
    Cannot connect to server socket err = Datei oder Verzeichnis nicht gefunden
    Cannot connect to server request channel
    jack server is not running or cannot be started
    JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
    JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
    Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4611
    Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4611
    Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4611
    Expression 'stream->playback.pcm' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 4611
     > 
     > LANG=C zypper info audacity
    Loading repository data...
    Reading installed packages...
    
    
    Information for package audacity:
    ---------------------------------
    Repository     : Haupt-Repository                  
    Name           : audacity                          
    Version        : 2.2.2-lp151.2.4                   
    Arch           : x86_64                            
    Vendor         : openSUSE                          
    Installed Size : 13.9 MiB                          
    Installed      : Yes                               
    Status         : up-to-date                        
    Source package : audacity-2.2.2-lp151.2.4.src      
    Summary        : A Multi Track Digital Audio Editor
    Description    :                                   
        Audacity is a program that manipulates digital audio wave forms.
        In addition to multitrack recording capabilities with effects, it
        imports and exports many sound file formats, including WAV, AIFF,
        AU, IRCAM, MP, and Ogg Vorbis. Wave data larger than the available
        physical memory size can be edited.
    
     >

  7. #7

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Well when I retry, I still get failure. These are all the steps:
    # zypper in audacity
    Retrieving repository 'Main Update Repository' metadata ..................[done]
    Building repository 'Main Update Repository' cache .......................[done]
    Retrieving repository 'google-chrome' metadata ...........................[done]
    Building repository 'google-chrome' cache ................................[done]
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    The following 6 NEW packages are going to be installed:
    audacity audacity-lang libwx_gtk2u_adv-suse-nostl3
    libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_html-suse-nostl3
    libwx_gtk2u_qa-suse-nostl3

    The following recommended package was automatically selected:
    audacity-lang

    6 new packages to install.
    Overall download size: 7.1 MiB. Already cached: 0 B. After the operation,
    additional 30.2 MiB will be used.
    Continue? [y/n/v/...? shows all options] (y):
    Retrieving package libwx_gtk2u_core-suse-nostl3-3.0.3-lp151.6.13.x86_64
    (1/6), 1.4 MiB ( 5.7 MiB unpacked)
    Retrieving: libwx_gtk2u_core-suse-nostl3-3.0.3-lp151.6.13.x8[done (697.1 KiB/s)]
    Retrieving package libwx_gtk2u_qa-suse-nostl3-3.0.3-lp151.6.13.x86_64
    (2/6), 66.6 KiB (183.7 KiB unpacked)
    Retrieving: libwx_gtk2u_qa-suse-nostl3-3.0.3-lp151.6.13.x86_6[done (14.9 KiB/s)]
    Retrieving package libwx_gtk2u_html-suse-nostl3-3.0.3-lp151.6.13.x86_64
    (3/6), 249.0 KiB (847.6 KiB unpacked)
    Retrieving: libwx_gtk2u_html-suse-nostl3-3.0.3-lp151.6.13.x86_64.rpm .....[done]
    Retrieving package libwx_gtk2u_adv-suse-nostl3-3.0.3-lp151.6.13.x86_64
    (4/6), 434.5 KiB ( 1.7 MiB unpacked)
    Retrieving: libwx_gtk2u_adv-suse-nostl3-3.0.3-lp151.6.13.x86_64.rpm ......[done]
    Retrieving package audacity-2.2.2-lp151.2.4.x86_64
    (5/6), 3.7 MiB ( 13.9 MiB unpacked)
    Retrieving: audacity-2.2.2-lp151.2.4.x86_64.rpm ..............[done (1.3 MiB/s)]
    Retrieving package audacity-lang-2.2.2-lp151.2.4.noarch
    (6/6), 1.3 MiB ( 8.0 MiB unpacked)
    Retrieving: audacity-lang-2.2.2-lp151.2.4.noarch.rpm .........[done (1.0 MiB/s)]
    Checking for file conflicts: .............................................[done]
    (1/6) Installing: libwx_gtk2u_core-suse-nostl3-3.0.3-lp151.6.13.x86_64 ...[done]
    (2/6) Installing: libwx_gtk2u_qa-suse-nostl3-3.0.3-lp151.6.13.x86_64 .....[done]
    (3/6) Installing: libwx_gtk2u_html-suse-nostl3-3.0.3-lp151.6.13.x86_64 ...[done]
    (4/6) Installing: libwx_gtk2u_adv-suse-nostl3-3.0.3-lp151.6.13.x86_64 ....[done]
    (5/6) Installing: audacity-2.2.2-lp151.2.4.x86_64 ........................[done]
    Additional rpm output:
    Unknown media type in type 'all/all'
    Unknown media type in type 'all/allfiles'


    (6/6) Installing: audacity-lang-2.2.2-lp151.2.4.noarch ...................[done]
    # zypper info audacity
    Loading repository data...
    Reading installed packages...


    Information for package audacity:
    ---------------------------------
    Repository : Main Repository
    Name : audacity
    Version : 2.2.2-lp151.2.4
    Arch : x86_64
    Vendor : openSUSE
    Installed Size : 13.9 MiB
    Installed : Yes
    Status : up-to-date
    Source package : audacity-2.2.2-lp151.2.4.src
    Summary : A Multi Track Digital Audio Editor
    Description :
    Audacity is a program that manipulates digital audio wave forms.
    In addition to multitrack recording capabilities with effects, it
    imports and exports many sound file formats, including WAV, AIFF,
    AU, IRCAM, MP, and Ogg Vorbis. Wave data larger than the available
    physical memory size can be edited.

    # audacity
    audacity: symbol lookup error: audacity: undefined symbol: _ZN4FLAC7Decoder4File4initERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE
    #

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,067

    Default AW: Audacity fails to load since upgrading to Leap 15.1

    # audacity
    Do not run any gui-application as root, only as user.

    Please post:
    Code:
    zypper se -si | grep -Ei 'systemp|system-p|system_p'
    And please use Code-Tags, the small # button.

  9. #9

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    That command produces no output at all, just the prompt for the next command.

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,606

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    @tgf:

    Please use “zypper install --force audacity” to ensure that, all the required libraries have been overwritten.

    You should also check for orphaned libraries which have been pulled in from the previous installs.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •