Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Audacity fails to load since upgrading to Leap 15.1

  1. #11

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Thanks for the advice. I installed rpmorphan and ran it. It identified 206 libraries that were not being used so I removed them with zypper. At the end, zypper wanted to remove other things as well:
    Code:
    amarok amarok-lang autoyast2-installation breeze4-style kdebase4-runtime
      kdebase4-workspace-libs kdelibs4 kdelibs4-core kdepimlibs4 kio_audiocd4 kscd
      libakonadi4 libkcddb4 libkcompactdisc4 libkde4 libkdepimlibs4 libksuseinstall1
      libxfce4ui-lang libxfce4util-lang libxine2-pulse libxshmfence-devel
      libxslt1-32bit libyui-ncurses-pkg9 libyui-qt-graph9 libyui-qt-pkg9
      yast2-add-on yast2-bootloader yast2-country yast2-installation
      yast2-iscsi-client yast2-ldap yast2-mail yast2-metapackage-handler
      yast2-network yast2-nfs-client yast2-nis-client yast2-ntp-client
      yast2-online-update yast2-online-update-frontend yast2-packager
      yast2-samba-server yast2-storage-ng yast2-sudo yast2-tune yast2-update
      yast2-users yast2-vm
    I said no to that because I was unsure whether removing them would cause a problem.

    I checked to see if there were any broken dependencies with:
    Code:
    # zypper verify
    Loading repository data...
    Reading installed packages...
    
    Dependencies of all installed packages are satisfied.
    I got a message when deleting the unwanted library files that running programs might be affected by the removal, so I checked what they might be:
    Code:
     # zypper ps -s
    The following running processes use deleted files:
    
    PID   | PPID | UID  | User     | Command                             | Service
    ------+------+------+----------+-------------------------------------+--------
    2385  | 2161 | 1000 | gfreeman | xfce4-session                       |        
    2408  | 2385 | 1000 | gfreeman | xfwm4                               |        
    2423  | 2385 | 1000 | gfreeman | xfce4-panel                         |        
    2424  | 1    | 1000 | gfreeman | xfsettingsd                         |        
    2428  | 2385 | 1000 | gfreeman | xfdesktop                           |        
    2436  | 2423 | 1000 | gfreeman | wrapper-2.0                         |        
    2440  | 2385 | 1000 | gfreeman | gwenview                            |        
    2456  | 1    | 1000 | gfreeman | xfce4-power-manager                 |        
    2469  | 2423 | 1000 | gfreeman | wrapper-2.0                         |        
    2470  | 2423 | 1000 | gfreeman | wrapper-2.0                         |        
    2471  | 2423 | 1000 | gfreeman | wrapper-1.0                         |        
    2509  | 2385 | 1000 | gfreeman | polkit-gnome-authentication-agent-1 |        
    2581  | 1    | 1000 | gfreeman | xfce4-power-manager                 |        
    2589  | 2385 | 1000 | gfreeman | nm-applet                           |        
    2600  | 2385 | 1000 | gfreeman | pk-update-icon                      |        
    2623  | 2604 | 1000 | gfreeman | ibus-ui-gtk3                        |        
    2626  | 2604 | 1000 | gfreeman | ibus-extension-gtk3                 |        
    2631  | 1    | 1000 | gfreeman | ibus-x11                            |        
    2650  | 2619 | 1000 | gfreeman | python2.7                           |        
    5385  | 2423 | 1000 | gfreeman | firefox                             |        
    5444  | 5385 | 1000 | gfreeman | firefox                             |        
    5501  | 5385 | 1000 | gfreeman | firefox                             |        
    7199  | 2423 | 1000 | gfreeman | thunderbird-bin                     |        
    20223 | 5385 | 1000 | gfreeman | firefox                             |        
    22574 | 5385 | 1000 | gfreeman | firefox                             |        
    23243 | 1    | 1000 | gfreeman | orage                               |        
    23400 | 2423 | 1000 | gfreeman | wrapper-1.0                         |
    I am a bit worried that some of these seem important and I hope that they will still run after I next reboot.

    I then force loaded audacity but it still will not execute:
    Code:
    > audacity
    audacity: symbol lookup error: audacity: undefined symbol: _ZN4FLAC7Decoder4File4initERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

  2. #12

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    I don't know if this is relevant but I don't have a lot of disk space allocated to the operating system. It hasn't been a problem in the past but I had to delete a lot of stuff from /tmp to install Leap 15.1.
    Code:
    # df
    Filesystem     1K-blocks      Used Available Use% Mounted on
    devtmpfs         3656324         0   3656324   0% /dev
    tmpfs            3668360     19348   3649012   1% /dev/shm
    tmpfs            3668360      1740   3666620   1% /run
    tmpfs            3668360         0   3668360   0% /sys/fs/cgroup
    /dev/sda7       41946112  40954104    734680  99% /
    /dev/sda7       41946112  40954104    734680  99% /.snapshots
    /dev/sda7       41946112  40954104    734680  99% /var/lib/libvirt/images
    /dev/sda7       41946112  40954104    734680  99% /opt
    /dev/sda7       41946112  40954104    734680  99% /var/opt
    /dev/sda7       41946112  40954104    734680  99% /var/crash
    /dev/sda7       41946112  40954104    734680  99% /var/lib/machines
    /dev/sda7       41946112  40954104    734680  99% /boot/grub2/x86_64-efi
    /dev/sda7       41946112  40954104    734680  99% /var/spool
    /dev/sda7       41946112  40954104    734680  99% /var/lib/pgsql
    /dev/sda7       41946112  40954104    734680  99% /var/lib/mailman
    /dev/sda7       41946112  40954104    734680  99% /var/lib/mariadb
    /dev/sda7       41946112  40954104    734680  99% /var/lib/mysql
    /dev/sda7       41946112  40954104    734680  99% /var/lib/named
    /dev/sda7       41946112  40954104    734680  99% /srv
    /dev/sda7       41946112  40954104    734680  99% /var/tmp
    /dev/sda7       41946112  40954104    734680  99% /var/log
    /dev/sda7       41946112  40954104    734680  99% /tmp
    /dev/sda7       41946112  40954104    734680  99% /usr/local
    /dev/sda7       41946112  40954104    734680  99% /boot/grub2/i386-pc
    /dev/sda2          98304     63070     35234  65% /boot/efi
    /dev/sda8      723188724 153500092 569688632  22% /home
    tmpfs             733672        20    733652   1% /run/user/1000

  3. #13
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,559

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Quote Originally Posted by tgf View Post
    I don't know if this is relevant but I don't have a lot of disk space allocated to the operating system.
    It seems that, you have a Btrfs system partition.
    • The correct command is: “btrfs filesystem df /”

    Clean up the Snapper images.

    Check that, the Btrfs balance and scrub systemd jobs have been run successfully.

  4. #14

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Thanks. I have cleaned up the snapshots and the journal, recovering a fair amount of space in the root area.

    The problem with audacity remains:
    Code:
    > audacity
    audacity: symbol lookup error: audacity: undefined symbol: _ZN4FLAC7Decoder4File4initERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE

  5. #15
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: Audacity fails to load since upgrading to Leap 15.1

    Post:
    Code:
    zypper lr -d
    Code:
    zypper se -si audacity

  6. #16

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    Code:
     # zypper lr -d
    #  | Alias                     | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                      | Service
    ---+---------------------------+------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------+--------
     1 | openSUSE-Leap-15.1-1      | openSUSE-Leap-15.1-1               | Yes     | (r ) Yes  | No      |   99     | rpm-md | cd:/?devices=/dev/disk/by-id/ata-MATSHITADVD-RAM_UJ8G2_W091_054714       |        
     2 | packman.inode.at-suse     | Packman Repository                 | Yes     | (r ) Yes  | Yes     |   98     | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/                         |        
     3 | repo-debug                | Debug Repository                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/      |        
     4 | repo-debug-non-oss        | Debug Repository (Non-OSS)         | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/  |        
     5 | repo-debug-update         | Update Repository (Debug)          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.1/oss/                 |        
     6 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.1/non-oss/             |        
     7 | repo-non-oss              | Non-OSS Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/        |        
     8 | repo-oss                  | Main Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/            |        
     9 | repo-source               | Source Repository                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/     |        
    10 | repo-source-non-oss       | Source Repository (Non-OSS)        | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/ |        
    11 | repo-update               | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/                       |        
    12 | repo-update-non-oss       | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                   |        
    13 | x86_64                    | google-chrome                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64/                     |        
     # zypper se -si audacity
    Loading repository data...
    Reading installed packages...
    
    S  | Name          | Type    | Version         | Arch   | Repository     
    ---+---------------+---------+-----------------+--------+----------------
    i+ | audacity      | package | 2.2.2-lp151.2.4 | x86_64 | Main Repository
    i+ | audacity-lang | package | 2.2.2-lp151.2.4 | noarch | Main Repository
     #

  7. #17
    Join Date
    Dec 2016
    Location
    Somewhere in Italy
    Posts
    36

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    I've installed the version 2.3.2-lp151.140.1 (my DE is KDE) from Multimedia repository : http://download.opensuse.org/reposit...USE_Leap_15.1/

    Functions of program not tested ... but it starts without issues.

  8. #18

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    I have tried adding the http://download.opensuse.org/reposit...USE_Leap_15.1/ repository. When I try the command
    Code:
    zypper in audacity
    I get this choice
    Code:
     # zypper in audacity
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libSoundTouch.so.1()(64bit) needed by audacity-2.3.2-lp151.140.1.x86_64
     Solution 1: do not install audacity-2.3.2-lp151.140.1.x86_64
     Solution 2: break audacity-2.3.2-lp151.140.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    When I tried 2, audacity could not find the library libSoundTouch.so.1
    Tumbleweed has that library and I tried to load just that library but it depends on libm.so.6, and to install that would mean removing many installed packages.
    Code:
    # zypper in libSoundTouch1-2.1.2-1.5.x86_64
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: libSoundTouch1-2.1.2-1.5.x86_64 requires libm.so.6(GLIBC_2.29)(64bit), but this requirement cannot be provided
      not installable providers: glibc-2.29-7.3.x86_64[openSUSE_20190806-0]
     Solution 1: Following actions will be done:
      deinstallation of yast2-ruby-bindings-4.1.4-lp151.1.1.x86_64
      deinstallation of yast2-network-4.1.51-lp151.2.3.1.noarch
      deinstallation of yast2-country-data-4.1.13-lp151.2.3.1.x86_64
      deinstallation of yast2-proxy-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-printer-4.1.1-lp151.1.1.x86_64
      deinstallation of yast2-pam-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-online-update-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-nis-client-4.1.1-lp151.1.1.x86_64
      deinstallation of yast2-nfs-client-4.1.5-lp151.1.1.noarch
      deinstallation of yast2-metapackage-handler-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-mail-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-journal-4.1.5-lp151.1.1.noarch
      deinstallation of yast2-iscsi-client-4.1.7-lp151.1.1.noarch
      deinstallation of yast2-hardware-detection-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-firewall-4.1.12-lp151.1.1.noarch
      deinstallation of yast2-auth-client-4.1.1-lp151.1.1.noarch
      deinstallation of yast2-apparmor-4.1.7-lp151.1.1.noarch
      deinstallation of autoyast2-installation-4.1.6-lp151.1.1.noarch
      deinstallation of yast2-samba-client-4.1.2-lp151.1.1.noarch
      deinstallation of yast2-samba-server-4.1.3-lp151.1.1.noarch
      deinstallation of yast2-scanner-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-security-4.1.2-lp151.1.1.noarch
      deinstallation of yast2-services-manager-4.1.14-lp151.1.1.noarch
      deinstallation of yast2-slp-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-snapper-4.1.2-lp151.1.1.x86_64
      deinstallation of yast2-sound-4.1.1-lp151.1.9.x86_64
      deinstallation of yast2-sudo-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-sysconfig-4.1.2-lp151.1.1.noarch
      deinstallation of yast2-transfer-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-tune-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-vm-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-vpn-4.1.0-lp151.1.1.noarch
      deinstallation of yast2-storage-ng-4.1.85-lp151.2.6.1.x86_64
      deinstallation of yast2-update-4.1.10-lp151.2.3.1.x86_64
      deinstallation of yast2-users-4.1.13-lp151.2.3.1.x86_64
      deinstallation of libksuseinstall1-4.14.38-lp151.8.21.x86_64
      deinstallation of yast2-ldap-4.1.0-lp151.1.1.x86_64
      deinstallation of yast2-control-center-4.1.7-lp151.1.2.x86_64
      deinstallation of yast2-online-update-frontend-4.1.0-lp151.1.1.noarch
      deinstallation of kdepimlibs4-4.14.10-6.6.x86_64
      deinstallation of libkde4-4.14.38-lp151.8.21.x86_64
      deinstallation of yast2-control-center-qt-4.1.7-lp151.1.2.x86_64
      deinstallation of kscd-17.08.3-lp151.2.4.x86_64
      deinstallation of libkcompactdisc4-16.08.3-lp151.2.3.x86_64
      deinstallation of libkcddb4-16.08.3-lp151.2.3.x86_64
      deinstallation of libakonadi4-4.14.10-lp151.4.3.x86_64
      deinstallation of kio_audiocd4-16.08.3-lp151.2.3.x86_64
      deinstallation of kdelibs4-core-4.14.38-lp151.8.21.x86_64
      deinstallation of kdelibs4-4.14.38-lp151.8.21.x86_64
      deinstallation of kdebase4-workspace-libs-4.11.22-lp151.9.5.x86_64
      deinstallation of kdebase4-runtime-17.08.3-lp151.6.61.x86_64
      deinstallation of breeze4-style-5.12.8-lp151.1.1.x86_64
      deinstallation of amarok-2.9.0-lp151.3.5.x86_64
      deinstallation of libkdepimlibs4-4.14.10-lp151.4.3.x86_64
     Solution 2: Following actions will be done:
      deinstallation of ruby2.5-2.5.5-lp151.4.3.1.x86_64
      deinstallation of ruby2.5-stdlib-2.5.5-lp151.4.3.1.x86_64
      deinstallation of ruby2.5-rubygem-simpleidn-0.0.9-lp151.2.1.x86_64
      deinstallation of ruby2.5-rubygem-ruby-dbus-0.14.0-lp151.2.1.x86_64
      deinstallation of ruby2.5-rubygem-ruby-augeas-0.5.0-lp151.2.2.x86_64
      deinstallation of ruby2.5-rubygem-gem2rpm-0.10.1-lp151.4.43.x86_64
      deinstallation of ruby2.5-rubygem-fast_gettext-1.6.0-lp151.2.1.x86_64
      deinstallation of ruby2.5-rubygem-cheetah-0.5.0-lp151.2.1.x86_64
      deinstallation of ruby2.5-rubygem-cfa_grub2-1.0.1-lp151.1.1.x86_64
      deinstallation of ruby2.5-rubygem-cfa-0.7.0-lp151.1.1.x86_64
      deinstallation of ruby2.5-rubygem-abstract_method-1.2.1-lp151.2.1.x86_64
     Solution 3: do not install libSoundTouch1-2.1.2-1.5.x86_64
     Solution 4: break libSoundTouch1-2.1.2-1.5.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c] (c): 4
    Choosing option 2 means that audacity still won't work:
    Code:
    > audacity
    audacity: /lib64/libm.so.6: version `GLIBC_2.29' not found (required by /usr/lib64/libSoundTouch.so.1)

  9. #19
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: Audacity fails to load since upgrading to Leap 15.1

    So is this the first time you install packages from another openSUSE Version?

    Please do not do, it will break your system.

    I think, multimedia:apps is build against multimedia:libs, but that is also not a good choice for you, that can brak your multimedia stuff from Packman.......
    Last edited by Sauerland; 10-Aug-2019 at 05:07.

  10. #20
    Join Date
    Dec 2016
    Location
    Somewhere in Italy
    Posts
    36

    Default Re: Audacity fails to load since upgrading to Leap 15.1

    This is my approach when I install a new release of openSuse :
    - fresh installation using base repositories with new & clean /home. No upgrade from previous version
    - after first reboot, I add packman repository with priority 95 and switch system packages
    - after I add the following multimedia repository :
    - LibDVDcss http://opensuse-guide.org/repo/openSUSE_Leap_15.1/
    - MultimediaApps http://download.opensuse.org/reposit...USE_Leap_15.1/
    - MultimediaLibs http://download.opensuse.org/reposit...USE_Leap_15.1/
    - MultimediaPhoto http://download.opensuse.org/reposit...USE_Leap_15.1/
    - after I install multimedia sw (i.e. Audacity)
    And I confirm that Audacity works

    In any case I don't mix repos of different version ...

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •