Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Driver Nvidia and Kernel5.1 dont work

  1. #1

    Default Driver Nvidia and Kernel5.1 dont work

    The Nvidia Drivers don't work with the new Kernel5.1, even using hard way doesn't work, I got screwed because with the consecutive 5.1.2 update and the next day 5.1.3 it uninstalled the last 5.0 Kernel that worked, now I'm using generic mesa drivers with a resolution that's not right ... but acceptable
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,640
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by enziosavio View Post
    The Nvidia Drivers don't work with the new Kernel5.1, even using hard way doesn't work, I got screwed because with the consecutive 5.1.2 update and the next day 5.1.3 it uninstalled the last 5.0 Kernel that worked, now I'm using generic mesa drivers with a resolution that's not right ... but acceptable
    Hi
    The 430.14 should work...
    https://download.nvidia.com/XFree86/Linux-x86_64/
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    I'm not sure that they support my Nvidia Geforce 610, I try them anyway

    Post Edid
    Nothing to do tells me that my card does not support it and the installation does not even start
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,480
    Blog Entries
    3

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by enziosavio View Post
    ... because with the consecutive 5.1.2 update and the next day 5.1.3 it uninstalled the last 5.0 Kernel that worked, ...
    That's why I recommend using
    Code:
    multiversion.kernels = oldest,latest,latest-1,running
    in "/etc/zypp.conf". Just insert "oldest," in the list of the kernels to keep.

    I do that in Tumbleweed. It keeps an older kernel around. Until recently, that was keeping a 4.20 kernel available, though I never used it. When the 5.1 kernel landed, I deleted the 4.20 kernel (with Yast and the "Versions" tab). That left a 5.0 kernel as the oldest. And that won't go away until I manually remove it. However, 5.1 is working here (I don't have a Nvidia card).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,640
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by enziosavio View Post
    I'm not sure that they support my Nvidia Geforce 610, I try them anyway

    Post Edid
    Nothing to do tells me that my card does not support it and the installation does not even start
    Hi
    Ahh I tested a 640 here as well... (Also have a GT8800 running the 340.107 patched driver on 5.1.3)

    So you need the 390.116 driver for a 610, plus needed patching to create a custom run file...

    See the following for a patch link and how to apply the patch: https://lists.opensuse.org/opensuse-.../msg00168.html
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Putting a lock on the kernel is also generally a good option here until driver updates fix issue.

  7. #7
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,102

    Default Re: Driver Nvidia and Kernel5.1 dont work

    I see that:

    https://download.nvidia.com/opensuse/tumbleweed/x86_64/

    has been updated this afternoon.

  8. #8

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Problem solved with today's update, perfect
    ------------------------------------
    Correct me if I'm wrong .
    ------------------------------------

  9. #9

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Ahh I tested a 640 here as well... (Also have a GT8800 running the 340.107 patched driver on 5.1.3)
    Hi
    which patch did you use for this 340.107? I had no luck with those I found.

    https://github.com/LibreELEC/LibreEL...legacy/patches


    GeForce 8800 GTX, openSUSE Tumbleweed x86_64

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,640
    Blog Entries
    15

    Default Re: Driver Nvidia and Kernel5.1 dont work

    Quote Originally Posted by gaedcke View Post
    Hi
    which patch did you use for this 340.107? I had no luck with those I found.

    https://github.com/LibreELEC/LibreEL...legacy/patches


    GeForce 8800 GTX, openSUSE Tumbleweed x86_64
    Hi
    Here you go;
    https://susepaste.org/view/raw/7dc9015e
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •