Results 1 to 2 of 2

Thread: OpenSuse 15.1 DHCP reservation funktioniert nicht mehr :(

Hybrid View

  1. #1

    Exclamation OpenSuse 15.1 DHCP reservation funktioniert nicht mehr :(

    Hi,

    habe gerade angefangen Opensuse 15.1 und SLES 15.1 zu deployen und dabei ist mir etwas komisches aufgefallen. Wir haben einen Windows 2012 R2 DHCP server. Dort erstellen wir für jede VM eine DHCP Reservierung und booten dann über PXE um das OS Deployment zu automatisiern. Wir benutzen hierfür Foreman (genauer gesagt Katello). Beim PXE Boot bekommt der client noch die reservierte IP aber kurz darauf sendet der client wieder eine DHCP anfrage und bekommt eine ganz andere IP. In den Leases auf dem DHCP server steht dann auch bei der IP eine ganz komische Unique ID:


    https://pasteboard.co/IqmFufg.png


    Der Fehler tritt nur bei SLES 15.1 und OpenSuSE 15.1 auf. Hier hat sich scheinbar irgendwas geändert. Aber was???

  2. #2
    Join Date
    Nov 2015
    Location
    Bremen
    Posts
    27

    Default AW: OpenSuse 15.1 DHCP reservation funktioniert nicht mehr :(

    Hallo tpzvega,

    vor zwei Wochen wollte ich in der Firma in der ich arbeite einen Laptop mit Leap 15.1 einrichten, damit meine Kollegen mal ein anderes System kennen lernen können.
    Ich bin an der Kontaktaufnahme zu einem Windows Server 2012r2 als AD-DC gescheitert!
    Dies ist also nur ein Problem im Produktivbereich - ich glaube nicht das eine Privatperson zu hause ein Windows Server >= 2012r2 hat!
    Und betroffen sind nur 'neuere' Linuxe mit Windows Server >= 2012r2 - Ubuntu 16.04.5 LTS ist z.B. nicht betroffen!
    Alle Linuxsystem sind nicht in die Windowsdomäne integriert worden.

    Alles läuft über diesen Server, bis auf DHCP, das läuft auf einen Linuxserver!
    Und darum hatte ich in diesen Bereich bei der Einrichtung von Leap 15.1 noch keine Probleme!

    Probleme gab es mit dem Leap 15.1 und dolphin die Freigabeliste der Netzwerkressourcen des Windowsserver zu suchen und zu sehen.

    In dolphin ging mit Leap 15.1 nicht: smb://, smb://windowsdomäne und smb://windowsserver!
    In dophin funktionierte mit Leap 15.1: smb://linuxarbeitsgruppe und smb://linuxserver! (ich vermute Protokoll NT1, muss mal SMB1 ausprobieren)

    Ich habe dann im Internet gesucht und folgenden Dialog gefunden, indem von einer Rückfall-Methode gesprochen wird.
    Siehe unter: "https://phabricator.kde.org/D16299"
    Und auch hier: "https://www.samba.org/samba/docs/current/man-html/smb.conf.5.html#DIRECTORYMASK", die Abschnitte mit "client min protocol (G)" und "client max protocol (G)"

    In der smb.conf auf dem Leap-Rechner habe ich dann in der [global] Sektion folgende Zeilen hinzugefügt:

    client min protocol = NT1
    client max protocol = SMB2 #(oder SMB3)

    Nach einem Neustart kann ich jetzt die Verzeichnisfreigaben vom Windowsserver auf dem Leap 15.1 sehen und verbinden.
    Es gibt noch Probleme mit den Freigaben der Kombilaserdruckern/Scannern und den Plottern.

    Aber vielleicht löst das auch Dein Problem mit dem DHCP!

    Probiere es mal aus und berichte

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •