Results 1 to 2 of 2

Thread: TP-Link TL WN823N (Realtek rtl8192eu) funtkioniert nicht

  1. #1

    Default TP-Link TL WN823N (Realtek rtl8192eu) funtkioniert nicht

    Hallo,
    Ich habe den TP-Link TL WN823Nv2. Laut Google läuft dieser mit den RTL8192EU Treibern.
    Leider funktioniert dieser nicht. Ich habe kernel-firmware installiert.

    Also wollte ich die Treiber von TP-Link selbst installieren.
    Für Linux gibt es nur die Source files.
    Also habe ich diese nach Anleitung kompiliert.
    Bei
    Code:
    sudo make
    kommt jedoch schon folgender Fehler:

    Code:
    "******************************************"
    "NO SKRC,we will use default KSRC"
    "******************************************"
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.14-lp150.12.64-default/build M=/home/pfad/zu/TL-WN823NEU_V2_160315_Linux/TL-WN823N(EU)_V2_160315_Linux/Driver  modules
    /bin/sh: -c: Zeile 0: Syntaxfehler beim unerwarteten Wort `('
    /bin/sh: -c: Zeile 0: `make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.14-lp150.12.64-default/build M=/home/pfad/zu//TL-WN823NEU_V2_160315_Linux/TL-WN823N(EU)_V2_160315_Linux/Driver  modules'
    Bei
    Code:
    lsusb
    wird mir folgendes gezeigt:
    Code:
    Bus 001 Device 006: ID 2357:0109
    (Es ist das einzige Gerät bei dem kein Name angezeigt wird)

    Hat jemand noch eine idee?
    Am liebsten würde ich es ohne selbst kompilierte Treiber lösen. Wenn es nicht anders geht kompiliere ich auch gerne die Treiber selbst. Aber auch das hatte ja Schwierigkeiten gemacht.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: TP-Link TL WN823N (Realtek rtl8192eu) funtkioniert nicht

    1. Da du anscheinend noch den vorletzten Kernel benutzt (4.12.14-lp150.12.64-default), solltest du erst mal per Kabel updaten.

    2. Dann binde mein Repo ein:
    Code:
    zypper ar -f https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.0_Update Sauerland-Update
    3. Dann installiere:
    Code:
    zypper in rtl8xxxu-kmp-default
    4. Rechner herunterfahren, Kabel abziehen, Rechner neu starten und Netzwerk einrichten.

    Wenn es funktioniert sollte es bei einem Kernel Update auch immer ein Update des Treibers in meinem Repo geben und angezeigt werden.
    Last edited by Sauerland; 29-Jul-2019 at 08:28.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •